Sign in with
Sign up | Sign in
Your question

Crysis 3 multiplayer connection issues

Last response: in Video Games
Share
February 23, 2013 1:00:03 PM

Hi Crysis 3 players

I was able to play yesterday but today I always get "connection to the crysis 3 server has been lost or cannot be established" after multiplayer login.

Anybody else having the same problem?

Firewalls are already disabled.
While attempting to connect, I see the ff. in the lower left of the multiplayer screen:
[ONLINE][PATCH_A_2XP].

I am able to access this [http://editorial.gos.ea.com/Crysis/3/network_test/test....]
I got it from this [http://www.mycrysis.com/forums/topic59915]

The flushdns did not work.

How do you debug this? Is there a problem in the servers or is it on my end?

Thanks

=)
February 23, 2013 7:28:08 PM

bcarb said:
Hi Crysis 3 players

I was able to play yesterday but today I always get "connection to the crysis 3 server has been lost or cannot be established" after multiplayer login.

Anybody else having the same problem?

Firewalls are already disabled.
While attempting to connect, I see the ff. in the lower left of the multiplayer screen:
[ONLINE][PATCH_A_2XP].

I am able to access this [http://editorial.gos.ea.com/Crysis/3/network_test/test....]
I got it from this [http://www.mycrysis.com/forums/topic59915]

The flushdns did not work.

How do you debug this? Is there a problem in the servers or is it on my end?

Thanks

=)

im not sure if youre saying you have the same issue??? but also was having plenty games without connection problems yesturday and today, and then EVERY server i tried to join and play on lasted for about 2min of game time then i either got kicked, or it said connection lost... this is BS!
m
0
l
February 23, 2013 10:38:09 PM

Mine does not reach the part where you see the "join" and "quick match" in the menu.

Are others able to play without problems?
m
0
l
Related resources
February 23, 2013 11:24:10 PM

yesterday arvo i was able to join and play full games,
last night however and still ongoing today, i am unable to play through a game of multiplayer, connection always drops.

it has troubles at different points during connection to server, sometimes i cant get to server, others i join a side but game doesnt load, other times i get into game, but short time later its dropped.

any solutions would b great
m
0
l
February 24, 2013 9:53:51 AM

ok after i posted this my i had 1 or 2 games so im pretty sure its not my side...
In multiplayer menu, make sure it says ONLINE PATCH A in the bottom left hand corner... other than that i really dont know.. let us know if you are able to play or were able to have a game or 2..
also where are you from? and do you normally have connection issue?
i know there are a few connection issues but i never heard of it being that you cant see the join match or quick match
m
0
l
February 24, 2013 11:45:16 AM

Philippines. I was able to play again for about 2 hours straight then it happened again (can't login). Don't have connection problems, only for this multiplayer. Probably not on my end also. It's just sad that it is very hard to connect.
m
0
l
February 24, 2013 2:52:01 PM

This is really annoying... now whats happening is that i will be gaming for 2-3 games and it will crash with black screen and whit box saying
"DXGI ERROR DEVICE REMOVED"...

It says that my nvidia driver 314.07 was not working, or failed (or somethng like that). i stop/end the program and it just says that it has successfully recovered???

m
0
l
February 24, 2013 4:41:52 PM

Ukraine and vpn from Amazon - the same problems!
m
0
l
February 26, 2013 3:47:48 AM

Australia, and still same issue, although i can get into MP menu screen just fine,
just cannot hold a game, occasionally i can connect to one, few seconds ingame and it boots me, saying connection error, etc...

same as wrekcreation i have latest nvidia drivers 314.07
m
0
l
February 27, 2013 2:02:20 PM

update:
I currently have v1.0.0.2000 [PATCH_B]

For a split second, I also see "An error has occurred" in the green vertical bar before it shows the red attention: error message "connection to the crysis 3 server has been lost or cannot be established". Anybody know where to check next? Thanks!

m
0
l
March 1, 2013 12:34:29 AM

I have the same problem(the connection to crysis 3 has been lost or cannot established), I was thinking before my router or the connection with my internet provider but no, I buy a new router and call to my internet provider and they say everything its ok. I start feel frustrated.
m
0
l
June 1, 2013 5:38:03 PM

bcarb said:
Hi Crysis 3 players

I was able to play yesterday but today I always get "connection to the crysis 3 server has been lost or cannot be established" after multiplayer login.

Anybody else having the same problem?

Firewalls are already disabled.
While attempting to connect, I see the ff. in the lower left of the multiplayer screen:
[ONLINE][PATCH_A_2XP].

I am able to access this [http://editorial.gos.ea.com/Crysis/3/network_test/test....]
I got it from this [http://www.mycrysis.com/forums/topic59915]

The flushdns did not work.

How do you debug this? Is there a problem in the servers or is it on my end?

Thanks

=)


m
0
l
June 1, 2013 5:40:42 PM

Same here. WTF? Been trying for two days to get onto 'Join Match' and no servers come up!
m
0
l
June 4, 2014 2:59:28 AM

bcarb said:
Hi Crysis 3 players

I was able to play yesterday but today I always get "connection to the crysis 3 server has been lost or cannot be established" after multiplayer login.

Anybody else having the same problem?

Firewalls are already disabled.
While attempting to connect, I see the ff. in the lower left of the multiplayer screen:
[ONLINE][PATCH_A_2XP].

I am able to access this [http://editorial.gos.ea.com/Crysis/3/network_test/test....]
I got it from this [http://www.mycrysis.com/forums/topic59915]

The flushdns did not work.

How do you debug this? Is there a problem in the servers or is it on my end?

Thanks

=)


m
0
l
June 4, 2014 3:02:39 AM

10200916,0,1051528 said:
Hi Crysis 3 players

I was able to play yesterday but today I always get "connection to the crysis 3 server has been lost or cannot be established" after multiplayer login.

Anybody else having the same problem?

yes and i fix this problem !!!
hi guys i found a way to fix this prob..
if you use origin you can go game location >>
1> x:\Program Files (x86)\Origin Games\Crysis 3
2>shift,delete the (__Installer , Bin32 , Patch , support , system.cfg and all GDFBinary.dll) folder.
3> go to this addres C:\Users\ ............. \Saved Games and Shift,delete Crysis3
4> go to run typ %temp% and Shift,delet all fils
5> now go to origin, push download button

attention!!!
remember dont' stop download

i hop that works for evry one who has this problem
PROUD EAGLEĀ²5
m
0
l
!