Sign in with
Sign up | Sign in
Your question
Solved

Bad performance in Sleeping Dogs

Last response: in Video Games
Share
February 24, 2013 4:22:31 PM

Hey guys, I am getting bad fps in Sleeping Dogs as well as very noticeable drops to sometimes even 25fps for 1-2 seconds. My average benchmarking is around 37 fps but my system runs games like BF3, The Witcher 2, Crysis 2, at full ultra and over 100fps never dropping below. I am running a Crossfire setup so is my problem the lack of Xfire support in Sleeping Dogs? Thanks for the help!

My specs:
ASRock 990FX Professional Fatal1ty Mobo
FX-8350@4.4ghz Noctua NH-14 Cpu cooler
8GB Patriot Viper 3 1866mhz (2x4GB)
2xGigabyte 7850 2GB DDR5 both overclocked to 1ghz core, 1400mhz mem clock
XFX 750w Pro Core Edition 80plus bronze
February 24, 2013 9:05:46 PM

What do you have in-game AA and ambient occlusion set to? What are your shadow and shadow-resolution settings at?
m
0
l
February 24, 2013 10:41:14 PM

Extreme AA, ambient occlusion is on low. Shadow res is set to high as well.
m
0
l
Related resources
February 24, 2013 11:02:40 PM

Turn your AA setting down. With Sleeping Dogs the extreme AA preset uses an anti aliasing method called supersampling. Supersampling is a ludicrously demanding AA method that effectively cuts your framerate in half because supersampling will actually render each pixel twice to smooth out jagged edges. It is the best looking AA option, but it is the most demanding. If you aren't happy with 37FPS, you'll have to turn your AA down to the medium or low setting.
m
0
l
February 24, 2013 11:09:19 PM

I was running at 49fps average with 1 card before though. Also, I play games with much higher end graphics over 100fps, why would this game bring down my fps? It doesn't look nearly as good or crisp as BF3 or Crysis.
m
0
l

Best solution

February 24, 2013 11:17:29 PM

Sleeping Dogs isn't a very well optimized game, so it is a bit more demanding than it should be considering how the game looks. That said, you seem to have some Crossfire issues with this game if you are getting negative scaling. Make sure you have the latest Catalyst Drivers, and Catalyst Application Profiles, if you don't have the CAP for Sleeping Dogs, Crossfire won't work.

If that doesn't fix it, there might be some kind of driver or Crossfire related issue that AMD or the game developer will have to fix on their end. In which case, you may simply have to turn Crossfire off and run the game with a single card. This is one of the big drawbacks to multiple GPU configurations, not every game will work properly with those configs, and sometimes you will have to fall back to a single card to get optimal performance.
Share
February 24, 2013 11:49:41 PM

Best answer selected by chrisafp07.
m
0
l
February 24, 2013 11:49:43 PM

Ok, thanks for your reply, most games I've played seem to do well with Crossfire, this is the first one I've encountered that isn't well optimized. Thanks for your answer. Appreciate the insight.
m
0
l
February 25, 2013 2:07:04 AM

chrisafp07 said:
I was running at 49fps average with 1 card before though. Also, I play games with much higher end graphics over 100fps, why would this game bring down my fps? It doesn't look nearly as good or crisp as BF3 or Crysis.


The quality of the graphics means a lot less than A. the optimization of the game and B. what processes you are forcing it to perform. The Extreme AA in Sleeping Dogs is really damned demanding. Lower that to high and you should see immediate framerate increase.
m
0
l
!