Sign in with
Sign up | Sign in
Your question
Solved

Windows 8 immediately restarts after sleep or shutdown

Last response: in Windows 8
Share
November 4, 2012 7:26:01 AM

Hello,
When I sleep or hibernate windows 8, my machine immediately restarts. WOL is disabled.
It works fine in XP.
Hardware is Asus A8v, dual-core AMD64 4200+ (about 7 years old).
November 4, 2012 7:49:05 AM

Wol is for waking up the computer via the network card.
In any case its likely that the Apci setting of the bios are not set right, maybe windows 8 supports more features.
I do know that most of the time when you shut it down it goes into hibernation mode. where as it saves the state of the Os and all running programs at the time within it to a temporary file to the HD. Ie :S4 mode.

S3 : Mode powers down the system and all of the fans,cpu,drives,cards. But instead of saving a snapshot of the OS running and all of the running programs inside to the HD as a temporary file it keeps it all in the main system memory.that is the only thing provided with power as memory is volatile/ meaning if power is lost or a small interruption to the power happens, there is a high chance of data corruption.



m
0
l
November 14, 2012 9:20:17 AM

I am having exactly the same issue with my Asus A8V-VM board AMD Processor and Windows 8 if this helps... I'm getting a bit fed up with not being able to find a solution as I have just built it into a HTPC setup.
m
0
l
Related resources
a b * Windows 8
November 14, 2012 2:02:44 PM

check
powercfg.exe /lastwake
see if the system indicated what event woke the computer
m
0
l
November 14, 2012 7:25:17 PM

Yep, I had a look at that, but it was pretty unhelpful, I tried looking at the logfile as well, but didn't really understand what I was looking at :-(
m
0
l
a b * Windows 8
November 14, 2012 8:04:02 PM

if no wake event is listed then maybe it is refusing to sleep. that is, you request sleep, the system tells the drivers to sleep, one tells the system not to sleep. This would happen if you had a shared multi media device. Last time I had this it was caused by
the windows media center I installed as a free install with windows 8 pro.
powercfg.exe /energy and look at the energy-report.html file it generates in your system32 directory. It should indicated what program countermanded the sleep request.
m
0
l

Best solution

November 16, 2012 6:46:13 AM

Fixed it! The issue was with the USB HIDs - they all had the allow device to wake up the computer option ticked, disabled and it sleeps... joy!

I also had an issue with the thing forgetting the network connection (ethernet) when waking up, this was solved by un ticking the allow windows to switch off to save power... no tyhat is good too :-)

Thanks Johnbl, you got me looking in the right places, cheers!
Share
November 24, 2012 3:25:37 PM

This was the solution for me as well - thanks!

However, it was not the generic USB devices which were causing the problem but the keyboard and mouse - both of which were set to allow them to wake the computer (I am using USB keyboard and mouse although the motherboard supports PS2 connections).
m
0
l
November 24, 2012 3:27:14 PM

That also fixed it for me - Thanks!

My issue was not with generic USB devices but with the keyboard and mouse as I am using USB ones rather than the PS2 ones which the motherboard supports.
m
0
l
November 24, 2012 3:28:36 PM

Best answer selected by Martin_W.
m
0
l
December 27, 2012 5:22:46 AM

I'm so sorry for reviving this thread :(  but even after reading the answers I do not know how to disable the settings that you guys talked about, I'm fairly new to computers and my windows 8 is doing exactly the same thing.

Could someone kindly directs me to the right place for disabling these settings so that my computer doesn't wake right after sleep?

Thank you so much and once again very sorry for reviving this thread.
m
0
l
January 6, 2013 9:04:50 AM

yamko said:
I'm so sorry for reviving this thread :(  but even after reading the answers I do not know how to disable the settings that you guys talked about, I'm fairly new to computers and my windows 8 is doing exactly the same thing.

Could someone kindly directs me to the right place for disabling these settings so that my computer doesn't wake right after sleep?

Thank you so much and once again very sorry for reviving this thread.


These settings you have to change in the bios. Where they are depends on your motherboard, just look aroud!
m
0
l
June 22, 2013 9:18:56 AM

guybatt234 said:
yamko said:
I'm so sorry for reviving this thread :(  but even after reading the answers I do not know how to disable the settings that you guys talked about, I'm fairly new to computers and my windows 8 is doing exactly the same thing.

Could someone kindly directs me to the right place for disabling these settings so that my computer doesn't wake right after sleep?

Thank you so much and once again very sorry for reviving this thread.


These settings you have to change in the bios. Where they are depends on your motherboard, just look aroud!


Quite another solution worked well in my case with a MB ASUS F2A85-M LE and a AMD A8-5600K where the BIOS (after testing it out) was not at the origin of the problems.

The computer worked flawlessly since I built it three months ago. Then two weeks ago I put in a Samsung SSD Pro 128GB giving a fantastic boost to the machine. I suppose I did something wrong because after having used the Data Migration program the problems started, the sleep function which I used very much didn't work anymore. Windows 8 restarted immediately after the command. Fortunately the shutdown still worked normally.

I started fiddling about with the Bios settings from the motherboard for hours, but that didn’t solve the problem. I installed another HDD, this time with Ubuntu and this operating system worked well, the functioning suspend function showed that the Bios was surely not the problem.

After two weeks of trying out almost all tips and tricks I found on the internet on this subject the problem was finally solved by intuition and not by ratio. I disconnected the LAN connector from the computer before pressing the sleep button and presto the machine went to sleep. In my opinion this was where I had to continue looking for a solution.
For some reasons or another the 'Turn sharing On or Off' in 'Settings\Network' or 'Control Panel\Network and Internet\Network Connections' solved my problem when it was turned to Off. It all works again as a charm.
m
0
l
!