Sign in with
Sign up | Sign in
Your question

Assassin's Creed III laggy after 1.03 Update

Tags:
  • PC gaming
  • Video Games
Last response: in Video Games
Share
February 28, 2013 6:42:02 PM

Hello,

Recently I have acquired Assassin's Creed III, and I had quite a good time playing it. I could max it out flawlessly on my i5 2500 and my GTX 460 1 GB with at least 40 FPS, with everything set to Very High, even the anti aliasing. But two days ago I have purchased the Tyranny of King Washington DLC and had to update my game in order to run it. So yeah, I installed 1.03, and got a weird bug with the voice dialogues, which I just got fixed. But now, my game is really laggy (playable, but annoying) and it doesn't seem to go away even when I turn down the Graphic options. How can I fix this?

EDIT: This lag starts right after Haytham steps in Boston. The Ship missions ran just fine.

More about : assassin creed iii laggy update

February 28, 2013 6:54:18 PM

C0sta said:
Hello,

Recently I have acquired Assassin's Creed III, and I had quite a good time playing it. I could max it out flawlessly on my i5 2500 and my GTX 460 1 GB with at least 40 FPS, with everything set to Very High, even the anti aliasing. But two days ago I have purchased the Tyranny of King Washington DLC and had to update my game in order to run it. So yeah, I installed 1.03, and got a weird bug with the voice dialogues, which I just got fixed. But now, my game is really laggy (playable, but annoying) and it doesn't seem to go away even when I turn down the Graphic options. How can I fix this?

EDIT: This lag starts right after Haytham steps in Boston. The Ship missions ran just fine.

EDIT²: I also tried to play the DLC and it lags even worse than the original game :??:  I feel like I just threw my cash in the garbage by buying this game...
m
0
l
February 28, 2013 7:08:09 PM

UPDATE: GOT IT SORTED OUT!!!!!!! If any of you lads are having the same problem, follow these steps:

-Go to your Documents folder
-Search for "Assassin3.ini"
-Click it with the right mouse button, Open with..., and then Notepad
-Search for the line "Vsync"
-It'll be set to 1, erase the 1 and put 0

It should run smoothly once again :) 
m
0
l
Related resources
February 28, 2013 7:51:30 PM

UPDATE: GOT IT SORTED OUT!!!!!!! If any of you lads are having the same problem, follow these steps:

-Go to your Documents folder
-Search for "Assassin3.ini"
-Click it with the right mouse button, Open with..., and then Notepad
-Search for the line "Vsync"
-It'll be set to 1, erase the 1 and put 0

It should run smoothly once again :) 
m
0
l
February 28, 2013 10:21:11 PM

UPDATE: GOT IT SORTED OUT!!!!!!! If any of you lads are having the same problem, follow these steps:

-Go to your Documents folder
-Search for "Assassin3.ini"
-Click it with the right mouse button, Open with..., and then Notepad
-Search for the line "Vsync"
-It'll be set to 1, erase the 1 and put 0

It should run smoothly once again :) 
m
0
l
!