Sign in with
Sign up | Sign in
Your question
Solved

Crysis 3 lag

Last response: in Video Games
Share
March 1, 2013 8:45:03 AM

I just bought Crysis 3. I have upgraded to the latest drivers. I have two gtx 670 sli, and an intel i7 3770k, and 16 gigabytes of ram. The CPU and GPUs are all overclocked. So I should be achieving 60+ fps right? Well I'm only getting 25 - 30 fps on very high settings, and it is pretty much unplayable for me. Help, I don't know what the problem is. I am on 1080p

More about : crysis lag

March 1, 2013 9:17:31 AM

Did you make sure that you enabled SLI in the Nvidia control panel? I know it's kind of a dumb question to ask, but you'd be surprised at the amount of people I've come across that have dual-GPU setups, and never realized they had to "enable" it :p 

Other than that, make sure you have the latest drivers!!! Newest Nvidia drivers increase Crysis 3 SLI performance by up to 60%!

Other than that, try turning down some performance killers as well. For AA, try sticking on FXAA, Nvidia's AA solution. Decent AA, while using minimal vRAM, and not as hard on performance.

And finally, vRAM. Crysis 3 on ultimate max settings (with 1080p) WILL exceed 2GB of vRAM. I'm going to just assume that you're running the 2GB cards, so yea, you will probably need to turn down that AA, maybe a couple other things. If your exceeding your max vRAM, you can start to get some lag.
m
0
l
March 1, 2013 9:36:32 AM

nadim615 said:
Did you make sure that you enabled SLI in the Nvidia control panel? I know it's kind of a dumb question to ask, but you'd be surprised at the amount of people I've come across that have dual-GPU setups, and never realized they had to "enable" it :p 

Other than that, make sure you have the latest drivers!!! Newest Nvidia drivers increase Crysis 3 SLI performance by up to 60%!

Other than that, try turning down some performance killers as well. For AA, try sticking on FXAA, Nvidia's AA solution. Decent AA, while using minimal vRAM, and not as hard on performance.

And finally, vRAM. Crysis 3 on ultimate max settings (with 1080p) WILL exceed 2GB of vRAM. I'm going to just assume that you're running the 2GB cards, so yea, you will probably need to turn down that AA, maybe a couple other things. If your exceeding your max vRAM, you can start to get some lag.

I do have sli enabled. I actually have the 4 gb Evga sc models, so that should be plenty of vram. For now, I just turned off the AA, and its running pretty smoovely. But I still think that I can achieve best settings with a goof frame rate.
m
0
l
Related resources
Can't find your answer ? Ask !

Best solution

March 1, 2013 9:54:14 AM

itchytoo said:
I do have sli enabled. I actually have the 4 gb Evga sc models, so that should be plenty of vram. For now, I just turned off the AA, and its running pretty smoovely. But I still think that I can achieve best settings with a goof frame rate.


Eh, I'd have a look at the benchmarks. Even SLI 680's are barely pulling off a decent framerate with max settings.. AA is the real killer. TBH, Very High textures + 1080p + FXAA already looks damn good. Turning on MSAA or TXAA barely adds any extras, and is only a real frame killer. According to benchmarks, 670's cant handle everything at max at 1080p with a steady 60+ fps. So what you've got is as good as you're gonna get :) 
Share
March 1, 2013 10:10:19 AM

Best answer selected by itchytoo.
m
0
l
March 1, 2013 10:13:34 AM

nadim615 said:
Eh, I'd have a look at the benchmarks. Even SLI 680's are barely pulling off a decent framerate with max settings.. AA is the real killer. TBH, Very High textures + 1080p + FXAA already looks damn good. Turning on MSAA or TXAA barely adds any extras, and is only a real frame killer. According to benchmarks, 670's cant handle everything at max at 1080p with a steady 60+ fps. So what you've got is as good as you're gonna get :) 

Yeah, I've downloaded GeForce experience, and optimized all of the settings. It's running very smoothely, and it still looks REALLY good. :wahoo:  guess Crysis 3 really does "melt PCs"
m
0
l
March 1, 2013 6:53:43 PM

itchytoo said:
Yeah, I've downloaded GeForce experience, and optimized all of the settings. It's running very smoothely, and it still looks REALLY good. :wahoo:  guess Crysis 3 really does "melt PCs"


Yep :) 
m
0
l
July 22, 2013 10:59:10 AM

i was looking for a solution too !!!! But i know what to do! click crysis icon then run with your video card,!!! helps a lot
m
0
l
August 21, 2013 6:47:51 PM

I have an EVGA GTX 680 Signature Superclocked and an Asus GTX 680 Direct CU II Overclocked (factory settings) in SLI and I'm getting lag too. But only in short bursts at random times. GPU memory is always maxed on both cards. All settings maxed, 2560 x 1440.

Is it possible that my motherboard's PCI-E 2.0 8x slots are the bottle neck? Do the 680s have too little VRAM between the two? Or is this game really that demanding?
m
0
l
August 21, 2013 7:59:34 PM

Julie682 said:
Oakley Sunglasses


I actually own 2 pairs of Oakley flak jackets. but that doesn't help me :/ 
m
0
l
!