Java webstart jnlp How Do I let through Sygate Personal Fi..

Archived from groups: comp.security.firewalls (More info?)

Java Web start works if Sygate Personal Firewall (SPF) is set to "Allow All"
WebStart does NOT allow jnlp to load if SPF is set to "Normal"
What kind of SPF rule should I make to allow *.jnlp webstart to work?
I dont get any popup message from SPF
webstart simply says "cannot load resource...*.jnlp"

cheers
kleinbottle 28Jun04
3 answers Last reply
More about java webstart jnlp sygate personal
  1. Archived from groups: comp.security.firewalls (More info?)

    "kelvinq" <kelvinq415@yahoo.com> wrote in message
    news:67d8e1e3.0406271759.564ed4cc@posting.google.com...
    > Java Web start works if Sygate Personal Firewall (SPF) is set to "Allow
    All"
    > WebStart does NOT allow jnlp to load if SPF is set to "Normal"
    > What kind of SPF rule should I make to allow *.jnlp webstart to work?
    > I dont get any popup message from SPF
    > webstart simply says "cannot load resource...*.jnlp"
    >
    > cheers
    > kleinbottle 28Jun04

    Don't know the real answer but check the traffic log to see what is being
    blocked which should give the info to create a rule.

    Billh
  2. Archived from groups: comp.security.firewalls (More info?)

    The answer is:
    Program Files\Java\j2re1.4.2_04\bin\javaw.exe
    must be allowed access to port 80

    What caused my confusion: SygatePersonalFirewall does NOT issue a
    warning
    prompt, it merely blocks traffic with no warning. I believe there must
    be a "Preferences" setting for SPF that will always show a warning. I
    would prefer that, rather than writing a rule to always allow javaw
    access to the internet. Right now SPF is loaded at startup, but to see
    warnings I must explicitely run SPF (which then shows on the wind98
    toolbar)
    cheers Kelvin
  3. Archived from groups: comp.security.firewalls (More info?)

    "kelvinq" <kelvinq415@yahoo.com> wrote in message
    news:67d8e1e3.0406281740.3cf8c33a@posting.google.com...
    > The answer is:
    > Program Files\Java\j2re1.4.2_04\bin\javaw.exe
    > must be allowed access to port 80
    >
    > What caused my confusion: SygatePersonalFirewall does NOT issue a
    > warning
    > prompt, it merely blocks traffic with no warning. I believe there must
    > be a "Preferences" setting for SPF that will always show a warning. I
    > would prefer that, rather than writing a rule to always allow javaw
    > access to the internet. Right now SPF is loaded at startup, but to see
    > warnings I must explicitely run SPF (which then shows on the wind98
    > toolbar)
    > cheers Kelvin

    Does Tools- Options- General- Display Notification Warnings have any
    bearing on this problem?
    Billh
Ask a new question

Read More

Firewalls Java Security Networking