Sign in with
Sign up | Sign in
Your question
Solved

Screen tearing when gaming?

Last response: in Video Games
Share
March 9, 2013 9:09:07 PM

Hello. First of all I'm not very tech savvy so please keep it simple :p 

My graphics card is GeForce GTX 560. I'm using an LG monitor. I think the cord to connect my moniter to my gfx card is VGA, but my card only has I think they're DVI ports? So I have this converter thing to connect them. I'm not sure if this could be the reason.

But anyway, when my computer is on and not running a game, it is perfectly fine. For example, when I'm on the desktop, there are no lines.

This all changes whenever I open up ANY game. As soon as a game is running, there are these horizontal flickering lines accross the screen. Even when I open up the browser, they are still there. But when I close out of the game, they are gone, and everything is normal again.

So obviously having a game open is the problem. Also, this is a problem because it is extremely annoying and effects my gaming experience.

I just want to know how to fix this because it's annoying me so much. I just want my games to be clear and more enjoyable.

Please halp me ;c

More about : screen tearing gaming

March 9, 2013 9:34:12 PM

May be a problem with your video card drivers, try updating them, and if your monitor has hdmi, I would recommend an hdmi cord.

Because sometimes vga and dvi can be a pain in the butt
March 9, 2013 11:40:46 PM

already tried updating driver ..and i dont think my monitor has hdmi D;
Related resources
March 10, 2013 1:31:09 AM

have you tried using vsync?
March 10, 2013 1:38:19 AM

already tried updating driver ..and i dont think my monitor has hdmi D;
March 10, 2013 1:40:08 AM

yes i've tried v-sync in nvidia control and also in-game settings ..its not just the game that screen tears.. its my computer whenever a game is running

even my browser has horizontal blinking lines right now because i have a game running in the background

???? :( 
March 10, 2013 1:41:30 AM

and this has just started?
March 10, 2013 3:58:30 AM

nono has been going on for months ;c
March 11, 2013 3:59:25 AM

try using old drivers and see if that helps
March 11, 2013 9:44:09 AM

also what is your PSU? maybe it doesn't have enough power to feed both CPU and GPU at elevated power needs at the same time?

this can lead to such strange behavior
a b U Graphics card
March 11, 2013 9:50:55 AM

the converter block is unlikely to be the reason it may however be the fact your converting an analog signal to a digital input.
vga is analog, dvi is digital. in theory it should make no difference but in fact it can. if the manufacturer uses cheap shielding or parts.
remove the old drivers run a full screen browser game and see if you get flicker. you will likely get away with using the default vga drivers for this although it may be slow. thats fine its just a test. switch the browser to full screen and see if you get flicker.
now install the latest drivers from nvidia, making sure you select the rite 1s for your o.s.
run the same browser game again and see if you get better or worse image quality.
if its the same try adaptive vsync if the nvidia control panel allows it. also turn off and on physx as it can interfere with the vsync.
make sure the monitor is running at 60hz via the monitors control panel and make sure its driver is up to date (check the manufacturers site for a driver as some need em when others dont)
March 19, 2013 4:43:14 AM

Sounds like a VRAM issue to me, but what you can do to test is beyond me!
March 19, 2013 6:00:44 AM

You can monitor vram usage with msi afterburner. I doubt that is the issue though. What kind of settings are you playing these games at? Is your card overclocked? That being my main suspect as of now. And the power supply is a good suspect as well being not to tech savy you may not have realized a better than oem solution was needed. That being said the described issue has always been fixed by vsync. I would turn vsync off in nvidia control panel on in game and lower visual settings a bit. See if fixed if not lower settings a bit more.

Best solution

a c 124 U Graphics card
March 19, 2013 8:03:10 AM
Share

If it's truly a problem with tearing, you need to do anything possible to bring your framerates down to match your monitors refresh rate (most likely 60Hz). What kind of frame rates are you getting when you see what you think is tearing?

Turn AA up beyond what is necessary. In control panel, turn on AA Transparency to 8x. Turn details up as high as they can go. If you can reduce your framerate to something close to your monitor's refresh rate. Target 60fps.

If your framerates are already there or lower and you still see horizontal lines and your drivers are up to date and you didn't see this issue when you first got the card, you have something else going on with the card. Is it still under warranty? If so, start the RMA process. If it's not under warranty, you have a perfect excuse for an upgrade.
!