Sign in with
Sign up | Sign in
Your question

Can't edit files on C:\

Tags:
Last response: in Windows 8
Share
November 4, 2012 5:50:57 PM

Hello,

Got win8 installed over the weekend from the $39.99 download.

I usually put a txt log file in C:\ for any changes I make to the system. I noticed when I right click from there the new text document option doesn't display. Actually the only thing I can create is a folder. I copied one of my log files from another partition and put it there, made my changes but it wouldn't let me save it. Gives me a permission denied message. I tried moving it around and same thing. Only when I put it into my documents would it let me save my changes. I checked my permissions on that file and they were ok.

I created a folder on the C:\ and moved the file there and same thing.

Is this something from Win8 where I can't edit files unless they're on another drive or in my documents? I checked my id and it is the admin.

Thanks

More about : edit files

a b * Windows 8
November 7, 2012 2:37:16 PM

gb777 said:
Hello,

Got win8 installed over the weekend from the $39.99 download.

I usually put a txt log file in C:\ for any changes I make to the system. I noticed when I right click from there the new text document option doesn't display. Actually the only thing I can create is a folder. I copied one of my log files from another partition and put it there, made my changes but it wouldn't let me save it. Gives me a permission denied message. I tried moving it around and same thing. Only when I put it into my documents would it let me save my changes. I checked my permissions on that file and they were ok.

I created a folder on the C:\ and moved the file there and same thing.

Is this something from Win8 where I can't edit files unless they're on another drive or in my documents? I checked my id and it is the admin.

Thanks


if you want to write to a location off the root of drive c: while user account control is active you will need to take ownership. <win>+x keys, select file explorer, open computer, find drive c, select properties, go to security tab, find your user group that you want to have access

then edit to change the permissions. (or advance tab to more settings)

on my system Users are given, read& execute, list folder contents, read
by default. you can add full control, modify and write, or special permissions

m
0
l
November 7, 2012 7:10:20 PM

C:\ is locked down by default I believe since Vista. Your folder probably had the same deal due to permission inheritance. Even though you're an admin (though you should never operate as the default Administrator account) you don't work at an elevated (privileged) level unless you explicitly tell an action to do so and then it's only limited to that single action. So, if you open notepad normally and do what you do then you'll get an error. However, if you run it "as administrator" via right-clicking then you'll get those elevated privileges.
m
0
l
!