Sign in with
Sign up | Sign in
Your question
Closed

Windows 7 freezes up with graphics acceleration

Tags:
Last response: in Windows 7
Share
February 7, 2009 3:31:31 PM

I'm having problems with my graphics card, system hard freezes and requires reset button to
continue. Upon reboot, if I disable graphics driver and run in vga mode these hard freezes
no longer occur. But the trade-off is that I have no 3d accelleration, can't play any games.
I have tried ati's catalyst 8.x for vista and 9.x for vista as well as the beta release for
Win 7, all drivers load and appear to work but system will freeze when 3d acceleration occurs,
ie when games load. I have a mobile hard drive tray installed to easily switch out hard drives and this only
occurs when using the Windows 7 installation, I also have Win xp and and Win 2000 on other hard drives and the graphics
work properly with the other systems(same configuration just different os with their respective drivers). I can't help but think it is a driver issue with win 7 and my graphics card. Below is detail from the dxdiag report. Any suggestions
will be greatly appreciated.

------------------
System Information
------------------
Time of this report: 1/29/2009, 19:28:17
Machine name: CHUCKLES-PC
Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7000) (7000.winmain_win7beta.081212-1400)
Language: English (Regional Setting: English)
System Manufacturer: VIA Technologies, Inc.
System Model: P4M266A-8235
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: Intel(R) Pentium(R) 4 CPU 3.06GHz, ~3.3GHz
Memory: 1536MB RAM
Page File: 563MB used, 2807MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7000.0000 32bit Unicode



Display Devices
---------------
Card name: ATI Radeon HD 3800 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor AGP (0x9505)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_9505&SUBSYS_95051002&REV_00
Display Memory: 761 MB
Dedicated Memory: 510 MB
Shared Memory: 251 MB
Current Mode: 1440 x 900 (32 bit) (60Hz)
Monitor: Generic PnP Monitor
Native Mode: 1440 x 900 (59.887Hz)
Driver Name: atidxx32.dll,atidxx64,atiumdag.dll,atiumdva.cap,atiumd64,atiumd6a,atitmm64
Driver Version: 7.15.0010.0163 (English)
DDI Version: 10.1
Driver Model: WDDM 1.0
Driver Attributes: Final Retail
Driver Date/Size: 12/1/2008 15:35:27, 2340352 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
Device Identifier: {D7B71EE2-D645-11CF-C471-0FB5A1C2CA35}
Vendor ID: 0x1002
Device ID: 0x9505
SubSys ID: 0x95051002
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_A ModeMPEG2_C

More about : windows freezes graphics acceleration

February 8, 2009 11:07:59 PM

Hm, do you have Build 7000? I have that on both of my machines, one having similar problem. Did you try forcing some update? Go to device manager right click on your graphics card, and click "update driver software." The Windows driver works for me, over the Geforce driver, see below.

I have an 8600GTS, though. I first booted up windows, it installed generic graphics driver, which was alright and still gave me a 5.5 in windows experience. I installed EVGA's drivers (to take advantage of overclock, temps, fan control, etc..) and all was fine until I went into Need for Speed Undercover. PC froze, had to cut power. Turned back on, purple pixels covered the screen in random places, and wouldn't even run games but worked fine in safe mode. Thinking the card was defective, I rolled the driver back to the windows one, and strangely everything was fine.
a b $ Windows 7
February 9, 2009 11:47:13 AM

Not that it gives a resolution, but I believe it's ATI's drivers: I have had the same issue with my 4870x2 and 7. I originally did a clean install to a new HDD using 7, Microsoft's default drivers and ATI's 7 Beta graphics drivers, and the system randomly hard locks while gaming. GPU temps in the 40s and 50s, Processor temps in the 30s to 40s, 900 Watt OCZ Power Supply fed from a UPS, mild~ish overclock (3.2GHz - 8 multi/1600 FSB - on a Q6600) Under normal usage, it runs well. Of course, the issue with a hard lock is no error code or .dmp is generated, so I wasn't entirely sure it wasn't an issue with the standard chipset drivers or something else.

So last weekend (31st~1st) I did a thorough reformat of the driver containing 7 and cloned my very stable Vista 64 install using Acronis. Then I used the Upgrade option to take the whole thing to 7. The reasoning being that would eliminate both MSFT's standard chipset and ATI's 7 Beta drivers as a potential cause because at that point there can be no trace of them left. But No Joy. The system is stable under all conditions using Vista 64, yet still hard locks while gaming in 7.

The only difference between the two systems on a hardware level is which Seagate 7200.11 HDD gets the nod while booting. So in my mind it's definitely a driver problem between ATI's stuff and 7.
Related resources
a b $ Windows 7
February 11, 2009 11:15:19 AM

Update - On the suggestion of one of the posters at seven forums, I disabled my second monitor. Played games for around 4 hours straight with no crashes/freezes. I'm not calling it 100% "solved" without putting more time into it. But so far, so good.
February 12, 2009 7:40:12 PM

Had the same problem on my game box. build 7000. Tried a different vista 64bit driver from nvidia and it helped out quite a bit. I think it is just a maturity issue with the drivers support of the newish 3d stuff in 7. They will get it ironed out I bet.
May 21, 2009 9:50:52 AM

I'm having the same exact problem as chuckles21. Im running on WIN7 RC1, display adapter is Geforce 7950GT. Mobo is Asus P5B. I've tried several nvidia drivers, flashed motherboard bios, to no avail. Nothing works. Only way to prevent the screen from freezing is disabling drivers completely and running at vga resolution.

Would hate to have to install XP back, does not feel like this problem should exist.
August 22, 2009 4:10:09 PM

Hello everyone , the good news is " Problem Solved ". At first i had all the problems with you guys had. I have Win 7 7100 and the games kept freezing anytime between 3 to 15 mins. I have checked many other websites about the problem and i noticed lots of people were suffering because of this problem. However i noticed that the games freezes in ONLY Single player mode. So are we not gonna play single player games ? No , do not worry about it. yeah i will tell you the solution but i am just living the moment of victory. First i updated all the drivers , i tried to re-installed them but nothing helped , then i gave up and i wanted to play Warcraft III , when i tried to connect battle.net windows gave me the weird error and it was something like " You need to run the application as administrator".... ok ok i shut up now , just run every game AS ADMINISTRATOR and the game will not freeze again. Well at least it worked for me and my gear. Peace.
August 22, 2009 4:39:23 PM

ALTERNATE SOLUTION

Hello again, First of al the reason of these freezes is very simple. The games only freezes in Single Player games and mode so whenever the game or teh software you are using needs to write something to harddrives (create/modify) the User Accounts Control prevents it to be written and the game freezes. However in Multiplayer modes nothing is changed in your computer and you can play the game for hours without freezing. The alternate solution is pretty is but it is only a bit risky for reckless users.

Go to Control Panel >> User Accounts >> Change User Account Control Setting >> Set it to Never notify.

after this change , Windows 7 will never ask " Yes or No" question when something is gonna be changed in the program files folder. So the games written data will not be prevented and there will no freeze during gameplay.

SOLUTION #1

-Run every game as ADMINISTRATOR

SOLUTION #2

-Disable (UAC) User Account Control. Set it to "Never Notify".
risky for low-experienced and reckless internet surfers
Anonymous
a b $ Windows 7
September 30, 2009 3:00:23 PM

false. i am doing both and it is freezing on NFS Pro Street, Project Torque, NFS Shift, and NFS Undercover. I'm using windows 7 7100. Just upgraded to a Geforce 9500 GT and still failure. Please help me out
Anonymous
a b $ Windows 7
November 4, 2009 1:58:18 AM

Windows 7 Freezing randomly its a very mind bogling thing this happen with me many times. After serching for many days in google and many windows 7 blogs. I find the solution that help me and my friend too. So hoping that it will help you guys too.
First go to control panel--system and security-Action center--Troubleshooting--system and security--power and then click next and then apply the fix in the 1st option it will show power plan set to high performance then close the trobleshooter. Its the fix that works for me and my friends. Now just make sure that your power plan set to High prformance. For that again go to control panel--system and security and if it is in balance set it to high performance due to administritive right it might not set to high performance for the first time.
!