Sign in with
Sign up | Sign in
Your question

Win98 not detecting correct RAM size! HELP!

Last response: in Windows 95/98/ME
Share
Anonymous
November 22, 2000 12:33:55 PM

Hello again all!
I've got a problem that I've been trying to solve for ahile now.
My sisters computer was just upgraded from 32MB EDO to 128MB of PC-100 Ram. Generic stuff, but she's not interested in gaming or anything like that, mosly internet and office applications, so it should be more than enough to do the trick.

Trouble is, as soon as I installed the stuff, things didn't seem to be going as well as they should for a system with 128MB of Ram.

Turns out Win98 will only detect 65MB worth!!
I've heard of this happening to other people as well. But so far the only way they've been able to correct that is to wipe the drive and reinstall Win98. That is NOT an option here.

Can anyone tell me how to get windows 98 to recognize the rest of the RAM??

System specs:

AMD K6-2 350
Soyo 5EHM Baby AT Super Socket 7 mainboard.
128MB PC-100 Generic RAM running fine at 8ns in "Turbo" mode.
Western Digital 3 GB hard drive. Ultra 33
Texas instruments Permedia 2 Graphics card (No worries folks, this will be upgraded soon. :)  )
Sound Blaster 16Pro
Zoom 33.6 Modem
Win98 2nd edition.

Thanks for any help in advance!

The Jolly Wizened Oaf!
Anonymous
November 22, 2000 6:23:06 PM

During POST, does the bios detect 128MB?
Anonymous
November 22, 2000 8:46:19 PM

Yes. During POST 128MB of Ram is detected.
On another note, when booting into Win98 Dos (ver 7?) and typing "MEM" to view the memory status, it only lists 64MB as well for total memory.

The Jolly Wizened Oaf!
Related resources
November 23, 2000 12:12:58 PM

Is the RAM you bought PC133? Older borads don't support that RAM speed. You could try booting into safe mode and going to device manager. In there you want to continue through all device listings looking for mutilpe enteries of anything.
If that does not work then I can send you a .bat file to run from a DOS prompt to remove registry enteries to re-install most of the hardware drivers.
Anonymous
November 23, 2000 12:16:17 PM

I've never seen this problem before, and it's just a guess but you might want to try it:

Some Bioses have an option to select whether you're using OS2 or nonOS2(everything else - windows & dos) The reason for this is that OS2 need a different mode to access larger amounts of memory. If os2 mode is selected it's possible it is messing up Windows.
The option is often labled "OS2 mode for memory above 64MB" and enabled/disabled. For windows this should be disabled.

Try changing this setting and let us know if it helps.
Anonymous
November 23, 2000 1:53:20 PM

Thanks to all of you for your help! I'll give your suggestions a go and get back to you with the results.

Thanks!

The Jolly Wizened Oaf!
Anonymous
November 24, 2000 9:16:34 PM

Well, I've tried reinstalling windows, but the system doesn't like that too much as it hangs. I've also checked the larger than 64MB OS size in the BIOS. It's going for greater than 64.

So, does anyone have any idea how to force windows to redetect everything it knows? I heard there was a way. Can anyone help? Or at least tell me where in the registry it keeps the memory size?

Thanks

The Jolly Wizened Oaf!
Anonymous
November 25, 2000 2:18:00 AM

There is an option in windows to limit it's memory usage, but I don't think this is the solution because you only got 64 in dos as well.
Click Start, Run and type <b>msconfig</b>
Then select Advanced.
There is an option to 'Limit memory to ????' - it should be disabled but you can try enabling it and increasing the memory size.

Also - for most computers the bios setting I mentioned should be disabled, but it depends on the wording of the question. Try changing it, even if it appears correct. If it doesn't make a differance then change it back.

Windows doesn't keep the memory size in the registry, it detects it every time it starts.
Anonymous
November 25, 2000 9:36:47 AM

Using Windows Help (Start>Help) type Memory in the keyword find under the Index tab. if you select the "problems with, troubleshooting options", they list the steps solving "System Properties reports that my computer has less memory than is installed on it." Hope that helps..
November 26, 2000 11:43:34 PM

Have you checked what version of the bios you have?
At Soyo's web site http://www.soyousa.com/ there is version EH-1DA1. It wouldn't hurt flashing the bios. Just follow the directions or you could destroy the bios.
Anonymous
November 28, 2000 12:28:34 AM

Well, the system is my old board and it ran fine with 256MB in it. But I'll take a look at that as well. This can be so frustrating. GRRRRRRRRR

thanks

The Jolly Wizened Oaf!
!