Cannot boot with Crossfire

So I used to have a 5870 and a Corsair TX750w. I decided to put in a second 5870, and now I can't boot. It POSTs fine, but it hangs on the verbose boot screen. It loads the last drivers, then the top of the screen starts corrupting (blue, red and green distortion). Safe mode is the same thing, and trying Startup Repair does nothing. Fans spin up, no beeps, but I can't boot. Any solutions?
11 answers Last reply
More about cannot boot crossfire
  1. Can you boot with one card
  2. No beep? must take off Power PSU from Mobo & Clear Cmos ? go default !
  3. I took out one card, still the same problem. I also cleared CMOS.
  4. After you cleared the CMOS did you change the primary video device to PCI-e? (If the feature is available)

    One more thing when you tried one card did you try the new one or the old one?
  5. Tried the old one. Primary video device is set to PCI-e.
  6. This is going to sound weird but have you tried to use another 12v connection from your psu?
  7. I should of asked if you have multiple 12v rails on your PSU and have you tried different rails if available.
  8. Single rail.

    And since I can't seem to find my screwdriver, I tried booting off another OS and seeing whether the hardware is the problem. I found my copy of Hiren's BootCD, and booted into Mini XP from there. Mini XP works flawlessly (except that it doesn't recognize my wireless adapter), so I think the problem is with my graphics drivers. Startup Repair had a "load drivers" option with the "choose OS" screen. Is there any way to load Radeon drivers that way?
  9. Have you made sure the connector ribbon that connects the two cards together is the right way round? Mini XP may be simply ignoring the second card. The connector will only work one way.
  10. I'm pretty sure the connector is in correctly. I tried installing drivers from Startup Repair, but it didn't work. Also, the only working system utility (CPU-Z) on Mini XP said that the first 5870 had stock clocks of 850/1200, while the second one is at 13/3200 for some reason.

    Edit: I also tried System Restore to 2 hours before installing the two cards, but it did nothing.
  11. Somehow, taking out the second GPU, rebooting, and switching verbose boot to normal boot meant that I could boot normally. I put the second GPU back in, reconnected and rebooted, and it works now. Thanks for the help.
Ask a new question

Read More

Boot Crossfire Corsair Windows 7