Delay with NVidia Stereo drivers

Archived from groups: alt.comp.periphs.videocards.nvidia (More info?)

Hello,

Is anybody using the NVidia stereo drivers with games, OpenGL demos or the
like and experiencing a delay until the stereo mode activates?

I am experiencing a delay with e.g. Quake2 , the Coin3D graphics API
and a self-made OpenGL demo, but no delay with Windows OpenGL screensavers
(e.g. tubes) and with Futuremark's 3DMark03. I am wondering, where this
delay is coming from and how to get rid of it.

A test revealed that (in case of the delay) about 550 buffer swaps have to
be performed before the stereo mode is activated. So manually performing
550 buffer swaps in a for loop in my program reduces the delay to nearly
nothing (without VSync), but i think there has to be a more elegant
solution... ;-)

Any hints welcome.

Cheers,
Guido
2 answers Last reply
More about delay nvidia stereo drivers
  1. Archived from groups: alt.comp.periphs.videocards.nvidia (More info?)

    "G Heumer" <gheumer@techfak.uni-bielefeld.de> wrote in message
    news:2rb4s3F189s52U1@uni-berlin.de...
    > Hello,
    >
    > Is anybody using the NVidia stereo drivers with games, OpenGL demos or the
    > like and experiencing a delay until the stereo mode activates?
    >
    > I am experiencing a delay with e.g. Quake2 , the Coin3D graphics API
    > and a self-made OpenGL demo, but no delay with Windows OpenGL screensavers
    > (e.g. tubes) and with Futuremark's 3DMark03. I am wondering, where this
    > delay is coming from and how to get rid of it.
    >
    > A test revealed that (in case of the delay) about 550 buffer swaps have to
    > be performed before the stereo mode is activated. So manually performing
    > 550 buffer swaps in a for loop in my program reduces the delay to nearly
    > nothing (without VSync), but i think there has to be a more elegant
    > solution... ;-)
    >
    > Any hints welcome.
    >
    > Cheers,
    > Guido
    No, I get no delay! What driver versions are you using? I am using 61.76,
    but I did'nt get any delay with 56.64 either...
  2. Archived from groups: alt.comp.periphs.videocards.nvidia (More info?)

    GTS wrote:
    >
    > No, I get no delay! What driver versions are you using? I am using 61.76,
    > but I did'nt get any delay with 56.64 either...
    >

    The newest version downloadable from NVidia: 61.77.

    Cheers,
    Guido
Ask a new question

Read More

Nvidia Drivers OpenGL Graphics