Sign in with
Sign up | Sign in
Your question
Closed

Windows 7 on raid 0

Last response: in Windows 7
Share
February 8, 2009 6:17:02 PM

I just put together pc with an ASUS P6TP Revolution MB that has an on board Marvell 88SE6320 SAS Controller. I set up a raid 0 array with 2 SAS drive, made 2 partitions, and installed windows xp pro 32 bit on one partition.

I want to test windows 7 beta 64 bit on the other partition, but during installation windows 7 does not detect my array, and the raid drivers that came with my motherboard are windows xp and windows vista. I tried using these drivers but windows 7 does not recognize them as valid drivers.
Are there any suggestions on how I can get windows 7 to detect the raid 0 array?

Thanks.

More about : windows raid

February 11, 2009 11:56:28 PM

Try downloading the most up-to-date drivers from the motherboard manufacturer or from Marvell's website, then load them on a flash drive and try to get Windows 7 to detect the RAID once you load up the drivers.
February 12, 2009 1:07:16 PM

Thanks. I was able to get it installed, however, I had to use the amd driver on an intel processor,which didn't make any sense.
It worked so all is well.

Bryan
Related resources
March 21, 2009 7:44:28 AM

I got the same issue
Windows 7057 unable to recocgize Raid 0 array
Still looking for a solution
Marc
France
April 7, 2009 4:06:52 PM

I had the same issue with a Asus m3a79-t deluxe and 2 640 gb wd blacks in raid 0. I had to load the drivers onto a floppy and a usb, upon install of windows 7 beta, go to the repair section, click on to load drivers and then go back to clean install and start the install, worked with no problems
a b $ Windows 7
April 23, 2009 8:31:56 PM

The "AMD" drivers simply refer to the fact that AMD had a x86-64 processor out before Intel. A lot of companies still name their drivers AMD64 even though they will work on either processor.
April 23, 2009 9:18:22 PM

I unchecked the show only compatable drivers box in setup and used the ones for the board it worked fine for me
May 10, 2009 6:28:43 AM

Hi
Asus m2n-sli deluxe nforce570. Install of windows 7 went without a problem, but my performance is poor. Any windows that I open, being IE8 or Control Panel takes forever. Much longer than single 150gb raptor. Now I have 2 1tb western digital in stripping mode. total 1800GB of space. I do understand that large drive might be little slower but not that much, especially since its raid-0.
Newest nforce vista 64 drivers fail upon a reboot, bsod.
December 25, 2009 2:31:08 PM

IF YOU ARE HAVING TROUBLE WITH WINDOWS 7 INSTALL ON A RAID ARRAY!!!

I'll try to be brief:

I had to use windows xp x64 RAID drivers to get through set up correctly! Here's what I did:

MSI board (K9A2 CF) - AMD Chipset
RAID 0 (two 74gb raptors)

1. if you do not have a floppy drive in your computer, go into bios and disable that bitch because it slows the win 7 install WAY down.

2. this was a clean install, not an upgrade. i started the computer with the win7 DVD in, (DVD-ROM set to first boot device, to be clear here).

3. during windows setup, i hit install, blah blah blah. when it gets to the screen that says windows needs some drivers. i hit BROWSE.

4. on my USB jump drive, i had ALL THE BIOS DRIVERS THAT MSI LISTS FOR MY MOTHERBOARD. they were in their respective folders. i ended up finding that the WINDOWS XP 64 BIT RAID drivers were the correct ones.

!NOTE: this part is stupid because when i was choosing the "windows 7" raid driver, setup would accept it and continue (or so i thought). when setup restarted and tried to boot from this new installation, it would cry about an "unsigned driver" and specifically ahcix64s.

SOLUTION: when loading RAID drivers, when your browsing (like i talk about in step 4), look for a driver that will be listed after you choose it. in other words, the box that has the "browse" button at the bottom, has an empty box above the "browse" button. the way you know you've selected the correct driver is that it will appear in this box once you've selected it. it has the d:/removableUSB/winxpx64/something.inf
if you do not see this, do not bother continuing. take your usb stick out, get another pc and download some more drivers until you find something it will accept.

hope this helps, i couldn't find this answer ANYWHERE.

email me if you want more explanation or anything
tongpoe@gmail.com
March 16, 2010 12:47:00 PM

I confirm the email of tongpoe, and I followed everything he mentioned in his post.

1. Disable Floppy disk drive : good idea.
2. Clean install for Raid : definitely, I am not sure how to make it otherwise
3. Browse from USB drive, one by one to highlight the driver, and click on "Hide drivers which are not compatible" or something like this.
4. And the best of all : though I tried all my best to get signed drivers for multiple sources, it was the drivers for 2k3 server which worked for Windows 7.

thank you tongpoe, without you, I wouldn't have gone through this.
a c 215 $ Windows 7
March 16, 2010 12:53:36 PM

This topic has been closed by The_Prophecy
!