Sign in with
Sign up | Sign in
Your question

Help configuring Windows 7 Firewall Outgoing Connections

Last response: in Windows 7
Share
November 25, 2010 11:50:47 AM

I'd like to limit outgoing programs as much as possible, so I set it to reject outgoing connections unless a rule allows it.

It seems Internet Explorer will only work if Port 80 is opened, but once I open Port 80 any programs can access the internet. So it at this point I have to go through and create a rule for every program that I want to restrict, which is exactly what I hoped to avoide by setting it to reject outgoing connections unless a rule allows it.

Is there a way to tell it to open Port 80 but only for certain programs?
November 25, 2010 12:27:02 PM

Why not get an anti-virus and use its firewall instead. Why would you limit outgoing for certain programs and not for certain programs anyway? Maybe there are other ways you can do what you really want to.
m
0
l
November 25, 2010 2:06:55 PM

I only want the programs that I authorize to access the internet.

I don't like commercial firewall programs for many reasons.

I was thinking of installing a Windows Firewall Control, but I'd rather not install anything if I can get the firewall to do what I want.
m
0
l
Related resources
November 29, 2010 12:08:13 PM

ratsa said:

It seems Internet Explorer will only work if Port 80 is opened, but once I open Port 80 any programs can access the internet.


After you have created the first outgoing rule for tcp/80 you should re-open it and then you will have more options, for example which local program could use this. Browse to the iexplore.exe and it should be the only program to be allowed to use this rule.
m
0
l
December 3, 2010 1:24:30 AM

Thanks for pointing that out ricno. I tried it, but unfortunately that did not give Explorer access to the Internet. I am puzzled by this. Also, Firewall is supposed to give a warning when it block a program from accessing the internet, but I get no such warning messages.
m
0
l
December 3, 2010 8:21:00 AM

ratsa said:
I tried it, but unfortunately that did not give Explorer access to the Internet.


Did you alter the correct profile? It is easy to edit perhaps the Domain profile, while it might actually be the Private one who is being used by the firewall.
m
0
l
!