Sign in with
Sign up | Sign in
Your question

Cant get the network card working

Last response: in Networking
Share
Anonymous
March 2, 2001 3:07:36 PM

I have an abit kt7a-raid mother board running win 98 and i cant get my linksys 10/100 fast ethernet network card to work with it. Windows detects it when i first put it in and the drivers installed with no problem. But when i set it up to use my cable modem it just donst work. I followed the instructions the cable company gave me which work fine on my other computers. I dont know whats wrong with it. I tried everything i can think of. The lights on the card turn on but when i run winipcfg to renew the ip address it just hangs for a bit then keeps the incorrect/default ip address. I tried disabling irq holding which was recomended in the manual but that didnt work either. Im gonna try to mess with the irq settings on the bios, but this hasnt worked either so far, all this has done was make more conflicts between the sound card and the scsi card. I have a bunch of free irqs but the scsi card and the sound card both want irq 11 for some reason. But i dont think this has anyting to do with the network card because in the device manager it says this device is working properly.

More about : network card working

Anonymous
March 2, 2001 3:15:46 PM

check to make sure the NIC is not set to 100MB or to 10MB full duplex.

you want it set to 10MegaBit Half Duplex.
this might be setup at the hardware level.
Anonymous
March 2, 2001 4:12:08 PM

It was on auto sense. I Tried every other setting too but since none of them worked I put it back on auto sense.

thx for the reply
Related resources
Anonymous
March 2, 2001 7:21:31 PM

i don't know how you have your TCP/IP properties setup, but if you have a cable ISP, make sure you just have it set to obtain IP and DNS automatically. Leave all other checkboxes blank. WINS can (most probably) be disabled to. After you do that, try renew-all and it should grab an IP from your ISP. Also, if you have your ISP's gateway address, try pinging it. You can also try pinging your loopback address (127.0.0.1) to see if TCP/IP and your NIC are actually properly installed. I don't know if you problem is a IRQ conflict, since IRQ confilcts most often result in (especially if you are on win98) a hung system. Give that a go.
Anonymous
March 2, 2001 8:09:38 PM

Im sure I set it up right. I have 2 other computers that work fine on the cable modem. I unplugged one of the old ones so I could plug the cable into the new one. But when I follow the steps it just dosnt renew with the proper ip address. I tried what you said with the ping 127.0.0.1
and this is what i got back

pinging 127.0.0.1 with 32 bytes of data:
Reply from 127.0.0.1 bytes=32 time<10ms TTL=128
Reply from 127.0.0.1 bytes=32 time<10ms TTL=128
Reply from 127.0.0.1 bytes=32 time<10ms TTL=128
Reply from 127.0.0.1 bytes=32 time<10ms TTL=128

ping statistics for 127.0.0.1:
packets Sent = 4, Recieved = 4, Lost = 0 (0%loss)
Approximate round trip times in milli-seconds:
Minimum = 0ms, maximum = 1 ms, average = 0 ms

I dont know my isp's gateway address.
Anonymous
March 2, 2001 8:30:30 PM

I also fixed the irq conflicts by moving the cards around. But the network card still doesn't work. If anyone cares here is how i have my cards in my comp which gets rid of all conflicts for me.
pci1 = nothing
pci2 = network card
pci3 = scsi card for hardrive
pci4 = sound card
pci5 = nothing
pci6 = nothing
isa = nothing

I also disabled com1 com2 parallel port and usb ports in the bios setup to free more irqs.
Anonymous
March 2, 2001 9:22:08 PM

If your loopback address is giving you those results, then that means your NIC is working fine and TCP/IP is installed properly. Describe your topology in better detail. Is this computer part of a LAN or is its NIC attached directly to the cable modem?
Anonymous
March 2, 2001 9:27:51 PM

As for your IRQ conflict (sorry, i didnt read that post until after I sent the previous message) don't bother wasting time with that anymore. I'm 98% sure its not an IRQ confilct. You can also find out your gateway address from one of the other computers that you say works fine. Again though, describe your network topology if that computer is part of a network. I also reiterate that you should have it set to obtain IP automatically (I'm sure you already have, but I'm just making sure). Make sure you haven't entered anything into the Subnet mask (should give you this automatically as soon as you are communicating with the DHCP server)
Anonymous
March 2, 2001 10:04:58 PM

Here is how im set up. I bought 2 ip addresses from my cable provider @home. I have the cable modem plugged into the hub in the uplink outlet and the 2 computers on outlets 1 and 2. This setup works for the two old computers. The oldest computer i have is a p200 so i was gonna take that one off the network and plug the wire that used to be in that one into the new computer which i did. I copied the settings exactly from the old computer to the new computer. I couldnt find the same exact network card because they didnt have the 10baseT only cards. So i bought the 10/100 one from linksys. It has some extra settings which my other card didnt have which might cause the problem. when i go into network settings and select the adapter and select properties then click on the advanced list i get a list labeled properties:( Ones i have selected are in parenthesis)
here are the properties in the list:
Link Off change= with the options (disabled)/enabled.
Link On change= with the options disable/(enabled).
Magic Packet wakeup = (enabled)/diabled
Media type: = (Auto Sense)/100BaseTX/100BaseTX Full Duplex/10BaseT FUll Duplex/10BaseT

Those are the only things differnt from the card in my old computer.
ill try to get a screenshot of the settings up
Anonymous
March 2, 2001 10:10:52 PM

Just a quick question, what kind of hub do you have and is it autosensing?
Anonymous
March 2, 2001 10:22:08 PM

Its a linksys 5 port hub. No idea but i dont think it would be autosensing because its only 10baseT. I lost the manual so i dont know for sure.
Anonymous
March 3, 2001 3:26:37 AM

Found an old non linksys nic and it works fine! Man two days trying to get that pos to work. thx for all the replies.
Anonymous
March 3, 2001 2:11:13 PM

The problem sounds like it just didnt like your 10/100BT card on that hub. The NIC had to be set to 10BT...probably half duplex
Anonymous
March 4, 2001 9:53:50 PM

was the card sharing an IRQ? I've found serious problems with the Linksys 100TX NIC when it has to share an IRQ where other cards (even Realtek based cards) did not have this issue.

***check the jumpers 1st then check em again***
!