Sign in with
Sign up | Sign in
Your question
Solved

Solution for Windows 8 Internet Slowness

Last response: in Windows 8
Share
November 8, 2012 12:38:05 AM

By default, Windows 8 will reduce to 1 active connection per server, causing other conenctions to be blocked until the current connection completed its progress. If you find any video in Youtube does not play automatically and need frequently page reloading, this may fix it.

Here, how to restore your network:
1) run "gpedit.msc" from Run dialog.
2) Navigate to Computer Configuration > Administrative Template > Network > Windows Connection Manager (Only for Window 8 and might be applicable for Server 2012?)
3) Click "Disabled" radio button in the Minimize the number of simultaneous connections to the Internet or a Windows Domain option.
4) Reboot your windows, you may see noticable speed improvement for Cable and DSL modem except 100Mbps Fibre which is already fast enough and might unlikely to see any gain.

Just found it by chance since I couldn't find such info in the web, it was hacky in XP but breeze in Windows 8.
a b * Windows 8
November 11, 2012 5:23:11 AM

proyb2 said:
By default, Windows 8 will reduce to 1 active connection per server, causing other conenctions to be blocked until the current connection completed its progress. If you find any video in Youtube does not play automatically and need frequently page reloading, this may fix it.

Here, how to restore your network:
1) run "gpedit.msc" from Run dialog.
2) Navigate to Computer Configuration > Administrative Template > Network > Windows Connection Manager (Only for Window 8 and might be applicable for Server 2012?)
3) Click "Disabled" radio button in the Minimize the number of simultaneous connections to the Internet or a Windows Domain option.
4) Reboot your windows, you may see noticable speed improvement for Cable and DSL modem except 100Mbps Fibre which is already fast enough and might unlikely to see any gain.

Just found it by chance since I couldn't find such info in the web, it was hacky in XP but breeze in Windows 8.


I looked up the setting. This default setting is intended to cause your highest speed device to take over your connection when a faster connection is provided. For example, you have your browser on your laptop reading a site over its wireless connection. Now you walk into your office and plug in your ethernet cable to the laptop. Win 8 will shut down the slower connection (wifi) and switch you over to the faster ethernet connection. This is good, your internet apps would start working at the higher speed without having to be restarted. If you make the policy change then both network loops would me active at the same time. Generally a bad thing in many respects.
a b * Windows 8
November 11, 2012 5:51:52 AM

proyb2 said:
By default, Windows 8 will reduce to 1 active connection per server, causing other conenctions to be blocked until the current connection completed its progress. If you find any video in Youtube does not play automatically and need frequently page reloading, this may fix it.

Here, how to restore your network:
1) run "gpedit.msc" from Run dialog.
2) Navigate to Computer Configuration > Administrative Template > Network > Windows Connection Manager (Only for Window 8 and might be applicable for Server 2012?)
3) Click "Disabled" radio button in the Minimize the number of simultaneous connections to the Internet or a Windows Domain option.
4) Reboot your windows, you may see noticable speed improvement for Cable and DSL modem except 100Mbps Fibre which is already fast enough and might unlikely to see any gain.

Just found it by chance since I couldn't find such info in the web, it was hacky in XP but breeze in Windows 8.


This is not advisable and it doesn't do what you think it does. There are no "slowness" issues with Windows 8.

Teaming network connections is not a good idea for client computers.
Related resources

Best solution

January 30, 2013 11:39:52 AM
Share

Hi.
I think i found the solution.

1. Open Network Sharing Center
2. Click Change Adapter Settings
3 Right click on WiFi and choose properties
4 Click Configure
5 Choose Advanced
6 From the list below choose minimum power consumption and change value to disable
7 Click Ok.

Hope it helps.
March 31, 2013 5:32:41 AM

Try the following: (especially if you have no gpedit.msc)

Open a Command Prompt (Admin) by hovering in the lower left corner, right clicking and choosing Command Prompt (Admin)

Type the following three command lines

netsh winsock resetcatlog
netsh int ipv4 reset reset.log
netsh int ipv6 reset reset.log

Reboot machine.
April 5, 2013 6:06:40 PM

Hi,

I had this issue - very slow internet, so slow I couldn't even get Windows to activate online.

I fixed it as follows:

1) Go to Network and Sharing Centre
2) Go to Change adapter settings
3) Right click on your Ethernet connection and select Properties
4) Click Configure
5) Advanced
6) Disable Energy Efficient Ethernet

This instantly fixed it for me.
April 8, 2013 10:32:50 PM

Joel Lithgow said:
Hi,

I had this issue - very slow internet, so slow I couldn't even get Windows to activate online.

I fixed it as follows:

1) Go to Network and Sharing Centre
2) Go to Change adapter settings
3) Right click on your Ethernet connection and select Properties
4) Click Configure
5) Advanced
6) Disable Energy Efficient Ethernet

This instantly fixed it for me.


I didn't have that option on my Advanced tab. This is what I have on my Advanced tab. http://tinypic.com/r/1eq69e/6

Help me!
April 8, 2013 10:33:33 PM

Sorry for the double post.
April 10, 2013 5:32:11 PM

Serious question: How do I "go to Network and Sharing Center"?

Thank you.

Joel Lithgow said:
Hi,

I had this issue - very slow internet, so slow I couldn't even get Windows to activate online.

I fixed it as follows:

1) Go to Network and Sharing Centre
2) Go to Change adapter settings
3) Right click on your Ethernet connection and select Properties
4) Click Configure
5) Advanced
6) Disable Energy Efficient Ethernet

This instantly fixed it for me.


April 10, 2013 5:41:41 PM

Nevermind. I'm not on an Ethernet. I'm on wifi. This new $1200 HP Wndows 8 computer is completely unusable on the internet. Meanwhile my daughter is happily viewing anything and everything she wants on Hulu and Youtube on her $200 Windows 7 Acer. Even my phone works on the internet. I'm about to lose my mind.
June 30, 2013 6:07:33 AM

TheGoodGoodMan said:
Hi.
I think i found the solution.

1. Open Network Sharing Center
2. Click Change Adapter Settings
3 Right click on WiFi and choose properties
4 Click Configure
5 Choose Advanced
6 From the list below choose minimum power consumption and change value to disable
7 Click Ok.

Hope it helps.

there is no choices about #6 :( 
June 30, 2013 6:08:55 AM

Hazy Jay said:
Try the following: (especially if you have no gpedit.msc)

Open a Command Prompt (Admin) by hovering in the lower left corner, right clicking and choosing Command Prompt (Admin)

Type the following three command lines

netsh winsock resetcatlog
netsh int ipv4 reset reset.log
netsh int ipv6 reset reset.log

Reboot machine.


tried this one I think this help a bit. Thanks
!