receiving 'access denied' message on all folders in logica..

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I have my hard drive configured with multiple logical drives and use the 'c'
drive just for the operating system. I just reloaded windows xp on my 'c'
drive after re-formatting the 'c' drive only. I have then installed all
updates but when I go into windows explorer and click on any folder on any of
the logical drives I receive and 'access denied' message. When I re-installed
I created a new user account other than the one I had previously used. How
can I make all these drives available again.
5 answers Last reply
More about receiving access denied message folders logica
  1. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Ten-

    I am going to presume two things:
    1) You are running XP Pro;
    2) You _had_ - before the reinstall - simple file sharing turned OFF

    It is very likely that the remaining un-reformated volumes (which you called
    logical drives, both terms are correct and somewhat appropriate but in this
    instance at this point you should think of it in terms of being a disk
    volume) access rights are based on the SID of the prior WinXP install's
    Administrator account (e.g. it may be called Administrator, but each time you
    install XP a new SecurityIDentifier is generated for each login account, and
    that's what XP actually uses in the security token that is reviewd when
    access is requested to any objcect: the SID _not_ the account name; however,
    there is a minor exception to this as regards to object ownership when
    AdministratorS is the owner - more details below.

    It is relatively easy to correct:
    Open your favorite Windows GUI (My Computer or Explorer or IE) and navigate
    to the disk voluem in question (let's say drive M:\...)
    Right-click the M:\-drive icon and select Sharing and Security (or
    Properties if that selection is not visible for some reason);
    Click on the Security Tab
    Click the Advanced button in lower-rgt region of Security window
    Click on the Ownership tab
    Select either the Administrator account or Administrators account as the new
    owner (read notes below before completing this procedure from this step on)
    Check the replace owner on subfolders box in lower-left area of this window
    Do NOT click OK just yet (unless you want to make it a two-step process; you
    won't hurt anything by clicking OK/Apply now, it is just a time-saver to wait
    at this point - but if you do want to two-step this, click Apply here not OK
    - there are considerations to be made, again see notes below): Click on the
    Permissions tab
    Review the listed permissions configuration and adjust as desired
    Click OK

    Notes:
    If you want just The Administrator to OWN the volume that's fine. There is a
    slight downside to that and that is if you do reformat/reinstall again, you
    will have to repeat this exercise all over as the Administrator SID will be
    assigned as the Object's Owner and not the Administrors Group.
    In XP, when the Administrators GROUP is assigned as the owner, then even
    after a reinstall and all SIDs get recreated, Objects that _were_ owned by
    and accessible to the old Administrators group are _still_ owned by and
    accessible to the NEW Administrators group. This business of reapplying
    ownership is moot.

    Sometimes, depending on how the permissions were setup on the volume
    _before_ you reinstalled XP (especially on subdirectories underneath where
    inheritance was turned off and a new set of permissions set at that level) in
    order for all the permissions to work or get reset properly, you get the
    results you want by Applying the ownership change BEFORE changing any of the
    Permission entries on that tab, and then APPLYing/OKing the Permissions
    changes as well. But, if all you want to do is establish the base
    permissions on the root of the volume and then utilize inheritance to
    propgate those permissions throughout the tree below, then there is no need
    to APPLY Ownership separate from Permissions, you can save the time it will
    take XP to reapply your new settings by configuring the Permissions entries
    after the Ownership before clicking APPLY/OK.

    You'll need to go thru this exercise for each of your disk drive volumes
    (logical drives).

    Then.... everything should be fine!

    Good luck, and Happy New Year!


    "ten" wrote:

    > I have my hard drive configured with multiple logical drives and use the 'c'
    > drive just for the operating system. I just reloaded windows xp on my 'c'
    > drive after re-formatting the 'c' drive only. I have then installed all
    > updates but when I go into windows explorer and click on any folder on any of
    > the logical drives I receive and 'access denied' message. When I re-installed
    > I created a new user account other than the one I had previously used. How
    > can I make all these drives available again.
  2. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    I am running xp home edition. I tried both the 'properties' and the 'sharing
    but there is not a 'security' or advance button on either. Any additional
    assistance would be greatly appreciated.l

    "Danor" wrote:

    > Ten-
    >
    > I am going to presume two things:
    > 1) You are running XP Pro;
    > 2) You _had_ - before the reinstall - simple file sharing turned OFF
    >
    > It is very likely that the remaining un-reformated volumes (which you called
    > logical drives, both terms are correct and somewhat appropriate but in this
    > instance at this point you should think of it in terms of being a disk
    > volume) access rights are based on the SID of the prior WinXP install's
    > Administrator account (e.g. it may be called Administrator, but each time you
    > install XP a new SecurityIDentifier is generated for each login account, and
    > that's what XP actually uses in the security token that is reviewd when
    > access is requested to any objcect: the SID _not_ the account name; however,
    > there is a minor exception to this as regards to object ownership when
    > AdministratorS is the owner - more details below.
    >
    > It is relatively easy to correct:
    > Open your favorite Windows GUI (My Computer or Explorer or IE) and navigate
    > to the disk voluem in question (let's say drive M:\...)
    > Right-click the M:\-drive icon and select Sharing and Security (or
    > Properties if that selection is not visible for some reason);
    > Click on the Security Tab
    > Click the Advanced button in lower-rgt region of Security window
    > Click on the Ownership tab
    > Select either the Administrator account or Administrators account as the new
    > owner (read notes below before completing this procedure from this step on)
    > Check the replace owner on subfolders box in lower-left area of this window
    > Do NOT click OK just yet (unless you want to make it a two-step process; you
    > won't hurt anything by clicking OK/Apply now, it is just a time-saver to wait
    > at this point - but if you do want to two-step this, click Apply here not OK
    > - there are considerations to be made, again see notes below): Click on the
    > Permissions tab
    > Review the listed permissions configuration and adjust as desired
    > Click OK
    >
    > Notes:
    > If you want just The Administrator to OWN the volume that's fine. There is a
    > slight downside to that and that is if you do reformat/reinstall again, you
    > will have to repeat this exercise all over as the Administrator SID will be
    > assigned as the Object's Owner and not the Administrors Group.
    > In XP, when the Administrators GROUP is assigned as the owner, then even
    > after a reinstall and all SIDs get recreated, Objects that _were_ owned by
    > and accessible to the old Administrators group are _still_ owned by and
    > accessible to the NEW Administrators group. This business of reapplying
    > ownership is moot.
    >
    > Sometimes, depending on how the permissions were setup on the volume
    > _before_ you reinstalled XP (especially on subdirectories underneath where
    > inheritance was turned off and a new set of permissions set at that level) in
    > order for all the permissions to work or get reset properly, you get the
    > results you want by Applying the ownership change BEFORE changing any of the
    > Permission entries on that tab, and then APPLYing/OKing the Permissions
    > changes as well. But, if all you want to do is establish the base
    > permissions on the root of the volume and then utilize inheritance to
    > propgate those permissions throughout the tree below, then there is no need
    > to APPLY Ownership separate from Permissions, you can save the time it will
    > take XP to reapply your new settings by configuring the Permissions entries
    > after the Ownership before clicking APPLY/OK.
    >
    > You'll need to go thru this exercise for each of your disk drive volumes
    > (logical drives).
    >
    > Then.... everything should be fine!
    >
    > Good luck, and Happy New Year!
    >
    >
    > "ten" wrote:
    >
    > > I have my hard drive configured with multiple logical drives and use the 'c'
    > > drive just for the operating system. I just reloaded windows xp on my 'c'
    > > drive after re-formatting the 'c' drive only. I have then installed all
    > > updates but when I go into windows explorer and click on any folder on any of
    > > the logical drives I receive and 'access denied' message. When I re-installed
    > > I created a new user account other than the one I had previously used. How
    > > can I make all these drives available again.
  3. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    What you have to do is take ownership of the directories.

    The best way to do it is like this...

    1. Make sure you are logged in with admin rights.
    2. Get the directory or drive letter from explorer and right click it
    3. Select the security tab and press advanced.
    4. Select the owner tab and click administrators (notice the s at the end,
    that is the group administrators not the user administrator)
    5. Press the check box at the bottom of that window to go through all
    subdirectories.
    6. Press all the ok buttons, it should take a little time, then all will be
    ok.

    Tell us your findings from there.


    "ten" <ten@discussions.microsoft.com> wrote in message
    news:9E052745-545F-44D8-A90D-C8F7C7EE6FFA@microsoft.com...
    >I have my hard drive configured with multiple logical drives and use the
    >'c'
    > drive just for the operating system. I just reloaded windows xp on my 'c'
    > drive after re-formatting the 'c' drive only. I have then installed all
    > updates but when I go into windows explorer and click on any folder on any
    > of
    > the logical drives I receive and 'access denied' message. When I
    > re-installed
    > I created a new user account other than the one I had previously used. How
    > can I make all these drives available again.
  4. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Ten-

    I run XP Pro and am quite familiar with NTFS permissions and want that level
    of control on my own systems, so I turn off the Simple File sharing in Folder
    Options in order to gain that access. Subsequently, I have essentially no
    experience in dealing with Ownership/Permissions on XP systems that _do_ have
    Simple File sharing turned on (I can tell this is your situation because you
    told us that you do not see a 'Security' tab or 'Advanced' button on the disk
    drive Properties page; those are the signs that Simple File sharing is turned
    on).

    Here is another major factor that I (and you) need clarified before I can
    really help you further, or you desire to seek assistance from me:
    When XP was installed, was the drive formatted using NTFS or FAT32?
    (to find out: In Explorer/My Computer, rt-click the drive, select
    Properties, General Tab, near the top under the Icon it will say "Type" then
    below that "File System"...)

    If it was formatted FAT32, then I perhaps a person with more
    "Simple-File-sharing-in-a-FAT32-File-System-environment" knowledge can help
    you.

    But, if its NTFS, I still believe that the following will help you:

    Turn OFF Simple File Sharing
    to do this:
    go back to My Computer/Windows Explorer
    On the Menu Bar select Tools>Folder Options (very bottom)
    Click the View tab
    in the Advanced settings section, scroll all the way down to the bottom and
    CLEAR
    the checkbox for Use simple file sharing
    Click OK

    This should be effective immediately no reboot s/b required.

    NOW you should be able to see the 'Security' tab on the disk drive
    properties pages.

    Should this be the last glitch that holds you up (i.e. the previously
    discussed procedures resolve your problems), then when your access has been
    restored and your happy that you can get to everything, I suggest that you
    turn Simple File sharing back ON, since that environment is what you are used
    to running in.

    Keep us posted as to your progress!

    Best wishes, & Happy New Year!


    "ten" wrote:

    > I am running xp home edition. I tried both the 'properties' and the 'sharing
    > but there is not a 'security' or advance button on either. Any additional
    > assistance would be greatly appreciated.l
    >
    > "Danor" wrote:
    >
    > > Ten-
    > >
    > > I am going to presume two things:
    > > 1) You are running XP Pro;
    > > 2) You _had_ - before the reinstall - simple file sharing turned OFF
    > >
    > > It is very likely that the remaining un-reformated volumes (which you called
    > > logical drives, both terms are correct and somewhat appropriate but in this
    > > instance at this point you should think of it in terms of being a disk
    > > volume) access rights are based on the SID of the prior WinXP install's
    > > Administrator account (e.g. it may be called Administrator, but each time you
    > > install XP a new SecurityIDentifier is generated for each login account, and
    > > that's what XP actually uses in the security token that is reviewd when
    > > access is requested to any objcect: the SID _not_ the account name; however,
    > > there is a minor exception to this as regards to object ownership when
    > > AdministratorS is the owner - more details below.
    > >
    > > It is relatively easy to correct:
    > > Open your favorite Windows GUI (My Computer or Explorer or IE) and navigate
    > > to the disk voluem in question (let's say drive M:\...)
    > > Right-click the M:\-drive icon and select Sharing and Security (or
    > > Properties if that selection is not visible for some reason);
    > > Click on the Security Tab
    > > Click the Advanced button in lower-rgt region of Security window
    > > Click on the Ownership tab
    > > Select either the Administrator account or Administrators account as the new
    > > owner (read notes below before completing this procedure from this step on)
    > > Check the replace owner on subfolders box in lower-left area of this window
    > > Do NOT click OK just yet (unless you want to make it a two-step process; you
    > > won't hurt anything by clicking OK/Apply now, it is just a time-saver to wait
    > > at this point - but if you do want to two-step this, click Apply here not OK
    > > - there are considerations to be made, again see notes below): Click on the
    > > Permissions tab
    > > Review the listed permissions configuration and adjust as desired
    > > Click OK
    > >
    > > Notes:
    > > If you want just The Administrator to OWN the volume that's fine. There is a
    > > slight downside to that and that is if you do reformat/reinstall again, you
    > > will have to repeat this exercise all over as the Administrator SID will be
    > > assigned as the Object's Owner and not the Administrors Group.
    > > In XP, when the Administrators GROUP is assigned as the owner, then even
    > > after a reinstall and all SIDs get recreated, Objects that _were_ owned by
    > > and accessible to the old Administrators group are _still_ owned by and
    > > accessible to the NEW Administrators group. This business of reapplying
    > > ownership is moot.
    > >
    > > Sometimes, depending on how the permissions were setup on the volume
    > > _before_ you reinstalled XP (especially on subdirectories underneath where
    > > inheritance was turned off and a new set of permissions set at that level) in
    > > order for all the permissions to work or get reset properly, you get the
    > > results you want by Applying the ownership change BEFORE changing any of the
    > > Permission entries on that tab, and then APPLYing/OKing the Permissions
    > > changes as well. But, if all you want to do is establish the base
    > > permissions on the root of the volume and then utilize inheritance to
    > > propgate those permissions throughout the tree below, then there is no need
    > > to APPLY Ownership separate from Permissions, you can save the time it will
    > > take XP to reapply your new settings by configuring the Permissions entries
    > > after the Ownership before clicking APPLY/OK.
    > >
    > > You'll need to go thru this exercise for each of your disk drive volumes
    > > (logical drives).
    > >
    > > Then.... everything should be fine!
    > >
    > > Good luck, and Happy New Year!
    > >
    > >
    > > "ten" wrote:
    > >
    > > > I have my hard drive configured with multiple logical drives and use the 'c'
    > > > drive just for the operating system. I just reloaded windows xp on my 'c'
    > > > drive after re-formatting the 'c' drive only. I have then installed all
    > > > updates but when I go into windows explorer and click on any folder on any of
    > > > the logical drives I receive and 'access denied' message. When I re-installed
    > > > I created a new user account other than the one I had previously used. How
    > > > can I make all these drives available again.
  5. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    In order to access the security tab in XP Home edition you're
    going to have to boot into Safe Mode. Restart your computer and
    keep pressing the F8 key until you see the startup menu and
    select Safe Mode. Make sure you are logged in with an account
    that has administrative status. Right click on the drives you
    want to access and select Properties. From the Security tab
    select Advanced. Follow the advice you received on taking
    ownership.

    Nepatsfan
    "ten" <ten@discussions.microsoft.com> wrote in message
    news:30AC3302-2CDE-4E32-A906-36D710BB24C6@microsoft.com...
    >I am running xp home edition. I tried both the 'properties' and
    >the 'sharing
    > but there is not a 'security' or advance button on either. Any
    > additional
    > assistance would be greatly appreciated.l
    >
    > "Danor" wrote:
    >
    >> Ten-
    >>
    >> I am going to presume two things:
    >> 1) You are running XP Pro;
    >> 2) You _had_ - before the reinstall - simple file sharing
    >> turned OFF
    >>
    >> It is very likely that the remaining un-reformated volumes
    >> (which you called
    >> logical drives, both terms are correct and somewhat
    >> appropriate but in this
    >> instance at this point you should think of it in terms of
    >> being a disk
    >> volume) access rights are based on the SID of the prior WinXP
    >> install's
    >> Administrator account (e.g. it may be called Administrator,
    >> but each time you
    >> install XP a new SecurityIDentifier is generated for each
    >> login account, and
    >> that's what XP actually uses in the security token that is
    >> reviewd when
    >> access is requested to any objcect: the SID _not_ the account
    >> name; however,
    >> there is a minor exception to this as regards to object
    >> ownership when
    >> AdministratorS is the owner - more details below.
    >>
    >> It is relatively easy to correct:
    >> Open your favorite Windows GUI (My Computer or Explorer or IE)
    >> and navigate
    >> to the disk voluem in question (let's say drive M:\...)
    >> Right-click the M:\-drive icon and select Sharing and Security
    >> (or
    >> Properties if that selection is not visible for some reason);
    >> Click on the Security Tab
    >> Click the Advanced button in lower-rgt region of Security
    >> window
    >> Click on the Ownership tab
    >> Select either the Administrator account or Administrators
    >> account as the new
    >> owner (read notes below before completing this procedure from
    >> this step on)
    >> Check the replace owner on subfolders box in lower-left area
    >> of this window
    >> Do NOT click OK just yet (unless you want to make it a
    >> two-step process; you
    >> won't hurt anything by clicking OK/Apply now, it is just a
    >> time-saver to wait
    >> at this point - but if you do want to two-step this, click
    >> Apply here not OK
    >> - there are considerations to be made, again see notes below):
    >> Click on the
    >> Permissions tab
    >> Review the listed permissions configuration and adjust as
    >> desired
    >> Click OK
    >>
    >> Notes:
    >> If you want just The Administrator to OWN the volume that's
    >> fine. There is a
    >> slight downside to that and that is if you do
    >> reformat/reinstall again, you
    >> will have to repeat this exercise all over as the
    >> Administrator SID will be
    >> assigned as the Object's Owner and not the Administrors Group.
    >> In XP, when the Administrators GROUP is assigned as the owner,
    >> then even
    >> after a reinstall and all SIDs get recreated, Objects that
    >> _were_ owned by
    >> and accessible to the old Administrators group are _still_
    >> owned by and
    >> accessible to the NEW Administrators group. This business of
    >> reapplying
    >> ownership is moot.
    >>
    >> Sometimes, depending on how the permissions were setup on the
    >> volume
    >> _before_ you reinstalled XP (especially on subdirectories
    >> underneath where
    >> inheritance was turned off and a new set of permissions set at
    >> that level) in
    >> order for all the permissions to work or get reset properly,
    >> you get the
    >> results you want by Applying the ownership change BEFORE
    >> changing any of the
    >> Permission entries on that tab, and then APPLYing/OKing the
    >> Permissions
    >> changes as well. But, if all you want to do is establish the
    >> base
    >> permissions on the root of the volume and then utilize
    >> inheritance to
    >> propgate those permissions throughout the tree below, then
    >> there is no need
    >> to APPLY Ownership separate from Permissions, you can save the
    >> time it will
    >> take XP to reapply your new settings by configuring the
    >> Permissions entries
    >> after the Ownership before clicking APPLY/OK.
    >>
    >> You'll need to go thru this exercise for each of your disk
    >> drive volumes
    >> (logical drives).
    >>
    >> Then.... everything should be fine!
    >>
    >> Good luck, and Happy New Year!
    >>
    >>
    >> "ten" wrote:
    >>
    >> > I have my hard drive configured with multiple logical drives
    >> > and use the 'c'
    >> > drive just for the operating system. I just reloaded windows
    >> > xp on my 'c'
    >> > drive after re-formatting the 'c' drive only. I have then
    >> > installed all
    >> > updates but when I go into windows explorer and click on any
    >> > folder on any of
    >> > the logical drives I receive and 'access denied' message.
    >> > When I re-installed
    >> > I created a new user account other than the one I had
    >> > previously used. How
    >> > can I make all these drives available again.
Ask a new question

Read More

Hard Drives Windows XP