Sign in with
Sign up | Sign in
Your question

System restore Tab missing!

Last response: in Windows XP
Share
Anonymous
a b 8 Security
January 15, 2005 11:53:02 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Cannot use the system restore feature. I am the administrator on this
computer. Also tried to use the system restore function in safe mode under
“administrator� login…still wont work.

Right click my computer icon>> properties
The system Restore Tab is missing

Looked online and some of the suggestions by other forum user

1. System Restore for Windows XP
http://www.kellys-korner-xp.com/xp_restore.htm

Go to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\SystemRestore.
If a "DisableSR" value doesn't exist, go to the Edit menu, select New, DWORD
value, and create the value.
Set the value to 1 to disable System Restore or 0 to enable System Restore.

The “DisableSR� value is set to 0

2. How to start the System Restore tool at a command prompt in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;304449

But I get he following message:
You do not have sufficient security privileges to restore your system.
Please contact your administrator, or logout and log in again as an
administrator and try again

3. How to troubleshoot the System Restore tool in Windows XP
http://support.microsoft.com/default.aspx?scid=KB;EN-US;q302796

I checked and it shows that my system restore function has been started I
followed the directions to go to the “Event Viewer�, but cannot see any
services starting with ‘sr’ in the “Event Viewer�

4. Also followed instructions under
http://www.microsoft.com/resources/documentation/window...

When I run esentutl /g %windir%\Security\Database\Secedit.sdb I get the
following message
“The database is no up-to-date. This operation may find that this database
is corrupt because data from the log files has yet to be placed in the
database�

I tried to run recovery using esentutl /r
%windir%\Security\Database\Secedit.sdb, I got the following message
“Operation terminated with error –1003�

Ran the repair using esentutl /p %windir%\Security\Database\Secedit.sdb

Note:
It is recommended that you immediately perform a full backup of this
database. If you restore a backup made before the repair, the database will
be rolled back to he state it was in at the time of that backup

Operation completed successfully in 5.598 seconds


Sorry for the long post...but I wanted to post everything i have done so far.
Please let me know if there is a workaround or a solution to this.
Thanks a lot!
Anonymous
a b 8 Security
January 15, 2005 6:13:09 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

"XPPro user" wrote:

> Cannot use the system restore feature.

Reinstall System Restore:

Reinstall System Restore.

Insert your XP CD
Click Start/Run and type:
rundll32.exe advpack.dll,LaunchINFSection C:\Windows\Inf\sr.inf

HTH,

Russell
Anonymous
a b 8 Security
January 15, 2005 7:15:02 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi
Thanks a lot for the info. I tried doing as you suggested..
I have the XP-Pro SP1 CD...so it asked me for a 'sr.sys' file on SP2 CD...so
I looked under C:\WINDOWS\ServicePackFiles\i386 and found the file...
Then it asked for a 'srframe.mmf' file on XP-Pro CD...so I found that file
under D:\I386...and it completed the process.

I still cannot see the system restore tab and i still get the same
'administrator' message.

I tried to restart the system and still cant see the Tab.

Is there anything that I did wrong?
Thanks for help!


"Sickputer" wrote:

>
>
> "XPPro user" wrote:
>
> > Cannot use the system restore feature.
>
> Reinstall System Restore:
>
> Reinstall System Restore.
>
> Insert your XP CD
> Click Start/Run and type:
> rundll32.exe advpack.dll,LaunchINFSection C:\Windows\Inf\sr.inf
>
> HTH,
>
> Russell
Related resources
Anonymous
a b 8 Security
January 15, 2005 8:53:03 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

May be more underlying system corruption. Try using System File Checker. At
Start/Run type: sfc /scannow (if it finishes silently it finds
nothing to fix...if it finds files corrupt you will need to insert your CD).

HTH,

Russell
Anonymous
a b 8 Security
January 16, 2005 10:35:05 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi Russell,

I ran sfc /scannow...and it didnt find anything to fix.

Do you have any other ideas?
Thanks a lot for your inputs.

XPPro user


"Sickputer" wrote:

>
> May be more underlying system corruption. Try using System File Checker. At
> Start/Run type: sfc /scannow (if it finishes silently it finds
> nothing to fix...if it finds files corrupt you will need to insert your CD).
>
> HTH,
>
> Russell
Anonymous
a b 8 Security
January 16, 2005 4:11:18 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi, I don't have XP Pro but perhaps this may be of assistance:-

System Restore Tab Missing
Check your settings here: For Pro: Start/Run/gpedit.msc. Computer Configuration,
Administrative Templates, System, System Restore.

Re-Enabling System Restore (WinXP Pro)
If you previously disabled system restore through the Group Policy Editor, the option
to start it again does not show in the System Properties. You can re-enable it again
by:

1. Run the Group Policy Editor (gpedit.msc)
2. Go to Computer Configuration / Administrative Templates / System / System Restore
3. Set Turn off System Restore and Turn off Configuration to Disable
4. Right click on My Computer
5. Select Manage
6. Go to Services and Applications / Services
7. Scroll down to System Restore Service
8. Set it for Automatic
9. Click on the Start button to start the service
10. Close down this window
11. Go back to the Group Policy Editor and configure both to Not configured
12. Now when you right click on My Computer, there should be a tab for System Restore
and you can configure how much space will be used.


"XPPro user" <XPProuser@discussions.microsoft.com> wrote in message
news:E2937811-085C-4ECF-84D6-DA651398C2FE@microsoft.com...
> Cannot use the system restore feature. I am the administrator on this
> computer. Also tried to use the system restore function in safe mode under
> “administrator� login…still wont work.
>
> Right click my computer icon>> properties
> The system Restore Tab is missing
>
> Looked online and some of the suggestions by other forum user
>
> 1. System Restore for Windows XP
> http://www.kellys-korner-xp.com/xp_restore.htm
>
> Go to
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\SystemRestore.
> If a "DisableSR" value doesn't exist, go to the Edit menu, select New, DWORD
> value, and create the value.
> Set the value to 1 to disable System Restore or 0 to enable System Restore.
>
> The “DisableSR� value is set to 0
>
> 2. How to start the System Restore tool at a command prompt in Windows XP
> http://support.microsoft.com/default.aspx?scid=kb;en-us;304449
>
> But I get he following message:
> You do not have sufficient security privileges to restore your system.
> Please contact your administrator, or logout and log in again as an
> administrator and try again
>
> 3. How to troubleshoot the System Restore tool in Windows XP
> http://support.microsoft.com/default.aspx?scid=KB;EN-US;q302796
>
> I checked and it shows that my system restore function has been started I
> followed the directions to go to the “Event Viewer�, but cannot see any
> services starting with ‘sr’ in the “Event Viewer�
>
> 4. Also followed instructions under
> http://www.microsoft.com/resources/documentation/window...
>
> When I run esentutl /g %windir%\Security\Database\Secedit.sdb I get the
> following message
> “The database is no up-to-date. This operation may find that this database
> is corrupt because data from the log files has yet to be placed in the
> database�
>
> I tried to run recovery using esentutl /r
> %windir%\Security\Database\Secedit.sdb, I got the following message
> “Operation terminated with error –1003�
>
> Ran the repair using esentutl /p %windir%\Security\Database\Secedit.sdb
>
> Note:
> It is recommended that you immediately perform a full backup of this
> database. If you restore a backup made before the repair, the database will
> be rolled back to he state it was in at the time of that backup
>
> Operation completed successfully in 5.598 seconds
>
>
> Sorry for the long post...but I wanted to post everything i have done so far.
> Please let me know if there is a workaround or a solution to this.
> Thanks a lot!
Anonymous
a b 8 Security
January 16, 2005 4:11:19 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi Taurarian,
I tried the solution that you have suggested, but still cannot get the tab.
Thanks for your input.
Any other ideas?

XPPro user



"Taurarian" wrote:

> Hi, I don't have XP Pro but perhaps this may be of assistance:-
>
> System Restore Tab Missing
> Check your settings here: For Pro: Start/Run/gpedit.msc. Computer Configuration,
> Administrative Templates, System, System Restore.
>
> Re-Enabling System Restore (WinXP Pro)
> If you previously disabled system restore through the Group Policy Editor, the option
> to start it again does not show in the System Properties. You can re-enable it again
> by:
>
> 1. Run the Group Policy Editor (gpedit.msc)
> 2. Go to Computer Configuration / Administrative Templates / System / System Restore
> 3. Set Turn off System Restore and Turn off Configuration to Disable
> 4. Right click on My Computer
> 5. Select Manage
> 6. Go to Services and Applications / Services
> 7. Scroll down to System Restore Service
> 8. Set it for Automatic
> 9. Click on the Start button to start the service
> 10. Close down this window
> 11. Go back to the Group Policy Editor and configure both to Not configured
> 12. Now when you right click on My Computer, there should be a tab for System Restore
> and you can configure how much space will be used.
>
>
> "XPPro user" <XPProuser@discussions.microsoft.com> wrote in message
> news:E2937811-085C-4ECF-84D6-DA651398C2FE@microsoft.com...
> > Cannot use the system restore feature. I am the administrator on this
> > computer. Also tried to use the system restore function in safe mode under
> > “administrator� login…still wont work.
> >
> > Right click my computer icon>> properties
> > The system Restore Tab is missing
> >
> > Looked online and some of the suggestions by other forum user
> >
> > 1. System Restore for Windows XP
> > http://www.kellys-korner-xp.com/xp_restore.htm
> >
> > Go to
> > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\SystemRestore.
> > If a "DisableSR" value doesn't exist, go to the Edit menu, select New, DWORD
> > value, and create the value.
> > Set the value to 1 to disable System Restore or 0 to enable System Restore.
> >
> > The “DisableSR� value is set to 0
> >
> > 2. How to start the System Restore tool at a command prompt in Windows XP
> > http://support.microsoft.com/default.aspx?scid=kb;en-us;304449
> >
> > But I get he following message:
> > You do not have sufficient security privileges to restore your system.
> > Please contact your administrator, or logout and log in again as an
> > administrator and try again
> >
> > 3. How to troubleshoot the System Restore tool in Windows XP
> > http://support.microsoft.com/default.aspx?scid=KB;EN-US;q302796
> >
> > I checked and it shows that my system restore function has been started I
> > followed the directions to go to the “Event Viewer�, but cannot see any
> > services starting with ‘sr’ in the “Event Viewer�
> >
> > 4. Also followed instructions under
> > http://www.microsoft.com/resources/documentation/window...
> >
> > When I run esentutl /g %windir%\Security\Database\Secedit.sdb I get the
> > following message
> > “The database is no up-to-date. This operation may find that this database
> > is corrupt because data from the log files has yet to be placed in the
> > database�
> >
> > I tried to run recovery using esentutl /r
> > %windir%\Security\Database\Secedit.sdb, I got the following message
> > “Operation terminated with error –1003�
> >
> > Ran the repair using esentutl /p %windir%\Security\Database\Secedit.sdb
> >
> > Note:
> > It is recommended that you immediately perform a full backup of this
> > database. If you restore a backup made before the repair, the database will
> > be rolled back to he state it was in at the time of that backup
> >
> > Operation completed successfully in 5.598 seconds
> >
> >
> > Sorry for the long post...but I wanted to post everything i have done so far.
> > Please let me know if there is a workaround or a solution to this.
> > Thanks a lot!
>
>
Anonymous
a b 8 Security
January 16, 2005 4:11:20 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Enable Hidden Folders and Files and delete the contents of System Volume
Information folder. Empty the Recycle Bin. Reboot and see if you regain your
icon.

If it re-appears set the slide bar to 10% instead of the 12% default.

Also try a temp file cleanup using Steven Gould's freeware program Cleanup!

http://cleanup.stevengould.org

Excellent program...the one precaution is to click on the Options button and
make sure you don't have Favorites or Cookies enabled for deletion. Also
check the box to Fully Erase Files. This program does a far better job than
Disk Cleanup! Don't give up on it when it stalls on a file...it will pick
back up after a couple of minutes. Wait until it asks to log off to clean
remaining files. I have seen this program run for hours on machines really
loaded down with temp files. After the first time, run it daily to keep your
machine running well. I use it probably twice a day. The cool thing about
this program is it will clean all temp files in all Windows profiles. I ran
it on a machine with twenty profiles and it ran for 10 hours clearing all the
junk. On most machines that haven't ever been cleaned it will run about 30
minutes for the first pass. Subsequent cleanings will be very quick.

HTH,

Russell
Anonymous
a b 8 Security
January 17, 2005 8:47:04 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

HI,
I tried what you suggested, but I get the message "Cannot Access System
Volume Information: Access is denied"

Now I have tried it logging on as an administratoe in safe mode as well as
in the normal mode...get the same message both the times...


XPPro user




"Sickputer" wrote:

> Enable Hidden Folders and Files and delete the contents of System Volume
> Information folder. Empty the Recycle Bin. Reboot and see if you regain your
> icon.
>
> If it re-appears set the slide bar to 10% instead of the 12% default.
>
> Also try a temp file cleanup using Steven Gould's freeware program Cleanup!
>
> http://cleanup.stevengould.org
>
> Excellent program...the one precaution is to click on the Options button and
> make sure you don't have Favorites or Cookies enabled for deletion. Also
> check the box to Fully Erase Files. This program does a far better job than
> Disk Cleanup! Don't give up on it when it stalls on a file...it will pick
> back up after a couple of minutes. Wait until it asks to log off to clean
> remaining files. I have seen this program run for hours on machines really
> loaded down with temp files. After the first time, run it daily to keep your
> machine running well. I use it probably twice a day. The cool thing about
> this program is it will clean all temp files in all Windows profiles. I ran
> it on a machine with twenty profiles and it ran for 10 hours clearing all the
> junk. On most machines that haven't ever been cleaned it will run about 30
> minutes for the first pass. Subsequent cleanings will be very quick.
>
> HTH,
>
> Russell
>
Anonymous
a b 8 Security
January 17, 2005 9:21:09 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Is this a standalone computer or are you part of a domain?
Anonymous
a b 8 Security
January 17, 2005 9:29:03 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

This is a standalone

"jgormlyjr@cinci.rr.com" wrote:

> Is this a standalone computer or are you part of a domain?
>
>
Anonymous
a b 8 Security
January 17, 2005 10:55:02 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi Russell,
I finally got access to the System Volume Information folder...I tried
deleting all its contents as you suggested but I got the following message
"Cannot delete change.log.1. File in use by another user"

Should I just ignore that and delete all the other contents?

Thanks,

XPPro user




"Sickputer" wrote:

> Enable Hidden Folders and Files and delete the contents of System Volume
> Information folder. Empty the Recycle Bin. Reboot and see if you regain your
> icon.
>
> If it re-appears set the slide bar to 10% instead of the 12% default.
>
> Also try a temp file cleanup using Steven Gould's freeware program Cleanup!
>
> http://cleanup.stevengould.org
>
> Excellent program...the one precaution is to click on the Options button and
> make sure you don't have Favorites or Cookies enabled for deletion. Also
> check the box to Fully Erase Files. This program does a far better job than
> Disk Cleanup! Don't give up on it when it stalls on a file...it will pick
> back up after a couple of minutes. Wait until it asks to log off to clean
> remaining files. I have seen this program run for hours on machines really
> loaded down with temp files. After the first time, run it daily to keep your
> machine running well. I use it probably twice a day. The cool thing about
> this program is it will clean all temp files in all Windows profiles. I ran
> it on a machine with twenty profiles and it ran for 10 hours clearing all the
> junk. On most machines that haven't ever been cleaned it will run about 30
> minutes for the first pass. Subsequent cleanings will be very quick.
>
> HTH,
>
> Russell
>
Anonymous
a b 8 Security
February 19, 2005 2:55:23 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi,

I havent' been following this thread completely, so maybe you've already
received this tip.

I have been experiencing something similar in
a corporate environment: Local Administrators and
domain users addedd to the Local Admin Group were
unable to use SystemRestore: "insufficient privileges".

The resolution was this, maybe it helps you too:
The user attempting to do a system restore needs
this user right assigned: "Back up files and directories"
On my workstation I have this right assigned to:
Administrators, Backup Operators
(Local Security Policy -> Local Policies -> User Rights Assignment)

cheers,
didier
Anonymous
a b 8 Security
February 22, 2005 9:39:01 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi Didier,
I had tried to do this. But my system gets stuck before "User Rights
Assignment" window. Nothing comes up even after waiting for 5 minutes....so I
cannot access that.
Anyway Thanks for your suggestion.



"Didier Leimbach" wrote:

> Hi,
>
> I havent' been following this thread completely, so maybe you've already
> received this tip.
>
> I have been experiencing something similar in
> a corporate environment: Local Administrators and
> domain users addedd to the Local Admin Group were
> unable to use SystemRestore: "insufficient privileges".
>
> The resolution was this, maybe it helps you too:
> The user attempting to do a system restore needs
> this user right assigned: "Back up files and directories"
> On my workstation I have this right assigned to:
> Administrators, Backup Operators
> (Local Security Policy -> Local Policies -> User Rights Assignment)
>
> cheers,
> didier
>
>
>
Anonymous
a b 8 Security
August 21, 2005 6:23:00 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi XPRO User,

I think we may be having similar problems. In my case I can't update to
SP2 or get any other updates. Others are having this problem and I
haven't found a satisfactory solution. I also cannot see the System
Restore tab.

I think Didier is on to something. I've used gpedit.msc to manage group
permissions. Under Computer configuration/windows settings/security
settings/local policies/user rights assignments/

The options: act as part of the operating system, log on as a service,
and restore files and directories contain group policy
S-1-5-21-2474407962-1462291171-2481021255-1146, this group policy does
not exist anywhere in the registry and these are the only settings
where I can't assign users or groups. I believe that this policy's
control
of Restore Files and Directories is causing the permission problem (and
inability to see the System Restore Tab) but I don't know to fix it.

I had a virus a couple years ago and I remember that the fix involved
removing policies from the registry. I'm no longer on a network domain
so I don't need any network settings. Anyone know what can be done to
change these settings?


Thanks,
Bob


--
bob_piper
------------------------------------------------------------------------
bob_piper's Profile: http://forums.techarena.in/member.php?userid=8412
View this thread: http://forums.techarena.in/showthread.php?t=38465
Visit - http://www.techarena.in | http://forums.techarena.in | http://gallery.techarena.in
March 27, 2012 1:05:16 AM

Quote:
Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Enable Hidden Folders and Files and delete the contents of System Volume
Information folder. Empty the Recycle Bin. Reboot and see if you regain your
icon.
HTH,

Russell


I finally managed to get MY tab back, by booting UBCD4win, so I was completely independent from the drives being accessed, and deleted the contents of ALL System Volume Information directories from all three drives; and then rebooting.

I guess, in my case, Windows got confused as to which drives I was booting from or working from in doing some rather HUGE copying from drive-to-drive to save time ... which probably also corrupted the sys-vol-inf directory in at least one of the drives.

Normally, the best way to *avoid* this sort of problem is to turn OFF Windows Restore before doing the big copies that might copy one volume's information over another ... and screw things all up!

Windows, of course, won't just LET you go out and delete that information yourself.
It locks out the directory, so you can't even look in it, let alone delete it.

The *normal* way to remove all the *crap* in the System Volume Information directory, is to temporarily disable System Recovery, and then, if you want-to, restore it. That clears out all of your old restore-points; but if you have a good one, then that gives you a known clean start.
!