Sign in with
Sign up | Sign in
Your question

remote access security

Last response: in Windows XP
Share
January 21, 2005 10:51:24 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I have recently set up an internet server using windows xp, a router and pc
anywhere. Remote access to the internal network is fine with access to mapped
drives within the network. however, i now want to restrict access to the 'c'
drive of the internet server but still allow access to the rest of the
internal network. How can i password protect or protect in any otehr way the
hard drive of this machine? Using the share option does not appear to give me
any permissions etc to set.

More about : remote access security

Anonymous
a b 8 Security
January 21, 2005 3:41:20 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi,
If you are using Windows XP Home then you are limited in ways of
setting permissions.

If you are using Professional then you can fine tune both Share and
NTFS permissions (if your drive C: is formated with NTFS file system).
You can not set permissions directly on the root of C: drive, you can
set them on the folders created on the C: drive. Now by default, root
of a drive is not shared to the public so anyone who logs on to your
computer should not be able to see the C: drive of the server, they
should only be able to see folders that you have set up as shared.

If your C: drive is formated with any other file system, like FAT or
FAT32, that you are out of luck, no permissions for those, everyone who
successfully logs on can do whatever they want on your computer.

Open "My Computer" and left click once on the C: drive. On the left
side in the "Details" field it will show what file system is in use.

If your C: drive is FAT or FAT32 then I suggest you use this command to
make it NTFS: convert c: /fs:ntfs
After reboot, C: drive will be converted to NTFS file system and you
will be able to protect it. The process will preserve all your data on
the drive but you should make a fresh backup before you issue the
command, just to be on the safe side.
Anonymous
a b 8 Security
January 21, 2005 7:52:58 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

One more thing, did you disable simple file sharing ? If it's turned on
it will prevent you from setting up permissions.

To disable simple file sharing:
1. Click Start, and then click My Computer.
2. On the Tools menu, click Folder Options, and then click the View
tab.
3. In the Advanced Settings section, clear the "Use simple file sharing
(Recommended)" check box.
4. Click OK.
!