Sign in with
Sign up | Sign in
Your question

Blank video window on TV display?

Last response: in Graphics & Displays
Share
Anonymous
a b C Monitor
July 2, 2004 11:18:04 PM

Archived from groups: alt.comp.periphs.videocards.ati (More info?)

I'm trying to hook up my All-In-Wonder 9000 video output to a TV
monitor to display video. The TV display is detected, and a copy of
the Windows desktop appears on it, duplicating the regular computer
monitor display. Except when I try to show a video - the video window
is fine on the PC monitor, but blank on the TV display. What's wrong
and how can I fix it?

I suspect it's something to do with DirectX writing directly to the
video display memory for the main monitor only. I've tried playing
around with the ATI Display settings, and I can't seem to do anything
about it. If try to turn off the computer monitor, it turns off the TV
too. I guess I could try booting without the computer monitor
connected, but that seems to be a pretty awkward workaround.
July 3, 2004 12:04:53 PM

Archived from groups: alt.comp.periphs.videocards.ati (More info?)

This is how it is supposed to be, video overlay is not (and cannot be) shown
on secondary monitor windowed. In order to see video on your TV you need to
go to CAT settings section "Overlay" and "Clone mode options". There enable
"Theater mode". Your desktop is still shown normally, but when you start
video playback, the video will automatically go full screen on your TV.

And you are right about direct memory writing. Video overlay is just that,
the image is drawn directly into video card memory. It is not part of the
desktop image, therefore it is not dublicated via simple clone mode. It
needs to be shown full screen (that is, only one or the other can shown,
desktop or the video). That's also the reason why you cannot "take a
picture" of your video playback simply by pressing 'print screen'. The video
overlay isn't part of the desktop which is captured. You need a video
editing program for that (or some playback program that has frame capture
capability).


"FelixC" <felixcct@yahoo.com> wrote in message
news:7bce31ab.0407021818.4ce3bae2@posting.google.com...
> I'm trying to hook up my All-In-Wonder 9000 video output to a TV
> monitor to display video. The TV display is detected, and a copy of
> the Windows desktop appears on it, duplicating the regular computer
> monitor display. Except when I try to show a video - the video window
> is fine on the PC monitor, but blank on the TV display. What's wrong
> and how can I fix it?
>
> I suspect it's something to do with DirectX writing directly to the
> video display memory for the main monitor only. I've tried playing
> around with the ATI Display settings, and I can't seem to do anything
> about it. If try to turn off the computer monitor, it turns off the TV
> too. I guess I could try booting without the computer monitor
> connected, but that seems to be a pretty awkward workaround.
Anonymous
a b C Monitor
July 3, 2004 3:59:12 PM

Archived from groups: alt.comp.periphs.videocards.ati (More info?)

Vellu wrote:
> This is how it is supposed to be, video overlay is not (and cannot be) shown
> on secondary monitor windowed. In order to see video on your TV you need to
> go to CAT settings section "Overlay" and "Clone mode options". There enable
> "Theater mode". Your desktop is still shown normally, but when you start
> video playback, the video will automatically go full screen on your TV.

Thanks, that works. I see that there's a choice of having the video go
to full-screen on the TV, or staying in a window. Either one works.

I'm a little puzzled as to why this isn't the default setting (clone
video in window). The setting seems obscure and buried deep in the
interface. I don't see any performance impact. Why have to go the
extra step to "enable" the expected behaviour?
Related resources
Anonymous
a b C Monitor
July 4, 2004 3:43:56 PM

Archived from groups: alt.comp.periphs.videocards.ati (More info?)

FelixC wrote: in message > Vellu wrote:
> > This is how it is supposed to be, video overlay is not (and cannot be) shown
> > on secondary monitor windowed. In order to see video on your TV you need to
> > go to CAT settings section "Overlay" and "Clone mode options". There enable
> > "Theater mode". Your desktop is still shown normally, but when you start
> > video playback, the video will automatically go full screen on your TV.
>
> Thanks, that works. I see that there's a choice of having the video go
> to full-screen on the TV, or staying in a window. Either one works.

I've been playing around a bit more, and I have to say that ATI's user
interface and functionality is extremely frustrating.

Pardon the venting, but they could teach a class in "how not to design
a user interface" based this ATI driver software. The documentation
and help stinks. Almost nothing works intuitively or as expected.
Random experimentation for hours seems to be the only way to find out
anything.

Especially annoying is the problem that playing with the "TV" controls
seems to affect the computer monitor display in various unexpected
ways, depending on what other cryptic control options are set. Now
I've got it in a mode where the computer monitor goes to full screen
and the TV doesn't when a video starts. I can't seem to convince it
otherwise. Looks like a registry restore and start again is the only
way to fix it.
July 5, 2004 1:05:40 AM

Archived from groups: alt.comp.periphs.videocards.ati (More info?)

True, it's quite "buried" in there...I'd prefer it to be in the Displays
tab, right next to where you actually enable TV-out/Clone mode. As to why
it's not default, I believe it has something to do with the fact that not
everyone plugs their TV into their computer.

"FelixC" <felixcct@yahoo.com> wrote in message
news:7bce31ab.0407031059.42548808@posting.google.com...
> Vellu wrote:
> > This is how it is supposed to be, video overlay is not (and cannot be)
shown
> > on secondary monitor windowed. In order to see video on your TV you need
to
> > go to CAT settings section "Overlay" and "Clone mode options". There
enable
> > "Theater mode". Your desktop is still shown normally, but when you start
> > video playback, the video will automatically go full screen on your TV.
>
> Thanks, that works. I see that there's a choice of having the video go
> to full-screen on the TV, or staying in a window. Either one works.
>
> I'm a little puzzled as to why this isn't the default setting (clone
> video in window). The setting seems obscure and buried deep in the
> interface. I don't see any performance impact. Why have to go the
> extra step to "enable" the expected behaviour?
July 5, 2004 1:08:11 AM

Archived from groups: alt.comp.periphs.videocards.ati (More info?)

It's indeed far from user friendly. Though other manufactures have some
problems aswell. Do Nvidia users still need to use TVTool (an external
program) to get their TV-outs working properly?

>
> I've been playing around a bit more, and I have to say that ATI's user
> interface and functionality is extremely frustrating.
>
> Pardon the venting, but they could teach a class in "how not to design
> a user interface" based this ATI driver software. The documentation
> and help stinks. Almost nothing works intuitively or as expected.
> Random experimentation for hours seems to be the only way to find out
> anything.
>
> Especially annoying is the problem that playing with the "TV" controls
> seems to affect the computer monitor display in various unexpected
> ways, depending on what other cryptic control options are set. Now
> I've got it in a mode where the computer monitor goes to full screen
> and the TV doesn't when a video starts. I can't seem to convince it
> otherwise. Looks like a registry restore and start again is the only
> way to fix it.
!