Sign in with
Sign up | Sign in
Your question
Closed

Moving 'All Users' shared documents folder

Last response: in Windows XP
Share
Anonymous
February 13, 2005 8:05:16 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

If I open an explorer window (computer's resources) I can see a 'shortcut' named
'Shared Documents' to the Documents folder under 'All User' profile.
I moved the 'All Users' Documents folder to another position in the
file system.

Now If I open explorer I can see the shortcut but its same is just the
folder's name, not 'Shared Documents' as before.

1) How can I have the icon named 'Shared Documents' again?
2) How can Window XP do that? Can I use the same feature elsewhere?
--
Plinio Conti <pliniocontiATtiscaliDOTit>
February 13, 2005 11:13:35 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

you assumed the wrong way to move the Documents folder.

to learn the right way to move the Documents folder, use
Help and Support from the Start button, type in the Search box the words
"move Documents folder", and click on the link labeled
"How to Change the Default Location of the My Documents Folder"
under Microsoft Knowledge Base.


Plinio Conti wrote:
> If I open an explorer window (computer's resources) I can see a 'shortcut' named
> 'Shared Documents' to the Documents folder under 'All User' profile.
> I moved the 'All Users' Documents folder to another position in the
> file system.
>
> Now If I open explorer I can see the shortcut but its same is just the
> folder's name, not 'Shared Documents' as before.
>
> 1) How can I have the icon named 'Shared Documents' again?
> 2) How can Window XP do that? Can I use the same feature elsewhere?
Anonymous
February 15, 2005 1:09:11 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

No. I used exactly that way to redirect "My Documents" shortcut to
another folder (by the way: I failed to redirect "My Documents" for new
users editing ".default" profile. Any idea?).

But my question was about something different. I moved "All Users"
Documents folder, which under Explorer used to be displayed as "Shared
Documents". Basically I got it editing
"HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell
Folders" and
HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders".

That worked. Now the link in Explorer brings me to elsewhere (ex.
D:\SharedDocs), and no more to "C:\Documents and Settings\All
Users\Documents". The problem is the "magic name behaviour" disappeared:
the link in Explorer windows is not called "Shared Documents" anymore:
it just takes the name of the folder (say "SharedDocs" in the previous
example)

Thank you.


> you assumed the wrong way to move the Documents folder.
>
> to learn the right way to move the Documents folder, use
> Help and Support from the Start button, type in the Search box the words
> "move Documents folder", and click on the link labeled
> "How to Change the Default Location of the My Documents Folder"
> under Microsoft Knowledge Base.
>
>
> Plinio Conti wrote:
> > If I open an explorer window (computer's resources) I can see a 'shortcut' named
> > 'Shared Documents' to the Documents folder under 'All User' profile.
> > I moved the 'All Users' Documents folder to another position in the
> > file system.
> >
> > Now If I open explorer I can see the shortcut but its same is just the
> > folder's name, not 'Shared Documents' as before.
> >
> > 1) How can I have the icon named 'Shared Documents' again?
> > 2) How can Window XP do that? Can I use the same feature elsewhere?

--
Plinio Conti <pliniocontiATtiscaliDOTit>
Related resources
Anonymous
February 17, 2005 12:39:55 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

No. I used exactly that way to redirect "My Documents" shortcut to
another folder (by the way: I failed to redirect "My Documents" for new
users editing ".default" profile. Any idea?).

But my question was about something different. I moved "All Users"
Documents folder, which under Explorer used to be displayed as "Shared
Documents". Basically I got it editing
"HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell
Folders" and
HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders".

That worked. Now the link in Explorer brings me to elsewhere (ex.
D:\SharedDocs), and no more to "C:\Documents and Settings\All
Users\Documents". The problem is the "magic name behaviour" disappeared:
the link in Explorer windows is not called "Shared Documents" anymore:
it just takes the name of the folder (say "SharedDocs" in the previous
example)

Thank you.


> you assumed the wrong way to move the Documents folder.
>
> to learn the right way to move the Documents folder, use
> Help and Support from the Start button, type in the Search box the words
> "move Documents folder", and click on the link labeled
> "How to Change the Default Location of the My Documents Folder"
> under Microsoft Knowledge Base.
>
>
> Plinio Conti wrote:
> > If I open an explorer window (computer's resources) I can see a 'shortcut' named
> > 'Shared Documents' to the Documents folder under 'All User' profile.
> > I moved the 'All Users' Documents folder to another position in the
> > file system.
> >
> > Now If I open explorer I can see the shortcut but its same is just the
> > folder's name, not 'Shared Documents' as before.
> >
> > 1) How can I have the icon named 'Shared Documents' again?
> > 2) How can Window XP do that? Can I use the same feature elsewhere?

--
Plinio Conti <pliniocontiATtiscaliDOTit>
July 20, 2009 1:49:05 AM

To have the folder "Documents" display in Windows Explorer as "Shared Documents" you have to have the proper "desktop.ini" file in the folder. "desktop.ini" is normally a Hidden, System, Read-only file. You can reveal it by the cmdline: "Attrib -H -R -S desktop.ini" (provided it exists. Most likely it is missing). Simply make a two line desktop.txt file then rename it to desktop.ini, then use cmdline: "Attrib +H +S +R desktop.ini" to hide it. In the All User's "Document" folder in Windows xp, my desktop.ini file contains exactly the following two lines:

[.ShellClassInfo]
LocalizedResourceName=@shell32.dll,-21785

If I delete this file, then I get exactly the problem you describe--"Shared Documents" is gone and I have "Documents" in its place.
Anonymous
April 11, 2011 1:32:46 AM

What worked for me is "D:\Documents and Settings\All Users\Documents"

Make sure there is no folder named "D:\Documents and Settings\All Users\Documents" first then go search the registry for:

HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

change "%ALLUSERSPROFILE%\Documents" to the non-existing folder:

"D:\Documents and Settings\All Users\Documents" then log off then log back in.

Windows will create the folder and magically rename it to "Shared Documents"
April 11, 2011 2:44:21 AM

This topic has been closed by Buwish
!