Closed

Automatic Update is disabled

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I have XP Professional with SP2. The Automatic Update is disabled. If click
on "Turn on Automatic Updates" in the Security Center, I get an error statig:
We're sorry the Security Center could not change your settings. Try changing
it yourself in control Panel"

When I click on Automatic Updated in Control panel, all radio buttons are
grayed out.

How do I re enable Automatic updates. Thanks
11 answers Last reply
More about automatic update disabled
  1. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Hi there, perhaps this will assist:

    Automatic updates greyed out
    Click Start, select run and type in: services.msc,
    Now scroll down to the autoupdate service and double click it.
    Start it and set the startup type to automatic, then reboot.

    “The Windows Update Service is not available" and all of the check boxes and
    drop-down menus are greyed out. This can happen if the Automatic Update service is
    disabled.

    Click Start, select Run and type: Services.msc
    Press Enter
    Locate the - "Automatic Update"
    Make sure the service is not disabled and started.

    "The Windows Update Service is not available" and all of the check boxes and
    drop-down menus are greyed out. Automatic Update Service is missing from the
    services.msc list.
    Can happen if the wuaueng.dll file is not registered.

    Register the file wuaueng.dll:
    Click Start, select Run
    Type: regsvr32 wuaueng.dll
    Press OK.

    If all else fails:
    Windows Update Greyed Out - Restore (Line 179)
    http://www.kellys-korner-xp.com/xp_tweaks.htm


    "Rohit" <Rohit@discussions.microsoft.com> wrote in message
    news:6EB0BE55-D444-4D05-9DD4-532BEC6A9426@microsoft.com...
    >I have XP Professional with SP2. The Automatic Update is disabled. If click
    > on "Turn on Automatic Updates" in the Security Center, I get an error statig:
    > We're sorry the Security Center could not change your settings. Try changing
    > it yourself in control Panel"
    >
    > When I click on Automatic Updated in Control panel, all radio buttons are
    > grayed out.
    >
    > How do I re enable Automatic updates. Thanks
  2. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    thanks

    "Taurarian" wrote:

    > Hi there, perhaps this will assist:
    >
    > Automatic updates greyed out
    > Click Start, select run and type in: services.msc,
    > Now scroll down to the autoupdate service and double click it.
    > Start it and set the startup type to automatic, then reboot.
    >
    > “The Windows Update Service is not available" and all of the check boxes and
    > drop-down menus are greyed out. This can happen if the Automatic Update service is
    > disabled.
    >
    > Click Start, select Run and type: Services.msc
    > Press Enter
    > Locate the - "Automatic Update"
    > Make sure the service is not disabled and started.
    >
    > "The Windows Update Service is not available" and all of the check boxes and
    > drop-down menus are greyed out. Automatic Update Service is missing from the
    > services.msc list.
    > Can happen if the wuaueng.dll file is not registered.
    >
    > Register the file wuaueng.dll:
    > Click Start, select Run
    > Type: regsvr32 wuaueng.dll
    > Press OK.
    >
    > If all else fails:
    > Windows Update Greyed Out - Restore (Line 179)
    > http://www.kellys-korner-xp.com/xp_tweaks.htm
    >
    >
    > "Rohit" <Rohit@discussions.microsoft.com> wrote in message
    > news:6EB0BE55-D444-4D05-9DD4-532BEC6A9426@microsoft.com...
    > >I have XP Professional with SP2. The Automatic Update is disabled. If click
    > > on "Turn on Automatic Updates" in the Security Center, I get an error statig:
    > > We're sorry the Security Center could not change your settings. Try changing
    > > it yourself in control Panel"
    > >
    > > When I click on Automatic Updated in Control panel, all radio buttons are
    > > grayed out.
    > >
    > > How do I re enable Automatic updates. Thanks
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    You're welcome.
    Kaylene

    Rohit wrote:
    > thanks
    >
    > "Taurarian" wrote:
    >
    >> Hi there, perhaps this will assist:
    >>
    >> Automatic updates greyed out
    >> Click Start, select run and type in: services.msc,
    >> Now scroll down to the autoupdate service and double click it.
    >> Start it and set the startup type to automatic, then reboot.
    >>
    >> “The Windows Update Service is not available" and all of the check
    >> boxes and drop-down menus are greyed out. This can happen if the
    >> Automatic Update service is disabled.
    >>
    >> Click Start, select Run and type: Services.msc
    >> Press Enter
    >> Locate the - "Automatic Update"
    >> Make sure the service is not disabled and started.
    >>
    >> "The Windows Update Service is not available" and all of the check
    >> boxes and drop-down menus are greyed out. Automatic Update Service
    >> is missing from the services.msc list.
    >> Can happen if the wuaueng.dll file is not registered.
    >>
    >> Register the file wuaueng.dll:
    >> Click Start, select Run
    >> Type: regsvr32 wuaueng.dll
    >> Press OK.
    >>
    >> If all else fails:
    >> Windows Update Greyed Out - Restore (Line 179)
    >> http://www.kellys-korner-xp.com/xp_tweaks.htm
    >>
    >>
    >> "Rohit" <Rohit@discussions.microsoft.com> wrote in message
    >> news:6EB0BE55-D444-4D05-9DD4-532BEC6A9426@microsoft.com...
    >>> I have XP Professional with SP2. The Automatic Update is disabled.
    >>> If click on "Turn on Automatic Updates" in the Security Center, I
    >>> get an error statig: We're sorry the Security Center could not
    >>> change your settings. Try changing it yourself in control Panel"
    >>>
    >>> When I click on Automatic Updated in Control panel, all radio
    >>> buttons are grayed out.
    >>>
    >>> How do I re enable Automatic updates. Thanks
  4. Unfortunately what is suggested here didn't work for me. Turns out it was a trojan that was stopping the update service and disabling Norton Internet Security (my anti virus program). Norton has a program that I downloaded and that couldn't even get it. A friend of mine recently told me about AVG Anti Virus so I gave it a shot and it actually removed the virus. I was able to get the services started and I'm back in action! Just thought I'd share in case anyone else is beating their head against a wall like me. ;-)
  5. Quote:
    Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Hi there, perhaps this will assist:

    Automatic updates greyed out
    Click Start, select run and type in: services.msc,
    Now scroll down to the autoupdate service and double click it.
    Start it and set the startup type to automatic, then reboot.

    “The Windows Update Service is not available" and all of the check boxes and
    drop-down menus are greyed out. This can happen if the Automatic Update service is
    disabled.

    Click Start, select Run and type: Services.msc
    Press Enter
    Locate the - "Automatic Update"
    Make sure the service is not disabled and started.

    "The Windows Update Service is not available" and all of the check boxes and
    drop-down menus are greyed out. Automatic Update Service is missing from the
    services.msc list.
    Can happen if the wuaueng.dll file is not registered.

    Register the file wuaueng.dll:
    Click Start, select Run
    Type: regsvr32 wuaueng.dll
    Press OK.

    If all else fails:
    Windows Update Greyed Out - Restore (Line 179)
    http://www.kellys-korner-xp.com/xp_tweaks.htm


    "Rohit" <Rohit@discussions.microsoft.com> wrote in message
    news:6EB0BE55-D444-4D05-9DD4-532BEC6A9426@microsoft.com...
    >I have XP Professional with SP2. The Automatic Update is disabled. If click
    > on "Turn on Automatic Updates" in the Security Center, I get an error statig:
    > We're sorry the Security Center could not change your settings. Try changing
    > it yourself in control Panel"
    >
    > When I click on Automatic Updated in Control panel, all radio buttons are
    > grayed out.
    >
    > How do I re enable Automatic updates. Thanks

    Well this worked for me! after I got rid of the malware that was infecting by running avg in safe mode I was left with no auto. udate in services and this .dll put it right back! Thanks so much!
  6. Thank you!

    "Register the file wuaueng.dll:
    Click Start, select Run
    Type: regsvr32 wuaueng.dll
    Press OK. "

    I had a XP Security Trojan that I fixed but this was the last piece of the puzzle.

    Worked for me!
  7. Yes, thanks a million! I had the exact same problem (XP SP3, McAfee). I used Spybot to remove the trojan, and your remedy to restore auto updates.
  8. Blue Harvest said:
    Thank you!

    "Register the file wuaueng.dll:
    Click Start, select Run
    Type: regsvr32 wuaueng.dll
    Press OK. "

    I had a XP Security Trojan that I fixed but this was the last piece of the puzzle.

    Worked for me!



    ABSOLUTELY awesome, thank you very much. I had exactly the same issue as stated above. Well, my boss did. He asked me to fix his computer. (Pay rise for me. Maybe.)
  9. You can't even find this information on the microsoft website....Go figure. After almost 17 man hours of trying to fi this problem I have finally gotten it to work. I used malwarebytes to remove any trojans on the laptop, but I couldn't get the automatic updates to enable until I ran this sweet command. Thank you sooo much for your post!!!! It worked like a charm!
  10. This topic has been closed by Buwish
Ask a new question

Read More

Control Panel Security Windows XP