Refresh rate stuck to 50Hz after using TV-out

Archived from groups: alt.comp.periphs.videocards.ati (More info?)

Argh I'm going insane with this problem soon. I have a Radeon 9600XT and
I tested out it's TV-out connection. Now I have TV-out disabled and
there's no cable attached to it. Ever since trying it out, I only have
50Hz refresh rate (I know the exact rate due to my monitor's OSD showing
it) in text mode (booting up my computer, BIOS, Linux in console mode
etc) and even in some graphical modes (loading screen of Windows XP,
framebuffer graphics in Linux). Once Windows starts up or I start X in
Linux, the refresh rate get's adjusted to what I've set it in these
enviroments. But how do I fix it in text mode? It's really getting
annoying and my head is killing me because of that awful flicker. Oh how
I wish I'd see "restore factory settings" button in the ATI control panel...

I've tried to look everywhere for this problem but can't find anything
about it, does anyone know what's going on and how to fix it? If not I
guess I'll have to try if I can get someone from ATI to answer me :I

-sakus
9 answers Last reply
More about refresh rate stuck 50hz
  1. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    I had posted a similar problem with my 9800pro. Google for it or just search
    through this NG - it's there.. probably from late '03 or early '04. I never
    found a resolution to the problem except but to stop using the tv-out. Now,
    since you've stopped using the tv-out and are still having the problem, I'd
    make sure that the tv-out cable is disconnected from the TV-OUT. Also, turn
    off the power to the PC, unplug from AC source, and let it sit for a few
    minutes (not sure exactly how long it takes for the charge to exit
    completely) so that the radeon's registers can reset to hardware defaults.
    That should do it... let me know.

    --
    Tony DiMarzio
    djtone81@hotmail.com
    djraid@comcast.net


    "Saku S" <saku.saisa@juggalos.takethisout.net> wrote in message
    news:thpXc.290$Pv2.22@read3.inet.fi...
    > Argh I'm going insane with this problem soon. I have a Radeon 9600XT and
    > I tested out it's TV-out connection. Now I have TV-out disabled and
    > there's no cable attached to it. Ever since trying it out, I only have
    > 50Hz refresh rate (I know the exact rate due to my monitor's OSD showing
    > it) in text mode (booting up my computer, BIOS, Linux in console mode
    > etc) and even in some graphical modes (loading screen of Windows XP,
    > framebuffer graphics in Linux). Once Windows starts up or I start X in
    > Linux, the refresh rate get's adjusted to what I've set it in these
    > enviroments. But how do I fix it in text mode? It's really getting
    > annoying and my head is killing me because of that awful flicker. Oh how
    > I wish I'd see "restore factory settings" button in the ATI control
    panel...
    >
    > I've tried to look everywhere for this problem but can't find anything
    > about it, does anyone know what's going on and how to fix it? If not I
    > guess I'll have to try if I can get someone from ATI to answer me :I
    >
    > -sakus
  2. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    Tony DiMarzio wrote:
    > Also, turn
    > off the power to the PC, unplug from AC source, and let it sit for a few
    > minutes (not sure exactly how long it takes for the charge to exit
    > completely) so that the radeon's registers can reset to hardware defaults.
    > That should do it... let me know.
    >

    I tried this, but no help. Dunno if I didn't wait long enough or
    something though. I also tried the card in another PC, and the problem
    was still there. Also, I contacted Club3D's (it's their card) customer
    support but they didn't seem to have any new ideas (told me to
    re-install the drivers, etc).

    Oh yeah, and there's a jumper on the card that lets you choose between
    PAL and NTSC for the the TV-OUT. I remember reading somewhere that PAL
    is 50Hz, NTSC 60Hz.. so I tried to change the jumper to NTSC so that the
    refresh rate I get in text mode would also get set to 60Hz - but no.

    The way I see this, I got two options in the future when it's time to
    buy a new gfx card. 1, don't buy an ATI. 2, buy an ATI but NEVER EVER
    touch the god damned TV-OUT!

    -sakus
  3. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    Odd problem, which TV-out mode are you using? Clone/Secondary? I'm using
    clone, and my monitor refresh doesn't change at all, regardless of tv-out
    cable being plugged in or not. I do have 'refresh rate override' enabled in
    monitor settings, but that has to be on anyway (because of winxp's dumbass
    way of setting refresh rates). Can you set the override to what ever you
    require (mine is set to 85Hz)? (setting is in CAT->Display->Monitor)

    "Saku S" <saku.saisa@juggalos.takethisout.net> wrote in message
    news:O4XXc.46$tZ4.1@read3.inet.fi...
    > Tony DiMarzio wrote:
    > > Also, turn
    > > off the power to the PC, unplug from AC source, and let it sit for a few
    > > minutes (not sure exactly how long it takes for the charge to exit
    > > completely) so that the radeon's registers can reset to hardware
    defaults.
    > > That should do it... let me know.
    > >
    >
    > I tried this, but no help. Dunno if I didn't wait long enough or
    > something though. I also tried the card in another PC, and the problem
    > was still there. Also, I contacted Club3D's (it's their card) customer
    > support but they didn't seem to have any new ideas (told me to
    > re-install the drivers, etc).
    >
    > Oh yeah, and there's a jumper on the card that lets you choose between
    > PAL and NTSC for the the TV-OUT. I remember reading somewhere that PAL
    > is 50Hz, NTSC 60Hz.. so I tried to change the jumper to NTSC so that the
    > refresh rate I get in text mode would also get set to 60Hz - but no.
    >
    > The way I see this, I got two options in the future when it's time to
    > buy a new gfx card. 1, don't buy an ATI. 2, buy an ATI but NEVER EVER
    > touch the god damned TV-OUT!
    >
    > -sakus
  4. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    Vellu wrote:
    > Odd problem, which TV-out mode are you using? Clone/Secondary? I'm using
    > clone, and my monitor refresh doesn't change at all, regardless of tv-out
    > cable being plugged in or not. I do have 'refresh rate override' enabled in
    > monitor settings, but that has to be on anyway (because of winxp's dumbass
    > way of setting refresh rates). Can you set the override to what ever you
    > require (mine is set to 85Hz)? (setting is in CAT->Display->Monitor)
    >

    I'm not using any TV-OUT mode, not anymore, it's all disabled. I don't
    remember which one I used when I tried it. My refresh rate override is
    set, and as I stated earlier, when I'm booted to Windows, my refresh
    rate is correct (I use 75Hz) but it's 50Hz before Windows starts, before
    the driver gets loaded.

    The same thing in Linux. Once I start X, and the driver gets loaded, the
    refresh rate goes to 75Hz which I've set it to. But before that, it's
    50Hz, making it impossible to use Linux in console mode..

    -sakus
  5. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    Ok now... are you sure that it wasn't doing 50hz even before you tried the
    tv-out? meaning when you put the card in the machine for the first time.

    If you are sure that it was doing closer to 70hz the first time you used..
    then there has to be a way to get it back to that state. take the card out
    of the machine and examine it for any CMOS clear jumpers. Unplug the PC for
    about 15 minutes too.

    --
    Tony DiMarzio
    djtone81@hotmail.com
    djraid@comcast.net


    "Saku S" <saku.saisa@juggalos.takethisout.net> wrote in message
    news:0SZXc.102$tZ4.88@read3.inet.fi...
    > Vellu wrote:
    > > Odd problem, which TV-out mode are you using? Clone/Secondary? I'm using
    > > clone, and my monitor refresh doesn't change at all, regardless of
    tv-out
    > > cable being plugged in or not. I do have 'refresh rate override' enabled
    in
    > > monitor settings, but that has to be on anyway (because of winxp's
    dumbass
    > > way of setting refresh rates). Can you set the override to what ever you
    > > require (mine is set to 85Hz)? (setting is in CAT->Display->Monitor)
    > >
    >
    > I'm not using any TV-OUT mode, not anymore, it's all disabled. I don't
    > remember which one I used when I tried it. My refresh rate override is
    > set, and as I stated earlier, when I'm booted to Windows, my refresh
    > rate is correct (I use 75Hz) but it's 50Hz before Windows starts, before
    > the driver gets loaded.
    >
    > The same thing in Linux. Once I start X, and the driver gets loaded, the
    > refresh rate goes to 75Hz which I've set it to. But before that, it's
    > 50Hz, making it impossible to use Linux in console mode..
    >
    > -sakus
  6. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    Tony DiMarzio wrote:
    > Ok now... are you sure that it wasn't doing 50hz even before you tried the
    > tv-out? meaning when you put the card in the machine for the first time.
    >
    > If you are sure that it was doing closer to 70hz the first time you used..
    > then there has to be a way to get it back to that state. take the card out
    > of the machine and examine it for any CMOS clear jumpers. Unplug the PC for
    > about 15 minutes too.
    >

    Yup it was OK before touching the TV-OUT. First, it is cealrly visible
    how much the screen flickers now, it can't be looked at for long. Also,
    it's a screen mode that I haven't confiugured in my monitor, thus the
    screen is "off" quite a lot.. it's not stretched to the limits and it's
    not even in the center of the screen.

    And I agree.. there HAS to be a way to get it back to normal. The card
    doesn't have any CMOS clear jumpers, already checked that when I took
    the card out to test it in another PC. Also Club 3D support told me
    there's no way to "reset the card". The only thing left to try is to
    keep the PC unplugged for longer than I already did, I'll have to try
    that. Maybe even leave it unplugged for the night or something.

    I have a distinct feeling that I've had this same problem before, with
    my previous ATI card which was a Radeon 9000 pro.. I have that card in
    another PC now, and it works correctly. I have no idea what I might've
    done to get it working again.

    -sakus
  7. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    I feel your pain - this is a mysterious and notoriously hard to fix hardware
    bug.

    Something you might want to try to reset the card to it's factory state is
    to reflash the card's BIOS. Look up a few threads for a link to the site
    which archives the BIOS's and hosts the flashing util.


    "Saku S" <saku.saisa@juggalos.takethisout.net> wrote in message
    news:oR_Xc.130$tZ4.26@read3.inet.fi...
    > Tony DiMarzio wrote:
    > > Ok now... are you sure that it wasn't doing 50hz even before you tried
    the
    > > tv-out? meaning when you put the card in the machine for the first time.
    > >
    > > If you are sure that it was doing closer to 70hz the first time you
    used..
    > > then there has to be a way to get it back to that state. take the card
    out
    > > of the machine and examine it for any CMOS clear jumpers. Unplug the PC
    for
    > > about 15 minutes too.
    > >
    >
    > Yup it was OK before touching the TV-OUT. First, it is cealrly visible
    > how much the screen flickers now, it can't be looked at for long. Also,
    > it's a screen mode that I haven't confiugured in my monitor, thus the
    > screen is "off" quite a lot.. it's not stretched to the limits and it's
    > not even in the center of the screen.
    >
    > And I agree.. there HAS to be a way to get it back to normal. The card
    > doesn't have any CMOS clear jumpers, already checked that when I took
    > the card out to test it in another PC. Also Club 3D support told me
    > there's no way to "reset the card". The only thing left to try is to
    > keep the PC unplugged for longer than I already did, I'll have to try
    > that. Maybe even leave it unplugged for the night or something.
    >
    > I have a distinct feeling that I've had this same problem before, with
    > my previous ATI card which was a Radeon 9000 pro.. I have that card in
    > another PC now, and it works correctly. I have no idea what I might've
    > done to get it working again.
    >
    > -sakus
  8. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    Tony DiMarzio wrote:
    > I feel your pain - this is a mysterious and notoriously hard to fix hardware
    > bug.
    >
    > Something you might want to try to reset the card to it's factory state is
    > to reflash the card's BIOS. Look up a few threads for a link to the site
    > which archives the BIOS's and hosts the flashing util.
    >

    Ah I didn't even think of this myself. I tried and no.. no help. First I
    flashed it with an original bios for this card I got from the net. When
    this didn't do anything, I flashed it with a custom bios that has the
    tv-out completely disabled - still no help. I'm starting to think
    there's something seriously wrong with this damn card.. I don't think
    the warranty has expired yet but then again I'm not so sure this problem
    is enough for them to give me a new card.. besides, I don't think
    they're too happy to notice I've been flashing the bios :D

    Oh well.. I'll just try to get by. I don't need text mode THAT bad, but
    it would be nice to be able to look at it without getting a head ache
    and running eyes when I do need it.

    Thanks for trying to help!

    -sakus
  9. Archived from groups: alt.comp.periphs.videocards.ati (More info?)

    Not a problem at all. Personally, I would try to return the card though.
    There's no reason a $20 PCI vid card should outperform your Radeon in
    driverless environments.

    It's so unacceptable that I'm pissed for you!

    :) Ah well... I pretty much did the same thing though. Just accepted my 58hz
    fate and moved on with life :(

    --
    Tony DiMarzio
    djtone81@hotmail.com
    djraid@comcast.net


    "Saku S" <saku.saisa@juggalos.takethisout.net> wrote in message
    news:irZYc.125$em1.120@read3.inet.fi...
    > Tony DiMarzio wrote:
    > > I feel your pain - this is a mysterious and notoriously hard to fix
    hardware
    > > bug.
    > >
    > > Something you might want to try to reset the card to it's factory state
    is
    > > to reflash the card's BIOS. Look up a few threads for a link to the site
    > > which archives the BIOS's and hosts the flashing util.
    > >
    >
    > Ah I didn't even think of this myself. I tried and no.. no help. First I
    > flashed it with an original bios for this card I got from the net. When
    > this didn't do anything, I flashed it with a custom bios that has the
    > tv-out completely disabled - still no help. I'm starting to think
    > there's something seriously wrong with this damn card.. I don't think
    > the warranty has expired yet but then again I'm not so sure this problem
    > is enough for them to give me a new card.. besides, I don't think
    > they're too happy to notice I've been flashing the bios :D
    >
    > Oh well.. I'll just try to get by. I don't need text mode THAT bad, but
    > it would be nice to be able to look at it without getting a head ache
    > and running eyes when I do need it.
    >
    > Thanks for trying to help!
    >
    > -sakus
Ask a new question

Read More

Radeon TV Graphics