Sign in with
Sign up | Sign in
Your question

Local machine HTML files the information bar and the MOTW

Tags:
  • HTML
  • Microsoft
  • Windows XP
Last response: in Windows XP
Share
Anonymous
March 20, 2005 10:13:01 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I have some HTML files that rely on Javascript for navigation that I would
like to run on a local machine drive.

As you can imagine the information bar pops up unless I click the "Allow
active content to run files on My Computer". Since this is a not recommended
option, I try using the Mark of The Web (MOTW) option, that consists in
adding <!-- saved from url=(00xx)http://www.xxx.com --> to your HTML files.

The problem now is that when you load a page with this comment it loads OK,
but all links to other pages do not work at all.

Is the "Allow active content to run files on My Computer" the only solution?

More about : local machine html files information bar motw

Anonymous
March 21, 2005 12:09:47 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Hi Alvira,

>> but all links to other pages do not work at all.

Two questions:

1. Where are the links pointing to (perhaps to a file/folder in your hard
disk?)
2. What happens when you remove the MOTW, and enable "Allow active content
to run files on My Computer"

Also note that, there are certain criteria concerning the MOTW code
placement. See:
http://msdn.microsoft.com/library/default.asp?url=/work...

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"alvira" <alvira@discussions.microsoft.com> wrote in message
news:F280373D-39FA-4DA7-8AAF-982075ABE8C8@microsoft.com...
>I have some HTML files that rely on Javascript for navigation that I would
> like to run on a local machine drive.
>
> As you can imagine the information bar pops up unless I click the "Allow
> active content to run files on My Computer". Since this is a not
> recommended
> option, I try using the Mark of The Web (MOTW) option, that consists in
> adding <!-- saved from url=(00xx)http://www.xxx.com --> to your HTML
> files.
>
> The problem now is that when you load a page with this comment it loads
> OK,
> but all links to other pages do not work at all.
>
> Is the "Allow active content to run files on My Computer" the only
> solution?
Anonymous
March 21, 2005 12:09:48 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

The links to local files are the one that do not work, even if the other
files have the MOTW. If I remove the MOTW, and enable "Allow active content
to run files on My Computer" everything works OK.

Thanks for your quick response.

"Ramesh, MS-MVP" wrote:

> Hi Alvira,
>
> >> but all links to other pages do not work at all.
>
> Two questions:
>
> 1. Where are the links pointing to (perhaps to a file/folder in your hard
> disk?)
> 2. What happens when you remove the MOTW, and enable "Allow active content
> to run files on My Computer"
>
> Also note that, there are certain criteria concerning the MOTW code
> placement. See:
> http://msdn.microsoft.com/library/default.asp?url=/work...
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "alvira" <alvira@discussions.microsoft.com> wrote in message
> news:F280373D-39FA-4DA7-8AAF-982075ABE8C8@microsoft.com...
> >I have some HTML files that rely on Javascript for navigation that I would
> > like to run on a local machine drive.
> >
> > As you can imagine the information bar pops up unless I click the "Allow
> > active content to run files on My Computer". Since this is a not
> > recommended
> > option, I try using the Mark of The Web (MOTW) option, that consists in
> > adding <!-- saved from url=(00xx)http://www.xxx.com --> to your HTML
> > files.
> >
> > The problem now is that when you load a page with this comment it loads
> > OK,
> > but all links to other pages do not work at all.
> >
> > Is the "Allow active content to run files on My Computer" the only
> > solution?
>
>
Related resources
Can't find your answer ? Ask !
Anonymous
March 21, 2005 12:47:23 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

>> The links to local files are the one that do not work

Then I guess it may be the problem with MOTW code segment, or it's
placement. Read the MSDN document I provided earlier. Keep us posted!

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"alvira" <alvira@discussions.microsoft.com> wrote in message
news:CAA1A5C8-AC07-4443-8734-058F07CC0692@microsoft.com...
> The links to local files are the one that do not work, even if the other
> files have the MOTW. If I remove the MOTW, and enable "Allow active
> content
> to run files on My Computer" everything works OK.
>
> Thanks for your quick response.
>
> "Ramesh, MS-MVP" wrote:
>
>> Hi Alvira,
>>
>> >> but all links to other pages do not work at all.
>>
>> Two questions:
>>
>> 1. Where are the links pointing to (perhaps to a file/folder in your hard
>> disk?)
>> 2. What happens when you remove the MOTW, and enable "Allow active
>> content
>> to run files on My Computer"
>>
>> Also note that, there are certain criteria concerning the MOTW code
>> placement. See:
>> http://msdn.microsoft.com/library/default.asp?url=/work...
>>
>> --
>> Ramesh, Microsoft MVP
>> Windows XP Shell/User
>> http://windowsxp.mvps.org
>>
>>
>> "alvira" <alvira@discussions.microsoft.com> wrote in message
>> news:F280373D-39FA-4DA7-8AAF-982075ABE8C8@microsoft.com...
>> >I have some HTML files that rely on Javascript for navigation that I
>> >would
>> > like to run on a local machine drive.
>> >
>> > As you can imagine the information bar pops up unless I click the
>> > "Allow
>> > active content to run files on My Computer". Since this is a not
>> > recommended
>> > option, I try using the Mark of The Web (MOTW) option, that consists in
>> > adding <!-- saved from url=(00xx)http://www.xxx.com --> to your HTML
>> > files.
>> >
>> > The problem now is that when you load a page with this comment it loads
>> > OK,
>> > but all links to other pages do not work at all.
>> >
>> > Is the "Allow active content to run files on My Computer" the only
>> > solution?
Anonymous
March 21, 2005 12:47:24 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Ramesh,

I copied the MOTW saved by IE and it now works. Of course, I have to add
MOTW to every single page.

Thanks

alvira

I have tried copying the same lines.
"Ramesh, MS-MVP" wrote:

> >> The links to local files are the one that do not work
>
> Then I guess it may be the problem with MOTW code segment, or it's
> placement. Read the MSDN document I provided earlier. Keep us posted!
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "alvira" <alvira@discussions.microsoft.com> wrote in message
> news:CAA1A5C8-AC07-4443-8734-058F07CC0692@microsoft.com...
> > The links to local files are the one that do not work, even if the other
> > files have the MOTW. If I remove the MOTW, and enable "Allow active
> > content
> > to run files on My Computer" everything works OK.
> >
> > Thanks for your quick response.
> >
> > "Ramesh, MS-MVP" wrote:
> >
> >> Hi Alvira,
> >>
> >> >> but all links to other pages do not work at all.
> >>
> >> Two questions:
> >>
> >> 1. Where are the links pointing to (perhaps to a file/folder in your hard
> >> disk?)
> >> 2. What happens when you remove the MOTW, and enable "Allow active
> >> content
> >> to run files on My Computer"
> >>
> >> Also note that, there are certain criteria concerning the MOTW code
> >> placement. See:
> >> http://msdn.microsoft.com/library/default.asp?url=/work...
> >>
> >> --
> >> Ramesh, Microsoft MVP
> >> Windows XP Shell/User
> >> http://windowsxp.mvps.org
> >>
> >>
> >> "alvira" <alvira@discussions.microsoft.com> wrote in message
> >> news:F280373D-39FA-4DA7-8AAF-982075ABE8C8@microsoft.com...
> >> >I have some HTML files that rely on Javascript for navigation that I
> >> >would
> >> > like to run on a local machine drive.
> >> >
> >> > As you can imagine the information bar pops up unless I click the
> >> > "Allow
> >> > active content to run files on My Computer". Since this is a not
> >> > recommended
> >> > option, I try using the Mark of The Web (MOTW) option, that consists in
> >> > adding <!-- saved from url=(00xx)http://www.xxx.com --> to your HTML
> >> > files.
> >> >
> >> > The problem now is that when you load a page with this comment it loads
> >> > OK,
> >> > but all links to other pages do not work at all.
> >> >
> >> > Is the "Allow active content to run files on My Computer" the only
> >> > solution?
>
>
Anonymous
March 21, 2005 12:07:30 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Thanks for the feedback Alvira. Glad it's working now.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"alvira" <alvira@discussions.microsoft.com> wrote in message
news:3DD4963E-2D62-45EF-9309-F3A52FC36CB0@microsoft.com...
> Ramesh,
>
> I copied the MOTW saved by IE and it now works. Of course, I have to add
> MOTW to every single page.
>
> Thanks
>
> alvira
>
> I have tried copying the same lines.
> "Ramesh, MS-MVP" wrote:
>
>> >> The links to local files are the one that do not work
>>
>> Then I guess it may be the problem with MOTW code segment, or it's
>> placement. Read the MSDN document I provided earlier. Keep us posted!
>>
>> --
>> Ramesh, Microsoft MVP
>> Windows XP Shell/User
>> http://windowsxp.mvps.org
>>
>>
>> "alvira" <alvira@discussions.microsoft.com> wrote in message
>> news:CAA1A5C8-AC07-4443-8734-058F07CC0692@microsoft.com...
>> > The links to local files are the one that do not work, even if the
>> > other
>> > files have the MOTW. If I remove the MOTW, and enable "Allow active
>> > content
>> > to run files on My Computer" everything works OK.
>> >
>> > Thanks for your quick response.
>> >
>> > "Ramesh, MS-MVP" wrote:
>> >
>> >> Hi Alvira,
>> >>
>> >> >> but all links to other pages do not work at all.
>> >>
>> >> Two questions:
>> >>
>> >> 1. Where are the links pointing to (perhaps to a file/folder in your
>> >> hard
>> >> disk?)
>> >> 2. What happens when you remove the MOTW, and enable "Allow active
>> >> content
>> >> to run files on My Computer"
>> >>
>> >> Also note that, there are certain criteria concerning the MOTW code
>> >> placement. See:
>> >> http://msdn.microsoft.com/library/default.asp?url=/work...
>> >>
>> >> --
>> >> Ramesh, Microsoft MVP
>> >> Windows XP Shell/User
>> >> http://windowsxp.mvps.org
>> >>
>> >>
>> >> "alvira" <alvira@discussions.microsoft.com> wrote in message
>> >> news:F280373D-39FA-4DA7-8AAF-982075ABE8C8@microsoft.com...
>> >> >I have some HTML files that rely on Javascript for navigation that I
>> >> >would
>> >> > like to run on a local machine drive.
>> >> >
>> >> > As you can imagine the information bar pops up unless I click the
>> >> > "Allow
>> >> > active content to run files on My Computer". Since this is a not
>> >> > recommended
>> >> > option, I try using the Mark of The Web (MOTW) option, that consists
>> >> > in
>> >> > adding <!-- saved from url=(00xx)http://www.xxx.com --> to your HTML
>> >> > files.
>> >> >
>> >> > The problem now is that when you load a page with this comment it
>> >> > loads
>> >> > OK,
>> >> > but all links to other pages do not work at all.
>> >> >
>> >> > Is the "Allow active content to run files on My Computer" the only
>> >> > solution?
>>
>>
!