Access this computer from the network problem

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I am working with a Windows XP Pro SP2 workgroup computer that a 2nd
computer needs to access files on. So, I go to Control Panel ->
Administrative Tools -> Local Security Settings -> Local Policies -> User
Rights Assignment and add Everyone to the "Access this computer from the
network" Policy. This works perfectly. For a while. It stops working
immediately when I reboot. Then my file sharing stops working. If I go back
to this Security Policy, it is blank for some reason. I can reset it to
Everyone and it works again for a while or until reboot. Then I have to set
it back to Everyone again. What in the world has happened to my security
settings? I don't even mind setting this policy every time I need it if
there is just an easier way like a batch file or a script or a program I can
use. I just hate having to go back through all the steps every time I want
to share files. Any help would be appreciated.
4 answers Last reply
More about access computer network problem
  1. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    1) The folder should be added to Shared Resources
    in Administrative Tools\Computer Management\Shared
    Folders\Shared Resources. This can also be done in
    the Folder Properties\Sharing\Share this folder\Permissions.
    See this settings is complemented in the Security Tab.

    2) In Admin Tools\Services and Apps.\Services\
    check that the "Server" service is running and set to
    autostart.

    3) This never fails: go to the C:\drive properties\Sharing\
    New Shared Resource\type the folder path and set the
    allowed users.

    Just in case you need some more info....
    How to configure file sharing in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;304040


    ------------Original Message-------------
    "Josh" <jajunk@cableone.net> escribió en el mensaje
    news:e1ZRLv4OFHA.1884@TK2MSFTNGP15.phx.gbl...
    > I am working with a Windows XP Pro SP2 workgroup computer that a 2nd
    > computer needs to access files on. So, I go to Control Panel ->
    > Administrative Tools -> Local Security Settings -> Local Policies -> User
    > Rights Assignment and add Everyone to the "Access this computer from the
    > network" Policy. This works perfectly. For a while. It stops working
    > immediately when I reboot. Then my file sharing stops working. If I go
    back
    > to this Security Policy, it is blank for some reason. I can reset it to
    > Everyone and it works again for a while or until reboot. Then I have to
    set
    > it back to Everyone again. What in the world has happened to my security
    > settings? I don't even mind setting this policy every time I need it if
    > there is just an easier way like a batch file or a script or a program I
    can
    > use. I just hate having to go back through all the steps every time I want
    > to share files. Any help would be appreciated.
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Thanks Juan for that information. I double checked all of those settings and
    they all match what you wrote in your message. I did find something that at
    least works in a batch file: ntrights.exe from the resource kit. I can put:

    ntrights +r SeNetworkLogonRight -u Everyone

    Any idea why I have to run this after every restart?

    "Juan" <soyquiensoy@terra.com> wrote in message
    news:uz3VeW$OFHA.244@TK2MSFTNGP12.phx.gbl...
    > 1) The folder should be added to Shared Resources
    > in Administrative Tools\Computer Management\Shared
    > Folders\Shared Resources. This can also be done in
    > the Folder Properties\Sharing\Share this folder\Permissions.
    > See this settings is complemented in the Security Tab.
    >
    > 2) In Admin Tools\Services and Apps.\Services\
    > check that the "Server" service is running and set to
    > autostart.
    >
    > 3) This never fails: go to the C:\drive properties\Sharing\
    > New Shared Resource\type the folder path and set the
    > allowed users.
    >
    > Just in case you need some more info....
    > How to configure file sharing in Windows XP
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;304040
    >
    >
    > ------------Original Message-------------
    > "Josh" <jajunk@cableone.net> escribió en el mensaje
    > news:e1ZRLv4OFHA.1884@TK2MSFTNGP15.phx.gbl...
    >> I am working with a Windows XP Pro SP2 workgroup computer that a 2nd
    >> computer needs to access files on. So, I go to Control Panel ->
    >> Administrative Tools -> Local Security Settings -> Local Policies -> User
    >> Rights Assignment and add Everyone to the "Access this computer from the
    >> network" Policy. This works perfectly. For a while. It stops working
    >> immediately when I reboot. Then my file sharing stops working. If I go
    > back
    >> to this Security Policy, it is blank for some reason. I can reset it to
    >> Everyone and it works again for a while or until reboot. Then I have to
    > set
    >> it back to Everyone again. What in the world has happened to my security
    >> settings? I don't even mind setting this policy every time I need it if
    >> there is just an easier way like a batch file or a script or a program I
    > can
    >> use. I just hate having to go back through all the steps every time I
    >> want
    >> to share files. Any help would be appreciated.
    >>
    >>
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    By what the batch file reads, it's probably creating temporary access
    to the Everyone group which means there's a security/permissions
    issue preventing normal access. Following are a few links to check
    your permission security settings.
    Also check Services in Administration Tools and tweak with those
    services related to communications in a local network, it could be a
    necessary service is disabled which would cause the symptoms you
    describe.

    How to set, view, change, or remove file and folder permissions in Windows
    XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308418

    How to set, view, change, or remove special permissions for files and
    folders in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308419

    At times it's easyer and faster to access another computer by means
    of a Short Cut, here is how to do it.
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308416

    These are a few services that come to mind which could
    prevent a normal connection from being established.
    many services are dependant on other ones, so you'll
    have to check all those related to communications in the
    Dependance tab and find if they should be running in your
    particular setup.

    Server
    Telnet
    Terminal Server Service
    Network Connections
    Computer Browser Service (not present on all installations)
    If the Firewall (ICF) Service is enabled on the host computer
    it could be blocking access, but again it may not.

    hope this helps.

    ---------Original Message----------
    "Josh" <jajunk@cableone.net> escribió en el mensaje
    news:enJhVTHPFHA.2144@TK2MSFTNGP09.phx.gbl...
    > Thanks Juan for that information. I double checked all of those settings
    and
    > they all match what you wrote in your message. I did find something that
    at
    > least works in a batch file: ntrights.exe from the resource kit. I can
    put:
    >
    > ntrights +r SeNetworkLogonRight -u Everyone
    >
    > Any idea why I have to run this after every restart?
    >
    > "Juan" <soyquiensoy@terra.com> wrote in message
    > news:uz3VeW$OFHA.244@TK2MSFTNGP12.phx.gbl...
    > > 1) The folder should be added to Shared Resources
    > > in Administrative Tools\Computer Management\Shared
    > > Folders\Shared Resources. This can also be done in
    > > the Folder Properties\Sharing\Share this folder\Permissions.
    > > See this settings is complemented in the Security Tab.
    > >
    > > 2) In Admin Tools\Services and Apps.\Services\
    > > check that the "Server" service is running and set to
    > > autostart.
    > >
    > > 3) This never fails: go to the C:\drive properties\Sharing\
    > > New Shared Resource\type the folder path and set the
    > > allowed users.
    > >
    > > Just in case you need some more info....
    > > How to configure file sharing in Windows XP
    > > http://support.microsoft.com/default.aspx?scid=kb;en-us;304040
    > >
    > >
    > > ------------Original Message-------------
    > > "Josh" <jajunk@cableone.net> escribió en el mensaje
    > > news:e1ZRLv4OFHA.1884@TK2MSFTNGP15.phx.gbl...
    > >> I am working with a Windows XP Pro SP2 workgroup computer that a 2nd
    > >> computer needs to access files on. So, I go to Control Panel ->
    > >> Administrative Tools -> Local Security Settings -> Local Policies ->
    User
    > >> Rights Assignment and add Everyone to the "Access this computer from
    the
    > >> network" Policy. This works perfectly. For a while. It stops working
    > >> immediately when I reboot. Then my file sharing stops working. If I go
    > > back
    > >> to this Security Policy, it is blank for some reason. I can reset it to
    > >> Everyone and it works again for a while or until reboot. Then I have to
    > > set
    > >> it back to Everyone again. What in the world has happened to my
    security
    > >> settings? I don't even mind setting this policy every time I need it if
    > >> there is just an easier way like a batch file or a script or a program
    I
    > > can
    > >> use. I just hate having to go back through all the steps every time I
    > >> want
    > >> to share files. Any help would be appreciated.
    > >>
    > >>
    > >
    > >
    >
    >
  4. Hello Josh!

    I am sandra,

    and now i have the same problem with many of my computers

    i just want to ask you the solution if you get it.

    my email adress is emery_sandra4@yahoo.fr

    Thank's for your help.
Ask a new question

Read More

Policy Security Computers Windows XP