Sign in with
Sign up | Sign in
Your question

How to get full display resolution for some games on noteb..

Last response: in Graphics & Displays
Share
Anonymous
November 11, 2004 12:32:00 AM

Archived from groups: alt.comp.periphs.videocards.ati,alt.sys.pc-clone.compaq (More info?)

hello all,

My daughter and me are disappointed by the display resolution for games
like Happyland Adventures (http://www.freelunchdesign.com/) or Santa
Klaus in trouble (http://www.cdvspiel.de/ostern/index.htm). Funny and
nice free games for kids.
But on our Compaq Presario R3117EA, Happyland resolution is 640x480 and
Santa Klaus resolution is 800x600.
Default R3000EA series resolution is 1280x800 !
These games are running on our old Presario 14XL355 with 1024x768
resolution !
At the beginning, Santa Kaus has run in full screen resolution so I
know it's possible.
Compaq r3117EA is equipped with only 256 Mo DDR Ram, and 64 Mo is shared
with the graphic chip. Since Windows XP is installed on this PC, I've
decided to decrease shared memory from 64 to 32 from bios menu.
After a while, we saw that Santa Klaus was running with 800x600
resolution. Then I have upgraded the PC with 512 Mo DDR ram more, and
increase shared memory between system and graphic ship from 32 to 64 Mo.
But Santa Klaus was still running with 800x600 resolution.
So to get a better resolution, I've tried :
- to set default display resolution to 1024x768,
- to suppress and re-install ATI driver (partial and full operation),
- to suppress and re-install Santa Kaus game, Happyland, Doom, ...
- to set bios configuration to default values. Surprise ! The factory
set for shared memory is 128 Mo !
- I checked forums on internet,
- I checked windows register base,
- I checked all parameters in ATI configuration panel,
All that without any result !
Doom and Happyland are still running with 640x480 display resolution
which is a quarter of the screen side !

Can anybody help us ? Any idea ? Did I miss something ?

Thanks for your help,

Soib
Anonymous
November 11, 2004 1:28:09 PM

Archived from groups: alt.comp.periphs.videocards.ati,alt.sys.pc-clone.compaq (More info?)

Maybe a dumb question, but did you try the Options menu within the game
itself? Like, run the game, look for a resolution setting in there?
Anonymous
November 11, 2004 2:54:59 PM

Archived from groups: alt.comp.periphs.videocards.ati,alt.sys.pc-clone.compaq (More info?)

"Soib" <Soib@netcourrier.com_antispam> wrote in message
news:41927ac6$0$9799$8fcfb975@news.wanadoo.fr...
> hello all,
>
> My daughter and me are disappointed by the display resolution for games
> like Happyland Adventures (http://www.freelunchdesign.com/) or Santa
> Klaus in trouble (http://www.cdvspiel.de/ostern/index.htm). Funny and
> nice free games for kids.
> But on our Compaq Presario R3117EA, Happyland resolution is 640x480 and
> Santa Klaus resolution is 800x600.
> Default R3000EA series resolution is 1280x800 !

Some laptops will force a low res screen to use only that many pixels. You
may need to find an "expanded" mode so 64x480 fills the screen.

Another thing I would try: Right click on the Game icon and select
Properties and Compatibility. Then Select Run in 640x480, and Windows will
try changing the system resolution to 640x480. This will either result in a
small screen or a full screen. (On a CRT it should fill the screen.)

You may want to hook up a CRT if these don't work.

Brad
Related resources
Anonymous
November 12, 2004 1:58:00 AM

Archived from groups: alt.comp.periphs.videocards.ati,alt.sys.pc-clone.compaq (More info?)

BeingAnonymousMakesMeObnoxious aurait rédigé ce qui suit le 11/11/2004
16:28:
> Maybe a dumb question, but did you try the Options menu within the game
> itself? Like, run the game, look for a resolution setting in there?
>
>

Thanks for your answer but those games haven't any resolution setting.
Anonymous
November 12, 2004 4:35:11 AM

Archived from groups: alt.comp.periphs.videocards.ati,alt.sys.pc-clone.compaq (More info?)

BeingAnonymousMakesMeObnoxious wrote that on 11/11/2004 16:28:
> Maybe a dumb question, but did you try the Options menu within the game
> itself? Like, run the game, look for a resolution setting in there?
>
>
Hi,

Sorry for my previous answer. Too fast !
After sending it (bad manipulation), I checked again and I've found a
config.txt file for Santa Klaus game in which there is a parameter to
define the resolution. I modified it to 1280x800 and Santa Klaus turns
in full screen now :-)))
Sorry, I think I was really tired when I've checked configuration
setting to miss this config.txt file !!! And did I really uninstall and
re-install it ? Terrible doubt
About Happyland game, I've checked FreeLunchDesign forum (that's a good
idea, isn't it, why didn't I checked it before ?). It seems that the
problem is known. Some graphic cards have problem to execute the game in
fullscreen mode.
About Doom, the maximum definition is ... 640x480 but there is a
parameter to expand in fullscreen mode which is not effective.
I met the same problem with Directx Diagnostic. The test of DirectDraw
or Direct3D fails in switching in fullscreen mode.
It seems to be a limitation of the couple Compaq Presario R3000EA series
plus ATI mobility Radeon 9000 IGP graphic chip, probably located in the
driver, customized by HP !!

So the question is how to switch in fullscreen mode on this Compaq
Presario R3117EA ? Is it possible ?

Thanks for your help,

Soib
Anonymous
November 12, 2004 4:39:38 AM

Archived from groups: alt.comp.periphs.videocards.ati,alt.sys.pc-clone.compaq (More info?)

Brad Houser wrote that on 11/11/2004 20:54:

> "Soib" <Soib@netcourrier.com_antispam> wrote in message
> news:41927ac6$0$9799$8fcfb975@news.wanadoo.fr...
>
>>hello all,
>>
>>My daughter and me are disappointed by the display resolution for games
>>like Happyland Adventures (http://www.freelunchdesign.com/) or Santa
>>Klaus in trouble (http://www.cdvspiel.de/ostern/index.htm). Funny and
>>nice free games for kids.
>>But on our Compaq Presario R3117EA, Happyland resolution is 640x480 and
>>Santa Klaus resolution is 800x600.
>>Default R3000EA series resolution is 1280x800 !
>


Hi,

Thanks for your answer,
>
> Some laptops will force a low res screen to use only that many pixels. You
> may need to find an "expanded" mode so 64x480 fills the screen.
>
There is an expand mode (fullscreen mode) with Doom but it is not
effective on this PC. The same problem exist with DirectX Diagnostic.
See my previous message.

> Another thing I would try: Right click on the Game icon and select
> Properties and Compatibility. Then Select Run in 640x480, and Windows will
> try changing the system resolution to 640x480. This will either result in a
> small screen or a full screen. (On a CRT it should fill the screen.)
>
> You may want to hook up a CRT if these don't work.
>
> Brad
>
Ho, I forgot to indicate that i've tried that ! And the result is ......
small screen :-( 640x480. I tried also "Windows 95" and "Windows 98"
compatibility mode. I will do more test to combine parameters. May be,
afterall, there is a way to bypass this limitation (see previous message).

Thanks for your help,

Soib
!