Wireless home network security?

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

OK, I think I've got most of this figured out now. I LOVE my Linksys WRT54G.
I just went in tonight and fiddled with the security settings. I changed
the default password and SSID, and turned off the SSID broadcasting. I set
up WPA Pre-Shared key, entered my key, and set it to only accept the MAC
addresses I specified (only my laptop is wireless, so that's the only MAC I
allow.

2 questions:

1) Should I have SSID broadcast set to enabled? It seems when everything
was on default, my laptop would automatically find the wireless network
connection when I turned the machine on. Now, the wireless network icon has
a red X through it, and I have to click on it, go to the advanced setup and
refresh the connections list, at which point it will connect to the WRT54G.
Is that the purpose of the SSID broadcast setting?

2) As far as security goes, have I done enough to make sure no one else can
use my internet connection? I live in an apartment building, and I can get
perfect signal from anywhere in my apartment. As a test, I took the laptop
out in the hall and went all the way down to the end of the hall, and the
connection was still good. Only when I got to the elevator did the signal
drop and disconnect.

OK, a 3rd question.... Anything else I need to do within the OS on one or
both machines? Both my desktop and laptop use XP Home.

Thanks for any responses.
6 answers Last reply
More about wireless home network security
  1. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    yes, turn back on ssid broadcast. trying to hide by not broadcasting is not
    effective since any real traffic shows that the ap is there anyway. and
    turning off the broadcast can cause xp's wzc to want to switch away from
    your ap and probably cause other things like you have seen.

    "Guess Who" <chippe01@REMOVETHIShotmail.com> wrote in message
    news:%233vT4srSEHA.3756@TK2MSFTNGP11.phx.gbl...
    > OK, I think I've got most of this figured out now. I LOVE my Linksys
    WRT54G.
    > I just went in tonight and fiddled with the security settings. I changed
    > the default password and SSID, and turned off the SSID broadcasting. I set
    > up WPA Pre-Shared key, entered my key, and set it to only accept the MAC
    > addresses I specified (only my laptop is wireless, so that's the only MAC
    I
    > allow.
    >
    > 2 questions:
    >
    > 1) Should I have SSID broadcast set to enabled? It seems when everything
    > was on default, my laptop would automatically find the wireless network
    > connection when I turned the machine on. Now, the wireless network icon
    has
    > a red X through it, and I have to click on it, go to the advanced setup
    and
    > refresh the connections list, at which point it will connect to the
    WRT54G.
    > Is that the purpose of the SSID broadcast setting?
    >
    > 2) As far as security goes, have I done enough to make sure no one else
    can
    > use my internet connection? I live in an apartment building, and I can
    get
    > perfect signal from anywhere in my apartment. As a test, I took the laptop
    > out in the hall and went all the way down to the end of the hall, and the
    > connection was still good. Only when I got to the elevator did the signal
    > drop and disconnect.
    >
    > OK, a 3rd question.... Anything else I need to do within the OS on one or
    > both machines? Both my desktop and laptop use XP Home.
    >
    > Thanks for any responses.
    >
    >
  2. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    As long as you know what you named your SSID, it can be turned off a=with NO
    ill effect, despite the previous post. You will have to manually enter the
    SSID in the other devices, but they will connect as normal. Changing the
    default password and disabling the SSID are good security precautions.
    Disabling the SSID will discourage all but the most determined war walkers.

    Bobby

    "Dave" <noone@nowhere.com> wrote in message
    news:OeC3vYuSEHA.3224@TK2MSFTNGP10.phx.gbl...
    > yes, turn back on ssid broadcast. trying to hide by not broadcasting is
    > not
    > effective since any real traffic shows that the ap is there anyway. and
    > turning off the broadcast can cause xp's wzc to want to switch away from
    > your ap and probably cause other things like you have seen.
    >
    > "Guess Who" <chippe01@REMOVETHIShotmail.com> wrote in message
    > news:%233vT4srSEHA.3756@TK2MSFTNGP11.phx.gbl...
    >> OK, I think I've got most of this figured out now. I LOVE my Linksys
    > WRT54G.
    >> I just went in tonight and fiddled with the security settings. I changed
    >> the default password and SSID, and turned off the SSID broadcasting. I
    >> set
    >> up WPA Pre-Shared key, entered my key, and set it to only accept the MAC
    >> addresses I specified (only my laptop is wireless, so that's the only MAC
    > I
    >> allow.
    >>
    >> 2 questions:
    >>
    >> 1) Should I have SSID broadcast set to enabled? It seems when everything
    >> was on default, my laptop would automatically find the wireless network
    >> connection when I turned the machine on. Now, the wireless network icon
    > has
    >> a red X through it, and I have to click on it, go to the advanced setup
    > and
    >> refresh the connections list, at which point it will connect to the
    > WRT54G.
    >> Is that the purpose of the SSID broadcast setting?
    >>
    >> 2) As far as security goes, have I done enough to make sure no one else
    > can
    >> use my internet connection? I live in an apartment building, and I can
    > get
    >> perfect signal from anywhere in my apartment. As a test, I took the
    >> laptop
    >> out in the hall and went all the way down to the end of the hall, and the
    >> connection was still good. Only when I got to the elevator did the signal
    >> drop and disconnect.
    >>
    >> OK, a 3rd question.... Anything else I need to do within the OS on one or
    >> both machines? Both my desktop and laptop use XP Home.
    >>
    >> Thanks for any responses.
    >>
    >>
    >
    >
  3. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    just tell that to all the people who have posted on here with xp's wzc
    switching networks on them when they turned off ssid broadcast.
    then go read:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;811427

    "NoNoBadDog!" <nospam_bjsledge@pixi.com> wrote in message
    news:eFmyN5uSEHA.1172@TK2MSFTNGP11.phx.gbl...
    > As long as you know what you named your SSID, it can be turned off a=with
    NO
    > ill effect, despite the previous post. You will have to manually enter
    the
    > SSID in the other devices, but they will connect as normal. Changing the
    > default password and disabling the SSID are good security precautions.
    > Disabling the SSID will discourage all but the most determined war
    walkers.
    >
    > Bobby
    >
    > "Dave" <noone@nowhere.com> wrote in message
    > news:OeC3vYuSEHA.3224@TK2MSFTNGP10.phx.gbl...
    > > yes, turn back on ssid broadcast. trying to hide by not broadcasting is
    > > not
    > > effective since any real traffic shows that the ap is there anyway. and
    > > turning off the broadcast can cause xp's wzc to want to switch away from
    > > your ap and probably cause other things like you have seen.
    > >
    > > "Guess Who" <chippe01@REMOVETHIShotmail.com> wrote in message
    > > news:%233vT4srSEHA.3756@TK2MSFTNGP11.phx.gbl...
    > >> OK, I think I've got most of this figured out now. I LOVE my Linksys
    > > WRT54G.
    > >> I just went in tonight and fiddled with the security settings. I
    changed
    > >> the default password and SSID, and turned off the SSID broadcasting. I
    > >> set
    > >> up WPA Pre-Shared key, entered my key, and set it to only accept the
    MAC
    > >> addresses I specified (only my laptop is wireless, so that's the only
    MAC
    > > I
    > >> allow.
    > >>
    > >> 2 questions:
    > >>
    > >> 1) Should I have SSID broadcast set to enabled? It seems when
    everything
    > >> was on default, my laptop would automatically find the wireless network
    > >> connection when I turned the machine on. Now, the wireless network
    icon
    > > has
    > >> a red X through it, and I have to click on it, go to the advanced setup
    > > and
    > >> refresh the connections list, at which point it will connect to the
    > > WRT54G.
    > >> Is that the purpose of the SSID broadcast setting?
    > >>
    > >> 2) As far as security goes, have I done enough to make sure no one
    else
    > > can
    > >> use my internet connection? I live in an apartment building, and I can
    > > get
    > >> perfect signal from anywhere in my apartment. As a test, I took the
    > >> laptop
    > >> out in the hall and went all the way down to the end of the hall, and
    the
    > >> connection was still good. Only when I got to the elevator did the
    signal
    > >> drop and disconnect.
    > >>
    > >> OK, a 3rd question.... Anything else I need to do within the OS on one
    or
    > >> both machines? Both my desktop and laptop use XP Home.
    > >>
    > >> Thanks for any responses.
    > >>
    > >>
    > >
    > >
    >
    >
  4. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    Thanks, everyone. While WZC seems a good thing when you're out on the road,
    for home use, there should be a setting to ALWAYS connect to a particular
    wireless network. Thanks for the link to the article, I wasn't aware of
    this.

    "Dave" <noone@nowhere.com> wrote in message
    news:Ops4f7vSEHA.3140@tk2msftngp13.phx.gbl...
    > just tell that to all the people who have posted on here with xp's wzc
    > switching networks on them when they turned off ssid broadcast.
    > then go read:
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;811427
    >
    > "NoNoBadDog!" <nospam_bjsledge@pixi.com> wrote in message
    > news:eFmyN5uSEHA.1172@TK2MSFTNGP11.phx.gbl...
    > > As long as you know what you named your SSID, it can be turned off
    a=with
    > NO
    > > ill effect, despite the previous post. You will have to manually enter
    > the
    > > SSID in the other devices, but they will connect as normal. Changing
    the
    > > default password and disabling the SSID are good security precautions.
    > > Disabling the SSID will discourage all but the most determined war
    > walkers.
    > >
    > > Bobby
    > >
    > > "Dave" <noone@nowhere.com> wrote in message
    > > news:OeC3vYuSEHA.3224@TK2MSFTNGP10.phx.gbl...
    > > > yes, turn back on ssid broadcast. trying to hide by not broadcasting
    is
    > > > not
    > > > effective since any real traffic shows that the ap is there anyway.
    and
    > > > turning off the broadcast can cause xp's wzc to want to switch away
    from
    > > > your ap and probably cause other things like you have seen.
    > > >
    > > > "Guess Who" <chippe01@REMOVETHIShotmail.com> wrote in message
    > > > news:%233vT4srSEHA.3756@TK2MSFTNGP11.phx.gbl...
    > > >> OK, I think I've got most of this figured out now. I LOVE my Linksys
    > > > WRT54G.
    > > >> I just went in tonight and fiddled with the security settings. I
    > changed
    > > >> the default password and SSID, and turned off the SSID broadcasting.
    I
    > > >> set
    > > >> up WPA Pre-Shared key, entered my key, and set it to only accept the
    > MAC
    > > >> addresses I specified (only my laptop is wireless, so that's the only
    > MAC
    > > > I
    > > >> allow.
    > > >>
    > > >> 2 questions:
    > > >>
    > > >> 1) Should I have SSID broadcast set to enabled? It seems when
    > everything
    > > >> was on default, my laptop would automatically find the wireless
    network
    > > >> connection when I turned the machine on. Now, the wireless network
    > icon
    > > > has
    > > >> a red X through it, and I have to click on it, go to the advanced
    setup
    > > > and
    > > >> refresh the connections list, at which point it will connect to the
    > > > WRT54G.
    > > >> Is that the purpose of the SSID broadcast setting?
    > > >>
    > > >> 2) As far as security goes, have I done enough to make sure no one
    > else
    > > > can
    > > >> use my internet connection? I live in an apartment building, and I
    can
    > > > get
    > > >> perfect signal from anywhere in my apartment. As a test, I took the
    > > >> laptop
    > > >> out in the hall and went all the way down to the end of the hall, and
    > the
    > > >> connection was still good. Only when I got to the elevator did the
    > signal
    > > >> drop and disconnect.
    > > >>
    > > >> OK, a 3rd question.... Anything else I need to do within the OS on
    one
    > or
    > > >> both machines? Both my desktop and laptop use XP Home.
    > > >>
    > > >> Thanks for any responses.
    > > >>
    > > >>
    > > >
    > > >
    > >
    > >
    >
    >
  5. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    Dave...

    If you want it dummied down and broadcasting to everyone, then by all means
    use WZC. But if you want to make your network a little more secure, then
    WZC is not the way to go. WZC has its place (traveling), but setting up a
    home network should not leave you vulnerable to those outside your network.
    WPA, MAC Address filtering, SPI Firewall, changing the default password, and
    disabling SSID are all valid tools to use when securing your system. If you
    need the crutch of WZC and SSID at home, feel free to use it.

    Bobby

    "Dave" <noone@nowhere.com> wrote in message
    news:Ops4f7vSEHA.3140@tk2msftngp13.phx.gbl...
    > just tell that to all the people who have posted on here with xp's wzc
    > switching networks on them when they turned off ssid broadcast.
    > then go read:
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;811427
    >
    > "NoNoBadDog!" <nospam_bjsledge@pixi.com> wrote in message
    > news:eFmyN5uSEHA.1172@TK2MSFTNGP11.phx.gbl...
    >> As long as you know what you named your SSID, it can be turned off a=with
    > NO
    >> ill effect, despite the previous post. You will have to manually enter
    > the
    >> SSID in the other devices, but they will connect as normal. Changing the
    >> default password and disabling the SSID are good security precautions.
    >> Disabling the SSID will discourage all but the most determined war
    > walkers.
    >>
    >> Bobby
    >>
    >> "Dave" <noone@nowhere.com> wrote in message
    >> news:OeC3vYuSEHA.3224@TK2MSFTNGP10.phx.gbl...
    >> > yes, turn back on ssid broadcast. trying to hide by not broadcasting
    >> > is
    >> > not
    >> > effective since any real traffic shows that the ap is there anyway.
    >> > and
    >> > turning off the broadcast can cause xp's wzc to want to switch away
    >> > from
    >> > your ap and probably cause other things like you have seen.
    >> >
    >> > "Guess Who" <chippe01@REMOVETHIShotmail.com> wrote in message
    >> > news:%233vT4srSEHA.3756@TK2MSFTNGP11.phx.gbl...
    >> >> OK, I think I've got most of this figured out now. I LOVE my Linksys
    >> > WRT54G.
    >> >> I just went in tonight and fiddled with the security settings. I
    > changed
    >> >> the default password and SSID, and turned off the SSID broadcasting. I
    >> >> set
    >> >> up WPA Pre-Shared key, entered my key, and set it to only accept the
    > MAC
    >> >> addresses I specified (only my laptop is wireless, so that's the only
    > MAC
    >> > I
    >> >> allow.
    >> >>
    >> >> 2 questions:
    >> >>
    >> >> 1) Should I have SSID broadcast set to enabled? It seems when
    > everything
    >> >> was on default, my laptop would automatically find the wireless
    >> >> network
    >> >> connection when I turned the machine on. Now, the wireless network
    > icon
    >> > has
    >> >> a red X through it, and I have to click on it, go to the advanced
    >> >> setup
    >> > and
    >> >> refresh the connections list, at which point it will connect to the
    >> > WRT54G.
    >> >> Is that the purpose of the SSID broadcast setting?
    >> >>
    >> >> 2) As far as security goes, have I done enough to make sure no one
    > else
    >> > can
    >> >> use my internet connection? I live in an apartment building, and I
    >> >> can
    >> > get
    >> >> perfect signal from anywhere in my apartment. As a test, I took the
    >> >> laptop
    >> >> out in the hall and went all the way down to the end of the hall, and
    > the
    >> >> connection was still good. Only when I got to the elevator did the
    > signal
    >> >> drop and disconnect.
    >> >>
    >> >> OK, a 3rd question.... Anything else I need to do within the OS on one
    > or
    >> >> both machines? Both my desktop and laptop use XP Home.
    >> >>
    >> >> Thanks for any responses.
    >> >>
    >> >>
    >> >
    >> >
    >>
    >>
    >
    >
  6. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    Some Entry level Wireless hardware might not work with SSID Off.

    Give it a try if it works with SSID Off then there is nothing to lose keep
    it Off.

    This might help too:

    http://www.ezlan.net/Wireless_Config.html

    http://www.ezlan.net/Wireless_Security.html

    Jack (MVP-Networking).


    "NoNoBadDog!" <nospam_bjsledge@pixi.com> wrote in message
    news:OClkMBzSEHA.3608@TK2MSFTNGP11.phx.gbl...
    > Dave...
    >
    > If you want it dummied down and broadcasting to everyone, then by all
    means
    > use WZC. But if you want to make your network a little more secure, then
    > WZC is not the way to go. WZC has its place (traveling), but setting up a
    > home network should not leave you vulnerable to those outside your
    network.
    > WPA, MAC Address filtering, SPI Firewall, changing the default password,
    and
    > disabling SSID are all valid tools to use when securing your system. If
    you
    > need the crutch of WZC and SSID at home, feel free to use it.
    >
    > Bobby
    >
    > "Dave" <noone@nowhere.com> wrote in message
    > news:Ops4f7vSEHA.3140@tk2msftngp13.phx.gbl...
    > > just tell that to all the people who have posted on here with xp's wzc
    > > switching networks on them when they turned off ssid broadcast.
    > > then go read:
    > > http://support.microsoft.com/default.aspx?scid=kb;en-us;811427
    > >
    > > "NoNoBadDog!" <nospam_bjsledge@pixi.com> wrote in message
    > > news:eFmyN5uSEHA.1172@TK2MSFTNGP11.phx.gbl...
    > >> As long as you know what you named your SSID, it can be turned off
    a=with
    > > NO
    > >> ill effect, despite the previous post. You will have to manually enter
    > > the
    > >> SSID in the other devices, but they will connect as normal. Changing
    the
    > >> default password and disabling the SSID are good security precautions.
    > >> Disabling the SSID will discourage all but the most determined war
    > > walkers.
    > >>
    > >> Bobby
    > >>
    > >> "Dave" <noone@nowhere.com> wrote in message
    > >> news:OeC3vYuSEHA.3224@TK2MSFTNGP10.phx.gbl...
    > >> > yes, turn back on ssid broadcast. trying to hide by not broadcasting
    > >> > is
    > >> > not
    > >> > effective since any real traffic shows that the ap is there anyway.
    > >> > and
    > >> > turning off the broadcast can cause xp's wzc to want to switch away
    > >> > from
    > >> > your ap and probably cause other things like you have seen.
    > >> >
    > >> > "Guess Who" <chippe01@REMOVETHIShotmail.com> wrote in message
    > >> > news:%233vT4srSEHA.3756@TK2MSFTNGP11.phx.gbl...
    > >> >> OK, I think I've got most of this figured out now. I LOVE my Linksys
    > >> > WRT54G.
    > >> >> I just went in tonight and fiddled with the security settings. I
    > > changed
    > >> >> the default password and SSID, and turned off the SSID broadcasting.
    I
    > >> >> set
    > >> >> up WPA Pre-Shared key, entered my key, and set it to only accept the
    > > MAC
    > >> >> addresses I specified (only my laptop is wireless, so that's the
    only
    > > MAC
    > >> > I
    > >> >> allow.
    > >> >>
    > >> >> 2 questions:
    > >> >>
    > >> >> 1) Should I have SSID broadcast set to enabled? It seems when
    > > everything
    > >> >> was on default, my laptop would automatically find the wireless
    > >> >> network
    > >> >> connection when I turned the machine on. Now, the wireless network
    > > icon
    > >> > has
    > >> >> a red X through it, and I have to click on it, go to the advanced
    > >> >> setup
    > >> > and
    > >> >> refresh the connections list, at which point it will connect to the
    > >> > WRT54G.
    > >> >> Is that the purpose of the SSID broadcast setting?
    > >> >>
    > >> >> 2) As far as security goes, have I done enough to make sure no one
    > > else
    > >> > can
    > >> >> use my internet connection? I live in an apartment building, and I
    > >> >> can
    > >> > get
    > >> >> perfect signal from anywhere in my apartment. As a test, I took the
    > >> >> laptop
    > >> >> out in the hall and went all the way down to the end of the hall,
    and
    > > the
    > >> >> connection was still good. Only when I got to the elevator did the
    > > signal
    > >> >> drop and disconnect.
    > >> >>
    > >> >> OK, a 3rd question.... Anything else I need to do within the OS on
    one
    > > or
    > >> >> both machines? Both my desktop and laptop use XP Home.
    > >> >>
    > >> >> Thanks for any responses.
    > >> >>
    > >> >>
    > >> >
    > >> >
    > >>
    > >>
    > >
    > >
    >
    >
Ask a new question

Read More

Wireless Security SSID Wireless Networking