Sign in with
Sign up | Sign in
Your question

Disk Management after loading XP2

Tags:
  • Disk Management
  • Computers
  • Windows XP
Last response: in Windows XP
Share
May 2, 2005 2:37:24 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I'm testing XP2 on a lab at my office network.
I have added program exceptions for
c:\windows\system32\dmremote.exe:*:enabled and I've also added port
exceptions for ports 135 and 445 and I'm still unable to use Disk Manager to
manage remote computer.
I keep getting the following message: The Disk Management console failed to
conect to the remote computer because the Disk Management remoting sevices is
not in the Windows Firewall exception list. Add the Disk Management remoting
service (dmremote.exe) to the Windows Firewall exception list and try again...

Any ideas.

More about : disk management loading xp2

May 2, 2005 5:53:56 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

did you add those to the local machine or the remote one or both?

"Edward" <Edward@discussions.microsoft.com> wrote in message
news:D BCF8C87-A9A2-43E0-B5FA-84C62EE02193@microsoft.com...
> I'm testing XP2 on a lab at my office network.
> I have added program exceptions for
> c:\windows\system32\dmremote.exe:*:enabled and I've also added port
> exceptions for ports 135 and 445 and I'm still unable to use Disk Manager
> to
> manage remote computer.
> I keep getting the following message: The Disk Management console failed
> to
> conect to the remote computer because the Disk Management remoting sevices
> is
> not in the Windows Firewall exception list. Add the Disk Management
> remoting
> service (dmremote.exe) to the Windows Firewall exception list and try
> again...
>
> Any ideas.
May 2, 2005 5:53:57 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I'm using a group policy, and I've run rsop and I know that the policy has
been set on all computers in my lab.

"Dave" wrote:

> did you add those to the local machine or the remote one or both?
>
> "Edward" <Edward@discussions.microsoft.com> wrote in message
> news:D BCF8C87-A9A2-43E0-B5FA-84C62EE02193@microsoft.com...
> > I'm testing XP2 on a lab at my office network.
> > I have added program exceptions for
> > c:\windows\system32\dmremote.exe:*:enabled and I've also added port
> > exceptions for ports 135 and 445 and I'm still unable to use Disk Manager
> > to
> > manage remote computer.
> > I keep getting the following message: The Disk Management console failed
> > to
> > conect to the remote computer because the Disk Management remoting sevices
> > is
> > not in the Windows Firewall exception list. Add the Disk Management
> > remoting
> > service (dmremote.exe) to the Windows Firewall exception list and try
> > again...
> >
> > Any ideas.
>
>
>
July 22, 2005 3:43:03 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I am experiencing this problem with Windows 2000 servers. I can use disk
management just fine from my XP box to my 2003 boxes but I get the same error
when I use disk management on a 2000 box. At first i suspected that the
problem was that the path to the diskmanagement EXE is not the same on 2000
and 2003. If is c:\winnt\system32 and c:\windows\system32 respectively. So I
changed the path to %windir%\system32 but this did not help....



"Edward" wrote:

> I'm using a group policy, and I've run rsop and I know that the policy has
> been set on all computers in my lab.
>
> "Dave" wrote:
>
> > did you add those to the local machine or the remote one or both?
> >
> > "Edward" <Edward@discussions.microsoft.com> wrote in message
> > news:D BCF8C87-A9A2-43E0-B5FA-84C62EE02193@microsoft.com...
> > > I'm testing XP2 on a lab at my office network.
> > > I have added program exceptions for
> > > c:\windows\system32\dmremote.exe:*:enabled and I've also added port
> > > exceptions for ports 135 and 445 and I'm still unable to use Disk Manager
> > > to
> > > manage remote computer.
> > > I keep getting the following message: The Disk Management console failed
> > > to
> > > conect to the remote computer because the Disk Management remoting sevices
> > > is
> > > not in the Windows Firewall exception list. Add the Disk Management
> > > remoting
> > > service (dmremote.exe) to the Windows Firewall exception list and try
> > > again...
> > >
> > > Any ideas.
> >
> >
> >
Anonymous
August 16, 2005 2:25:02 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Check this out.

I fixed my XP PRO computer with SP2 to perform Disk Managment and all other
MMC snap-in administrative functions on my remote network computer (Win XP
Pro):

dmremote.exe needs to be added to the Firewall Exception List.
dmadmin.exe also needs to be added to the Firewall Exception List.

I examined my System Error Log and found the following error:

DCOM got error "The RPC server is unavailable. " from the computer %1 when
attempting to activate the server:
%2

%1= my computer network ID for computer 1

%2 is the (Default) value of
My
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{4FB6BB00-3347-11D0-B40A-00AA005FF586}
key searchable in the registry is the value of the AppID for LocalServer32

You can search for the value e.g. 4FB6BB00-3347... using regedit and finding
wherever it exists. I did this and suspected that adding dmadmin to my
exception list might fix the problem. Along with the following
configurations, this seemed to be the case.

In order for remote administration using Disk Management from MMC.exe to
work several conditions may have to or should exist:

Firewall Exception List:
TCP Port 135 should be open (Add the Port)
X:\WINDOWS\System32\dmadmin.exe (Add the program)
X:\WINDOWS\System32\dmremote.exe (Add the program)

Modify the Group Policy Settings using the Group Policy snap-in from mmc.exe:

Console Root\Local Computer Policy\Computer Configuration\Administrative
Templates\Network\Network Conifiguration\Windows Firewall\Standard Profile

Enable the following:
Define Program Exceptions (Add mmc.exe)
Allow Local Program Exceptions (Enabled)
Allow Remote Administration Exception (add * or ip of appropriate computer(s))
Define Port Exceptions (Add TCP Port 135)
Allow Local Port Exceptions (Enabled)

Also:

Configure Disk Manager Administrative Service in DCOM to allow the
appropriate Computers and Locations
to launch the service.
Start > Run > dcomcnfg
Navigate to Component Services\Computers\My Computer\DCOM Config and view
the properties (right click Properties) of the Logical Disk Manager
Administrative Service

Configure the Location Tab: Select Run application of this computer and Run
application on the following computer
- browse for and add the remote computer (ensures that it is available on
the network) or enter its Network ID

Configure the Security Tab: Allow users that are allowed to launch the
service by Customizing and checking 'Allow' for the appropriate users
(probably Administrators, Interactive, Self and System). I checked them all.

I also configured 'Logical Disk Manager Remote Client' and 'MMC Application
Class' in the same way.

Restart the computer and try Disk Management for the remote computer.

Make sure that you specify the IP address of the local computer and the
localsubnet for the ports and exceptions that are configured.

I configured the remote computer in exactly the same way using the
recipricol addresses and equivalent settings. This is probably necessary.

Finally... this was bugging me for two days.

--
Ken Niebling
MCSA/MCSE student
Sheridan Technical Center
Hollywood Florida
niebling@email.com
ken_niebling@yahoo.com


"Josh" wrote:

> I am experiencing this problem with Windows 2000 servers. I can use disk
> management just fine from my XP box to my 2003 boxes but I get the same error
> when I use disk management on a 2000 box. At first i suspected that the
> problem was that the path to the diskmanagement EXE is not the same on 2000
> and 2003. If is c:\winnt\system32 and c:\windows\system32 respectively. So I
> changed the path to %windir%\system32 but this did not help....
>
>
>
> "Edward" wrote:
>
> > I'm using a group policy, and I've run rsop and I know that the policy has
> > been set on all computers in my lab.
> >
> > "Dave" wrote:
> >
> > > did you add those to the local machine or the remote one or both?
> > >
> > > "Edward" <Edward@discussions.microsoft.com> wrote in message
> > > news:D BCF8C87-A9A2-43E0-B5FA-84C62EE02193@microsoft.com...
> > > > I'm testing XP2 on a lab at my office network.
> > > > I have added program exceptions for
> > > > c:\windows\system32\dmremote.exe:*:enabled and I've also added port
> > > > exceptions for ports 135 and 445 and I'm still unable to use Disk Manager
> > > > to
> > > > manage remote computer.
> > > > I keep getting the following message: The Disk Management console failed
> > > > to
> > > > conect to the remote computer because the Disk Management remoting sevices
> > > > is
> > > > not in the Windows Firewall exception list. Add the Disk Management
> > > > remoting
> > > > service (dmremote.exe) to the Windows Firewall exception list and try
> > > > again...
> > > >
> > > > Any ideas.
> > >
> > >
> > >
!