Sharing and Security button is missing

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I am trying to allow a Folder Share on a Windows XP machine and when I
right-click the drive I can't see this button. Any idea where did it go and
how to get it back?
(Yes, I am logged in with administrator privileges).

Thank you.
5 answers Last reply
More about sharing security button missing
  1. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    [[Troubleshooting
    If the Security tab is not available, and if you cannot configure
    permissions for users and groups, either the file or folder that you want to
    apply permissions to is not an NTFS drive, or simple file sharing is
    enabled. To troubleshoot, follow these steps:1. Verify that the file or
    folder that you want to apply permissions to is an NTFS drive. You can set
    permissions only on drives that are formatted to use NTFS.
    2. By default, simplified sharing is enabled in Windows XP unless you are on
    a domain. To work around this behavior, disable Simplified Sharing. ]]
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308418#7

    How to set, view, change, or remove file and folder permissions in Windows
    XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308418

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:uEyLsAKYFHA.3616@TK2MSFTNGP15.phx.gbl,
    John <ein_shem@hotmail.com> hunted and pecked:
    > I am trying to allow a Folder Share on a Windows XP machine and when I
    > right-click the drive I can't see this button. Any idea where did it go
    > and how to get it back?
    > (Yes, I am logged in with administrator privileges).
    >
    > Thank you.
  2. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    1. How come in other Windows XP machines I didn't have to disable the
    Simplified Sharing and it is working fine?
    2. I disabled it, re-boot the computer - still not there.
    3. The drive is NTFS.
    4. This is weird...


    "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    news:e5sbTEKYFHA.2684@TK2MSFTNGP09.phx.gbl...
    > [[Troubleshooting
    > If the Security tab is not available, and if you cannot configure
    > permissions for users and groups, either the file or folder that you want
    > to
    > apply permissions to is not an NTFS drive, or simple file sharing is
    > enabled. To troubleshoot, follow these steps:1. Verify that the file or
    > folder that you want to apply permissions to is an NTFS drive. You can set
    > permissions only on drives that are formatted to use NTFS.
    > 2. By default, simplified sharing is enabled in Windows XP unless you are
    > on
    > a domain. To work around this behavior, disable Simplified Sharing. ]]
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;308418#7
    >
    > How to set, view, change, or remove file and folder permissions in Windows
    > XP
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;308418
    >
    > --
    > Hope this helps. Let us know.
    >
    > Wes
    > MS-MVP Windows Shell/User
    >
    > In news:uEyLsAKYFHA.3616@TK2MSFTNGP15.phx.gbl,
    > John <ein_shem@hotmail.com> hunted and pecked:
    >> I am trying to allow a Folder Share on a Windows XP machine and when I
    >> right-click the drive I can't see this button. Any idea where did it go
    >> and how to get it back?
    >> (Yes, I am logged in with administrator privileges).
    >>
    >> Thank you.
    >
  3. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    John,

    1. Who knows? Why is there air?

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
    Policies\Explorer
    Value Name: NoSecurityTab
    Value Type: REG_DWORD
    Value Data: 0 or 1
    0 = Security Tab
    1 = No Security Tab

    XP Pro???

    [[Remove Security tab

    Administrative Template: System
    Policy Node: USER
    Policy Path: Administrative Templates\Windows Components\Windows Explorer
    Help/Explain Text: Removes the Security tab from Windows Explorer. If you
    enable this setting, users opening the Properties dialog box for all file
    system objects, including folders, files, shortcuts, and drives, will not be
    able to access the Security tab. As a result, users will be able to neither
    change the security settings nor view a list of all users that have access
    to the resource in question. If you disable or do not configure this
    setting, users will be able to access the security tab.
    Registry Settings:
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    NoSecurityTab ]]
    http://www.boyce.us/gp/gpcontent.asp?ID=552

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:O8YyJMKYFHA.3220@TK2MSFTNGP14.phx.gbl,
    John <ein_shem@hotmail.com> hunted and pecked:
    > 1. How come in other Windows XP machines I didn't have to disable the
    > Simplified Sharing and it is working fine?
    > 2. I disabled it, re-boot the computer - still not there.
    > 3. The drive is NTFS.
    > 4. This is weird...
    >
    >
    > "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    > news:e5sbTEKYFHA.2684@TK2MSFTNGP09.phx.gbl...
    >> [[Troubleshooting
    >> If the Security tab is not available, and if you cannot configure
    >> permissions for users and groups, either the file or folder that you want
    >> to
    >> apply permissions to is not an NTFS drive, or simple file sharing is
    >> enabled. To troubleshoot, follow these steps:1. Verify that the file or
    >> folder that you want to apply permissions to is an NTFS drive. You can
    >> set permissions only on drives that are formatted to use NTFS.
    >> 2. By default, simplified sharing is enabled in Windows XP unless you are
    >> on
    >> a domain. To work around this behavior, disable Simplified Sharing. ]]
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;308418#7
    >>
    >> How to set, view, change, or remove file and folder permissions in
    >> Windows XP
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;308418
    >>
    >> --
    >> Hope this helps. Let us know.
    >>
    >> Wes
    >> MS-MVP Windows Shell/User
    >>
    >> In news:uEyLsAKYFHA.3616@TK2MSFTNGP15.phx.gbl,
    >> John <ein_shem@hotmail.com> hunted and pecked:
    >>> I am trying to allow a Folder Share on a Windows XP machine and when I
    >>> right-click the drive I can't see this button. Any idea where did it go
    >>> and how to get it back?
    >>> (Yes, I am logged in with administrator privileges).
    >>>
    >>> Thank you.
  4. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    John,

    When you view the properties of a file or folder you will see a number of
    tabs.
    General
    Sharing
    Security
    Customize
    Version
    There may be more, depending on the type of file/folder.

    You have to do this...
    Right click a file/folder | And the click Properties |

    The sharing tab is not visible if you are logged on to a machine with an
    account that does not have adequate rights.

    The sharing option is not available for the Documents and Settings, Program
    Files, and WINDOWS system folders. In addition, you cannot share folders in
    other user's profiles.

    or...

    The Sharing tab is not visible....
    Start | Run | Type: services.msc | OK |
    Scroll down to and double click: Server service |
    Set Startup type to: Automatic | Click Apply | Click the Start button |
    When it has started, click OK

    If you do not see the Server service..........
    This will restore the Server Service (lanmanserver).

    Open Network Connections, click Start, point to Settings, click Control
    Panel, and then double-click Network Connections. | Right click Your
    Connection | Properties | General tab | Install button | Highlight: Service
    | Add button | Highlight: File and Printer Sharing for Microsoft Networks |
    OK | Close

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:O0z5YBLYFHA.3320@TK2MSFTNGP12.phx.gbl,
    John <ein_shem@hotmail.com> hunted and pecked:
    > Well, I do have the Security Tab, what don't have is the Sharing and
    > Security button when you right-click a Folder/File.
    > See below/attached:
    >
    >
    >
    > Thanks.
    >
    >
    > "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    > news:%23xkr4bKYFHA.3616@TK2MSFTNGP15.phx.gbl...
    >> John,
    >>
    >> 1. Who knows? Why is there air?
    >>
    >> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
    >> Policies\Explorer
    >> Value Name: NoSecurityTab
    >> Value Type: REG_DWORD
    >> Value Data: 0 or 1
    >> 0 = Security Tab
    >> 1 = No Security Tab
    >>
    >> XP Pro???
    >>
    >> [[Remove Security tab
    >>
    >> Administrative Template: System
    >> Policy Node: USER
    >> Policy Path: Administrative Templates\Windows Components\Windows Explorer
    >> Help/Explain Text: Removes the Security tab from Windows Explorer. If you
    >> enable this setting, users opening the Properties dialog box for all file
    >> system objects, including folders, files, shortcuts, and drives, will
    >> not be able to access the Security tab. As a result, users will be able
    >> to neither change the security settings nor view a list of all users
    >> that have access to the resource in question. If you disable or do not
    >> configure this setting, users will be able to access the security tab.
    >> Registry Settings:
    >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    >> NoSecurityTab ]]
    >> http://www.boyce.us/gp/gpcontent.asp?ID=552
    >>
    >> --
    >> Hope this helps. Let us know.
    >>
    >> Wes
    >> MS-MVP Windows Shell/User
    >>
    >> In news:O8YyJMKYFHA.3220@TK2MSFTNGP14.phx.gbl,
    >> John <ein_shem@hotmail.com> hunted and pecked:
    >>> 1. How come in other Windows XP machines I didn't have to disable the
    >>> Simplified Sharing and it is working fine?
    >>> 2. I disabled it, re-boot the computer - still not there.
    >>> 3. The drive is NTFS.
    >>> 4. This is weird...
    >>>
    >>>
    >>> "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    >>> news:e5sbTEKYFHA.2684@TK2MSFTNGP09.phx.gbl...
    >>>> [[Troubleshooting
    >>>> If the Security tab is not available, and if you cannot configure
    >>>> permissions for users and groups, either the file or folder that you
    >>>> want to
    >>>> apply permissions to is not an NTFS drive, or simple file sharing is
    >>>> enabled. To troubleshoot, follow these steps:1. Verify that the file or
    >>>> folder that you want to apply permissions to is an NTFS drive. You can
    >>>> set permissions only on drives that are formatted to use NTFS.
    >>>> 2. By default, simplified sharing is enabled in Windows XP unless you
    >>>> are on
    >>>> a domain. To work around this behavior, disable Simplified Sharing. ]]
    >>>> http://support.microsoft.com/default.aspx?scid=kb;en-us;308418#7
    >>>>
    >>>> How to set, view, change, or remove file and folder permissions in
    >>>> Windows XP
    >>>> http://support.microsoft.com/default.aspx?scid=kb;en-us;308418
    >>>>
    >>>> --
    >>>> Hope this helps. Let us know.
    >>>>
    >>>> Wes
    >>>> MS-MVP Windows Shell/User
    >>>>
    >>>> In news:uEyLsAKYFHA.3616@TK2MSFTNGP15.phx.gbl,
    >>>> John <ein_shem@hotmail.com> hunted and pecked:
    >>>>> I am trying to allow a Folder Share on a Windows XP machine and when I
    >>>>> right-click the drive I can't see this button. Any idea where did it
    >>>>> go and how to get it back?
    >>>>> (Yes, I am logged in with administrator privileges).
    >>>>>
    >>>>> Thank you.
  5. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    John,

    Have a look through these and see if you can find something I may have
    missed.

    [[Note You cannot turn off simple file sharing in Microsoft Windows XP Home
    Edition.]]

    How to disable simplified sharing and set permissions on a shared folder in
    Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;307874

    How to set, view, change, or remove file and folder permissions in
    Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308418

    HOW TO: Set, View, Change, or Remove Special Permissions for Files and
    Folders in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308419

    How to configure file sharing in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

    HOW TO: Take Ownership of a File or Folder in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308421


    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:O4xo0LWYFHA.2520@TK2MSFTNGP09.phx.gbl,
    John <ein_shem@hotmail.com> hunted and pecked:
    > Wes, thanks for the info.
    >
    > I know all that...I know that you cannot share Documents and Settings,
    > Windows, etc. I know about the adequate rights of users.
    > The problem is - I am the administrator, I am signed in as the
    > administraotr, I am trying to share a drive (not C but a different
    > part...second partition), and even if I am trying to share anything else
    > (say, a new folder that I open under C)...the problem is that the Sharing
    > and Security button (or link, whatever you want to call it) under the
    > Properties is simply not there...
    > I have File and Printer Sharing for MS installed, I removed it and
    > re-installed just in case - nothing; did not solve the problem.
    > Server is running and is set to Automatic start....
    > So everything is like it's suppose to be.
    >
    > Thanks.
    >
    >
    >
    > "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    > news:e0LhNULYFHA.712@TK2MSFTNGP14.phx.gbl...
    >> John,
    >>
    >> When you view the properties of a file or folder you will see a number of
    >> tabs.
    >> General
    >> Sharing
    >> Security
    >> Customize
    >> Version
    >> There may be more, depending on the type of file/folder.
    >>
    >> You have to do this...
    >> Right click a file/folder | And the click Properties |
    >>
    >> The sharing tab is not visible if you are logged on to a machine with an
    >> account that does not have adequate rights.
    >>
    >> The sharing option is not available for the Documents and Settings,
    >> Program Files, and WINDOWS system folders. In addition, you cannot
    >> share folders in other user's profiles.
    >>
    >> or...
    >>
    >> The Sharing tab is not visible....
    >> Start | Run | Type: services.msc | OK |
    >> Scroll down to and double click: Server service |
    >> Set Startup type to: Automatic | Click Apply | Click the Start button |
    >> When it has started, click OK
    >>
    >> If you do not see the Server service..........
    >> This will restore the Server Service (lanmanserver).
    >>
    >> Open Network Connections, click Start, point to Settings, click Control
    >> Panel, and then double-click Network Connections. | Right click Your
    >> Connection | Properties | General tab | Install button | Highlight:
    >> Service
    >>> Add button | Highlight: File and Printer Sharing for Microsoft Networks
    >>> |
    >> OK | Close
    >>
    >> --
    >> Hope this helps. Let us know.
    >>
    >> Wes
    >> MS-MVP Windows Shell/User
    >>
    >> In news:O0z5YBLYFHA.3320@TK2MSFTNGP12.phx.gbl,
    >> John <ein_shem@hotmail.com> hunted and pecked:
    >>> Well, I do have the Security Tab, what don't have is the Sharing and
    >>> Security button when you right-click a Folder/File.
    >>> See below/attached:
    >>>
    >>>
    >>>
    >>> Thanks.
    >>>
    >>>
    >>> "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    >>> news:%23xkr4bKYFHA.3616@TK2MSFTNGP15.phx.gbl...
    >>>> John,
    >>>>
    >>>> 1. Who knows? Why is there air?
    >>>>
    >>>> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
    >>>> Policies\Explorer
    >>>> Value Name: NoSecurityTab
    >>>> Value Type: REG_DWORD
    >>>> Value Data: 0 or 1
    >>>> 0 = Security Tab
    >>>> 1 = No Security Tab
    >>>>
    >>>> XP Pro???
    >>>>
    >>>> [[Remove Security tab
    >>>>
    >>>> Administrative Template: System
    >>>> Policy Node: USER
    >>>> Policy Path: Administrative Templates\Windows Components\Windows
    >>>> Explorer Help/Explain Text: Removes the Security tab from Windows
    >>>> Explorer. If you enable this setting, users opening the Properties
    >>>> dialog box for all file system objects, including folders, files,
    >>>> shortcuts, and drives, will not be able to access the Security tab. As
    >>>> a result, users will be able to neither change the security settings
    >>>> nor view a list of all users that have access to the resource in
    >>>> question. If you disable or do not configure this setting, users will
    >>>> be able to access the security tab. Registry Settings:
    >>>> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    >>>> NoSecurityTab ]]
    >>>> http://www.boyce.us/gp/gpcontent.asp?ID=552
    >>>>
    >>>> --
    >>>> Hope this helps. Let us know.
    >>>>
    >>>> Wes
    >>>> MS-MVP Windows Shell/User
    >>>>
    >>>> In news:O8YyJMKYFHA.3220@TK2MSFTNGP14.phx.gbl,
    >>>> John <ein_shem@hotmail.com> hunted and pecked:
    >>>>> 1. How come in other Windows XP machines I didn't have to disable the
    >>>>> Simplified Sharing and it is working fine?
    >>>>> 2. I disabled it, re-boot the computer - still not there.
    >>>>> 3. The drive is NTFS.
    >>>>> 4. This is weird...
    >>>>>
    >>>>>
    >>>>> "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    >>>>> news:e5sbTEKYFHA.2684@TK2MSFTNGP09.phx.gbl...
    >>>>>> [[Troubleshooting
    >>>>>> If the Security tab is not available, and if you cannot configure
    >>>>>> permissions for users and groups, either the file or folder that you
    >>>>>> want to
    >>>>>> apply permissions to is not an NTFS drive, or simple file sharing is
    >>>>>> enabled. To troubleshoot, follow these steps:1. Verify that the file
    >>>>>> or folder that you want to apply permissions to is an NTFS drive.
    >>>>>> You can set permissions only on drives that are formatted to use
    >>>>>> NTFS.
    >>>>>> 2. By default, simplified sharing is enabled in Windows XP unless you
    >>>>>> are on
    >>>>>> a domain. To work around this behavior, disable Simplified Sharing.
    >>>>>> ]] http://support.microsoft.com/default.aspx?scid=kb;en-us;308418#7
    >>>>>>
    >>>>>> How to set, view, change, or remove file and folder permissions in
    >>>>>> Windows XP
    >>>>>> http://support.microsoft.com/default.aspx?scid=kb;en-us;308418
    >>>>>>
    >>>>>> --
    >>>>>> Hope this helps. Let us know.
    >>>>>>
    >>>>>> Wes
    >>>>>> MS-MVP Windows Shell/User
    >>>>>>
    >>>>>> In news:uEyLsAKYFHA.3616@TK2MSFTNGP15.phx.gbl,
    >>>>>> John <ein_shem@hotmail.com> hunted and pecked:
    >>>>>>> I am trying to allow a Folder Share on a Windows XP machine and
    >>>>>>> when I right-click the drive I can't see this button. Any idea
    >>>>>>> where did it go and how to get it back?
    >>>>>>> (Yes, I am logged in with administrator privileges).
    >>>>>>>
    >>>>>>> Thank you.
Ask a new question

Read More

Security Microsoft Windows XP