Sign in with
Sign up | Sign in
Your question

Folder not inheritting permissions

Last response: in Windows XP
Share
Anonymous
a b 8 Security
June 2, 2005 12:24:02 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I need to lock down the hard drive so users don't have write access.

I applied permissions for the users group, and creator owner at the C:\
level and enabled it to propagate to all child objects.

The permissions were successfully pushed to all subfolders with one
exception. When new user accounts are created their associated profile
directory C:\Documents and Settings\user folder doesn't inherit the
permissions.

Is there a way I can fix this, other than having the new user logon (which
will create the folder) then logging on with my account which has admin
rights to manually set permissions on the folder?

Running WXP SP2

Thanks.
Anonymous
a b 8 Security
June 2, 2005 5:24:42 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

You can't completely disable write access to the user's Documents and Settings\<username> folder. NTUSER.DAT which stores the user's portion of the registry is located there, and no user settings would be able to be saved. This may cause various applications to not function correctly or generate errors. Additionally, other folders in Documents and Settings need to be able to be written to, so that applications can save their information.

--
Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
Win 95/98/Me/XP Tweaks and Fixes
http://www.dougknox.com
--------------------------------
Per user Group Policy Restrictions for XP Home and XP Pro
http://www.dougknox.com/xp/utils/xp_securityconsole.htm
--------------------------------
Please reply only to the newsgroup so all may benefit.
Unsolicited e-mail is not answered.

"Barb" <Barb@discussions.microsoft.com> wrote in message news:7B892175-A1B6-4077-B32B-A709E475C63C@microsoft.com...
>I need to lock down the hard drive so users don't have write access.
>
> I applied permissions for the users group, and creator owner at the C:\
> level and enabled it to propagate to all child objects.
>
> The permissions were successfully pushed to all subfolders with one
> exception. When new user accounts are created their associated profile
> directory C:\Documents and Settings\user folder doesn't inherit the
> permissions.
>
> Is there a way I can fix this, other than having the new user logon (which
> will create the folder) then logging on with my account which has admin
> rights to manually set permissions on the folder?
>
> Running WXP SP2
>
> Thanks.
!