No users can access 'Shared Documents' folder

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

For some reason my admin account is the only one that can access files in the
'Shared Documents' folder. I thought this folder was suppose to be
accessible to every login on my system. What the heck happened? I get a
'You don't have the proper permissions' error thrown up...very annoying.
7 answers Last reply
More about users access shared documents folder
  1. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Are you running XP Home or Pro? Big difference. However, you need to ensure that the Everyone group has the access rights you wish to grant.

    XP PRO: In Windows Explorer, go to Tools, Folder Options, View and uncheck Use Simple File Sharing. Now, when you right click on a drive, folder or file (on an NTFS partition) and select Properties, you'll see a Security tab. Here you can assign or deny permissions based on user name or user group membership.

    XP Home: By default, you can only make files and folders under My Documents "private". This is done by right clicking a folder or file and selecting Properties, Sharing. To change the permissions on other folders, you need to boot the computer to Safe Mode and log in on the built in Administrator account. In this mode, you'll see the Security tab in Properties, and you can assign permissions based on user name or group membership.

    HOW TO: Set, View, Change, or Remove File and Folder Permissions in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308418

    HOW TO: Set, View, Change, or Remove Special Permissions for Files and Folders
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;308419

    HOW TO: Disable Simplified Sharing and Password-Protect a Shared Folder in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;307874


    --
    Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
    Win 95/98/Me/XP Tweaks and Fixes
    http://www.dougknox.com
    --------------------------------
    Per user Group Policy Restrictions for XP Home and XP Pro
    http://www.dougknox.com/xp/utils/xp_securityconsole.htm
    --------------------------------
    Please reply only to the newsgroup so all may benefit.
    Unsolicited e-mail is not answered.

    "gregg" <gregg@discussions.microsoft.com> wrote in message news:6E64AE94-0151-4487-B0A8-119A5D5BFFF9@microsoft.com...
    > For some reason my admin account is the only one that can access files in the
    > 'Shared Documents' folder. I thought this folder was suppose to be
    > accessible to every login on my system. What the heck happened? I get a
    > 'You don't have the proper permissions' error thrown up...very annoying.
  2. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    I use XP Home and had a problem that was almost similar to this one. Users
    could access, and add to folders and documents in the Shared Folder, but any
    existing files opened as read only, including the ones they had created if
    they had subsequently been edited by a user with an administrator account.
    Starting in safe mode, logging on as the default admin account and then
    giving users "Modify" permission has cured this. Not forgetting to tick the
    propogate permissions to child objects check box. I am well accustomed to
    assigning permissions in Windows 2K and NT4 so find this quirk of XP Home
    very frustrating.

    "Doug Knox MS-MVP" wrote:

    > Are you running XP Home or Pro? Big difference. However, you need to ensure that the Everyone group has the access rights you wish to grant.
    >
    > XP PRO: In Windows Explorer, go to Tools, Folder Options, View and uncheck Use Simple File Sharing. Now, when you right click on a drive, folder or file (on an NTFS partition) and select Properties, you'll see a Security tab. Here you can assign or deny permissions based on user name or user group membership.
    >
    > XP Home: By default, you can only make files and folders under My Documents "private". This is done by right clicking a folder or file and selecting Properties, Sharing. To change the permissions on other folders, you need to boot the computer to Safe Mode and log in on the built in Administrator account. In this mode, you'll see the Security tab in Properties, and you can assign permissions based on user name or group membership.
    >
    > HOW TO: Set, View, Change, or Remove File and Folder Permissions in Windows XP
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;308418
    >
    > HOW TO: Set, View, Change, or Remove Special Permissions for Files and Folders
    > http://support.microsoft.com/default.aspx?scid=kb;EN-US;308419
    >
    > HOW TO: Disable Simplified Sharing and Password-Protect a Shared Folder in Windows XP
    > http://support.microsoft.com/default.aspx?scid=kb;EN-US;307874
    >
    >
    > --
    > Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
    > Win 95/98/Me/XP Tweaks and Fixes
    > http://www.dougknox.com
    > --------------------------------
    > Per user Group Policy Restrictions for XP Home and XP Pro
    > http://www.dougknox.com/xp/utils/xp_securityconsole.htm
    > --------------------------------
    > Please reply only to the newsgroup so all may benefit.
    > Unsolicited e-mail is not answered.
    >
    > "gregg" <gregg@discussions.microsoft.com> wrote in message news:6E64AE94-0151-4487-B0A8-119A5D5BFFF9@microsoft.com...
    > > For some reason my admin account is the only one that can access files in the
    > > 'Shared Documents' folder. I thought this folder was suppose to be
    > > accessible to every login on my system. What the heck happened? I get a
    > > 'You don't have the proper permissions' error thrown up...very annoying.
    >
  3. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Suscalian, I have the very same problem you describe with XP Home Edition.

    Please forgive my ignorance. I know how to start the computer in Safe Mode
    and log on as the default admin. But, I have no clue as to how to give users
    "modify permission". Please would you tell me how to do this (or where to
    find the answer)?

    Thank you.
  4. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    XP Home: To change the permissions on other folders, you need to boot the computer to Safe Mode and log in on the built in Administrator account. In this mode, you'll see the Security tab in Properties, and you can assign permissions based on user name or group membership.

    HOW TO: Set, View, Change, or Remove File and Folder Permissions in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308418

    HOW TO: Set, View, Change, or Remove Special Permissions for Files and Folders
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;308419

    HOW TO: Disable Simplified Sharing and Password-Protect a Shared Folder in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;307874


    --
    Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
    Win 95/98/Me/XP Tweaks and Fixes
    http://www.dougknox.com
    --------------------------------
    Per user Group Policy Restrictions for XP Home and XP Pro
    http://www.dougknox.com/xp/utils/xp_securityconsole.htm
    --------------------------------
    Please reply only to the newsgroup so all may benefit.
    Unsolicited e-mail is not answered.

    "Paddy" <Paddy@discussions.microsoft.com> wrote in message news:E9313319-0607-47B8-9366-BE09C39287DD@microsoft.com...
    > Suscalian, I have the very same problem you describe with XP Home Edition.
    >
    > Please forgive my ignorance. I know how to start the computer in Safe Mode
    > and log on as the default admin. But, I have no clue as to how to give users
    > "modify permission". Please would you tell me how to do this (or where to
    > find the answer)?
    >
    > Thank you.
  5. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Doug, thank you for those pointers. In testing both before and after the
    changes, I found it's even worse than I thought.

    Each user cannot move or rename files or folders, even in THEIR OWN "My
    Documents" folders!

    Following Suscalian and your instructions, I've added every permission to
    every user, including "Full Control". I've gone into "Special Permissions"
    and ensured that every user has every permission. Still, it makes no
    difference.

    I've given up, and made every user an Administrator. I don't know what else
    to do!

    Thanks again for your answers.
  6. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    It should not be necessary to make every user an Administrator. Additionally, Group permissions can be more restrictive than User permissions. Particularly if the Deny box is checked (avoid this whenever possible).

    For a particular user's folders, under Documents and Settings, assign ownership to the user that the folder belongs to.

    See Help and Support and search for "take ownership"

    HOW TO: Take Ownership of a File or Folder in Windows XP
    http://support.microsoft.com/?id=308421

    --
    Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
    Win 95/98/Me/XP Tweaks and Fixes
    http://www.dougknox.com
    --------------------------------
    Per user Group Policy Restrictions for XP Home and XP Pro
    http://www.dougknox.com/xp/utils/xp_securityconsole.htm
    --------------------------------
    Please reply only to the newsgroup so all may benefit.
    Unsolicited e-mail is not answered.

    "Paddy" <Paddy@discussions.microsoft.com> wrote in message news:DA90A1A7-E6B0-453A-8675-E281683D880A@microsoft.com...
    > Doug, thank you for those pointers. In testing both before and after the
    > changes, I found it's even worse than I thought.
    >
    > Each user cannot move or rename files or folders, even in THEIR OWN "My
    > Documents" folders!
    >
    > Following Suscalian and your instructions, I've added every permission to
    > every user, including "Full Control". I've gone into "Special Permissions"
    > and ensured that every user has every permission. Still, it makes no
    > difference.
    >
    > I've given up, and made every user an Administrator. I don't know what else
    > to do!
    >
    > Thanks again for your answers.
  7. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Doug, I appreciate your answers. To confirm, I've ensured that, for EVERY user:

    1. The user owns his own folders;
    2. All permissions, including "Full Control", are checked, including for the
    children files and folders:
    (a) For "Shared Documents" (and its children), and
    (b) For "My Documents" AND its parent (and their children);
    3. None of the "Deny" boxes is checked for the above folders.

    Still, it doesn't work!

    So, unfortunately, after playing with it some more, I have had to continue
    with keeping every user as an Administrator.

    I realise, as you say, "It should not be necessary to make every user an
    Administrator." Sadly, as you know, MS Windows is not the easiest or most
    reliable operating system in the world, so unless you have some clever fix
    for this, I'll have to stick with Administrator for everyone!

    Again, Doug, thank you for your efforts.
Ask a new question

Read More

Security Microsoft Windows XP