Sign in with
Sign up | Sign in
Your question

Some programs do not run unless run as is used

Last response: in Windows XP
Share
Anonymous
July 18, 2005 1:22:02 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I am running Windows XP Home SP2 with all the latest service packs I can only
run some programs by right clicking and 'run as' using the account I am
already logged on as the Administrator account doesn't appear in the drop
down. The account I use is in the Administrators group. I have tried creating
a new account but it has the same problem. Help and Support doesn't run from
the start menu I can only start it by doing a 'run as' from the location of
the program also the 'link' from the event viewer does nothing. This problem
doesn't occur when running in Safe mode, I have tried changing the owner of
all files and folders on drive C: to Administrators and given full access to
my account but still no good. Any ideas.

More about : programs run run

Anonymous
August 10, 2005 11:16:06 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

When I 'run as' PSP with current username the program says that it cannot
access files under my name or anywhere else on the drive I have changed the
security permissions including ownership on the drive and the documents a
dozen times giving me and Administrators and System full access but this has
no affect, this is also affecting Word and Excel where a file will not open
when double clicked, I have tried all the suggestions under those threads in
the Office newsgroups.

Is there anything that can be corrupted under the 'Security' settings in XP
pro that could be causing this.

The problem still happens even if I create a new Admin user and logon with it.

I have also posted this on another post with regards to Programs won't launch:

I still have the same problems with Help and support and Paint Shop Pro even
if I add them to the DEP list

"Adobird" wrote:

> I may have found an answer to the problem KB873158 and KB87532 in Help and
> Support may be helpful.
>
> "Adobird" wrote:
>
> > I am having the same problems I think it may be one of the latest Windows
> > (Security?) updates causing it as I formatted my drive and reinstalled
> > Windows XP Pro SP2 and once all the latest upates were downloaded and
> > installed the problem came back I have tried toggling DEP and rebooting but
> > its still no good. I can however right click the exe file or a shortcut and
> > if I do a 'run as' and select the userid that I am already logged onto the
> > machine with, the programs start up ok. This problem is only occurring on one
> > of my pc's, an HP Pavilion 724a it is not occurring on my old pc or my IBM
> > laptop all of which have XP at the same level.



"Adobird" wrote:

> I am running Windows XP Home SP2 with all the latest service packs I can only
> run some programs by right clicking and 'run as' using the account I am
> already logged on as the Administrator account doesn't appear in the drop
> down. The account I use is in the Administrators group. I have tried creating
> a new account but it has the same problem. Help and Support doesn't run from
> the start menu I can only start it by doing a 'run as' from the location of
> the program also the 'link' from the event viewer does nothing. This problem
> doesn't occur when running in Safe mode, I have tried changing the owner of
> all files and folders on drive C: to Administrators and given full access to
> my account but still no good. Any ideas.
Related resources
!