STUMPED: Sharing Issue on "My Documents" folder

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

A Users machine is running XP Professional SP2 in a networked environment
(Windows 2000 server). I created a share on the “My Documents� folder called
“Andys_Documents� with the User Limit set to maximum and the Share
Permissions settings dialog is Everyone with Full Control, Change and Read
all set to “allow�. The Security Tab has “Everyone� as the third item listed
(below the local user account and the users account on the domain) which show
permissions as “allow� for all elements (full control, modify, etc) except
for ‘special permissions’ which is greyed out entirely.

- On any other XP Pro machine (regardless of service pack) they can find the
“Andys_Documents� share and edit files in this folder and any sub folders no
problem.

- On Windows 2000 Pro machines (regardless of service pack) they *can* find
the “Andys_Documents� share and edit files (and save) on this folder no
problem. However doing the *exact* same operation (edit and saving a file)
in any *subfolder* of “Andys_Documents� isn’t allowed. When the app tries
to save it I get a message that either the file is “read only� (for MS Office
files) or to “make sure that the full path and filename are correct� (notepad
..txt files). I can save the files if I use a different filename, however.

I am stumped. Please help!

Thanks,
Glenn
3 answers Last reply
More about stumped sharing issue documents folder
  1. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    From: "Glenn" <glennb/at/team/hypen/sys/dotcom>

    | A Users machine is running XP Professional SP2 in a networked environment
    | (Windows 2000 server). I created a share on the “My Documents” folder called
    | “Andys_Documents” with the User Limit set to maximum and the Share
    | Permissions settings dialog is Everyone with Full Control, Change and Read
    | all set to “allow”. The Security Tab has “Everyone” as the third item listed
    | (below the local user account and the users account on the domain) which show
    | permissions as “allow” for all elements (full control, modify, etc) except
    | for ‘special permissions’ which is greyed out entirely.
    |
    | - On any other XP Pro machine (regardless of service pack) they can find the
    | “Andys_Documents” share and edit files in this folder and any sub folders no
    | problem.
    |
    | - On Windows 2000 Pro machines (regardless of service pack) they *can* find
    | the “Andys_Documents” share and edit files (and save) on this folder no
    | problem. However doing the *exact* same operation (edit and saving a file)
    | in any *subfolder* of “Andys_Documents” isn’t allowed. When the app tries
    | to save it I get a message that either the file is “read only” (for MS Office
    | files) or to “make sure that the full path and filename are correct” (notepad
    | .txt files). I can save the files if I use a different filename, however.
    |
    | I am stumped. Please help!
    |
    | Thanks,
    | Glenn


    What about the NTFS permissions on the folder and sub-folders the share points to ?

    --
    Dave
    http://www.claymania.com/removal-trojan-adware.html
    http://www.ik-cs.com/got-a-virus.htm
  2. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Hi Dave and thanks for your reply.

    I am not entirely sure what you are asking. Looking at the file attributes
    via Windows Explorer (View | Choose Details | Attributes) nothing seems
    unusual. The files are not marked "read only" or any other restrictive
    measure that I can tell. Is there something else I should look at?

    Not sure if this gives any further clues: For kicks I shared one of the
    subdirectories. Under the the Share tab I switched the Everyone permission
    to include full control. When I applied this I was still unable to save the
    files. However I then went to the Security tab and needed to add "Everyone"
    in the 'Group or user names' list, and set that to full control. Once that
    as done, I was able to save the files either navigating through from that
    share OR drilling down to that subfolder from the "Andys_Documents" share.

    So it looks like that maybe the subfolders aren't inheriting this permission
    (only for Windows 2000 clients, not XP). I do have the first check box,
    marked "Inherit from parent the permission entries that apply to child
    objects. Include these with ehtries explicityl defined here" under the
    Security tab | Advanced with "Everyone" highlighted.

    Thanks,
    Glenn

    "David H. Lipman" wrote:

    > From: "Glenn" <glennb/at/team/hypen/sys/dotcom>
    >
    > | A Users machine is running XP Professional SP2 in a networked environment
    > | (Windows 2000 server). I created a share on the “My Documents� folder called
    > | “Andys_Documents� with the User Limit set to maximum and the Share
    > | Permissions settings dialog is Everyone with Full Control, Change and Read
    > | all set to “allow�. The Security Tab has “Everyone� as the third item listed
    > | (below the local user account and the users account on the domain) which show
    > | permissions as “allow� for all elements (full control, modify, etc) except
    > | for ‘special permissions’ which is greyed out entirely.
    > |
    > | - On any other XP Pro machine (regardless of service pack) they can find the
    > | “Andys_Documents� share and edit files in this folder and any sub folders no
    > | problem.
    > |
    > | - On Windows 2000 Pro machines (regardless of service pack) they *can* find
    > | the “Andys_Documents� share and edit files (and save) on this folder no
    > | problem. However doing the *exact* same operation (edit and saving a file)
    > | in any *subfolder* of “Andys_Documents� isn’t allowed. When the app tries
    > | to save it I get a message that either the file is “read only� (for MS Office
    > | files) or to “make sure that the full path and filename are correct� (notepad
    > | .txt files). I can save the files if I use a different filename, however.
    > |
    > | I am stumped. Please help!
    > |
    > | Thanks,
    > | Glenn
    >
    >
    > What about the NTFS permissions on the folder and sub-folders the share points to ?
    >
    > --
    > Dave
    > http://www.claymania.com/removal-trojan-adware.html
    > http://www.ik-cs.com/got-a-virus.htm
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    What Glen ment was what are the file permissions. If u are using an NTFS
    filing system then you should check who all can access the files.

    In the windows exployer right click the folder u are sharing and click
    'Security'. Ensure that everyone can access it.

    Regards
    ishan


    "Glenn" wrote:

    > Hi Dave and thanks for your reply.
    >
    > I am not entirely sure what you are asking. Looking at the file attributes
    > via Windows Explorer (View | Choose Details | Attributes) nothing seems
    > unusual. The files are not marked "read only" or any other restrictive
    > measure that I can tell. Is there something else I should look at?
    >
    > Not sure if this gives any further clues: For kicks I shared one of the
    > subdirectories. Under the the Share tab I switched the Everyone permission
    > to include full control. When I applied this I was still unable to save the
    > files. However I then went to the Security tab and needed to add "Everyone"
    > in the 'Group or user names' list, and set that to full control. Once that
    > as done, I was able to save the files either navigating through from that
    > share OR drilling down to that subfolder from the "Andys_Documents" share.
    >
    > So it looks like that maybe the subfolders aren't inheriting this permission
    > (only for Windows 2000 clients, not XP). I do have the first check box,
    > marked "Inherit from parent the permission entries that apply to child
    > objects. Include these with ehtries explicityl defined here" under the
    > Security tab | Advanced with "Everyone" highlighted.
    >
    > Thanks,
    > Glenn
    >
    > "David H. Lipman" wrote:
    >
    > > From: "Glenn" <glennb/at/team/hypen/sys/dotcom>
    > >
    > > | A Users machine is running XP Professional SP2 in a networked environment
    > > | (Windows 2000 server). I created a share on the “My Documents� folder called
    > > | “Andys_Documents� with the User Limit set to maximum and the Share
    > > | Permissions settings dialog is Everyone with Full Control, Change and Read
    > > | all set to “allow�. The Security Tab has “Everyone� as the third item listed
    > > | (below the local user account and the users account on the domain) which show
    > > | permissions as “allow� for all elements (full control, modify, etc) except
    > > | for ‘special permissions’ which is greyed out entirely.
    > > |
    > > | - On any other XP Pro machine (regardless of service pack) they can find the
    > > | “Andys_Documents� share and edit files in this folder and any sub folders no
    > > | problem.
    > > |
    > > | - On Windows 2000 Pro machines (regardless of service pack) they *can* find
    > > | the “Andys_Documents� share and edit files (and save) on this folder no
    > > | problem. However doing the *exact* same operation (edit and saving a file)
    > > | in any *subfolder* of “Andys_Documents� isn’t allowed. When the app tries
    > > | to save it I get a message that either the file is “read only� (for MS Office
    > > | files) or to “make sure that the full path and filename are correct� (notepad
    > > | .txt files). I can save the files if I use a different filename, however.
    > > |
    > > | I am stumped. Please help!
    > > |
    > > | Thanks,
    > > | Glenn
    > >
    > >
    > > What about the NTFS permissions on the folder and sub-folders the share points to ?
    > >
    > > --
    > > Dave
    > > http://www.claymania.com/removal-trojan-adware.html
    > > http://www.ik-cs.com/got-a-virus.htm
    > >
    > >
    > >
Ask a new question

Read More

My Documents Windows XP