Sign in with
Sign up | Sign in
Your question

Cant get g700 or Mamba to work on win 7 64 g51j

Tags:
  • Drivers
  • Asus
  • Mice
  • Windows 7
Last response: in Windows 7
Share
December 13, 2010 4:32:57 AM

I've been on the phone with Razer and Logitech and ASUS but no one can get either mice working. I have an ASUS G51j-A1 with Windows 7 64 bit Professional. I've loaded the latest drivers for both the Razor Mamba and the Logitech G700 gaming mouse. I've tried to update the driver once windows recognizes something in the USB. They come up in the Other Devices of the Device Manager, but they wont recognize them during the update driver option. Razer has been the most ardent tech support and called me back a couple times with ideas. ASUS support is utterly pathetic wich is a dissapointment after having an otherwise great experienct with this laptop so far. I've hit f8 to disable driver signing. I've run the driver installs as admin. I've turned off user account control settings. I've turned off Microsoft Security Essentials virusscan. The mice work fine on my old D830 Win7 64 laptop and my old Dell Optiplex 755 Win7 32 box. I've updated every driver available from ASUS for this laptop and updated the BIOS to the latest version. I've updated the firmware on the mice from the other machines and still they won't come up on this laptop. I've tried all 4 USB ports and they don't work in any of them. The lights come up on the mice when I plug the USB cable in so I know it is getting power, but the mouse does not get recognized and operate in Windows. I bought the G700 first and figured maybe it was just the driver and got the Razer Mamba as a second choice, but when neither of them worked I think maybe it is somethign else on my system keeping them from working. The Device Manager says the USB hub is HID compliant.
Anybody have any other ideas of how to get either of these working?
Oh btw did I mention that ASUS support was utterly useless?
Any help would be appreciated.
Thanks,
KindlePower

More about : g700 mamba work win g51j

December 13, 2010 4:48:06 AM

You could try toggling the "Enable Legacy USB support" setting in the BIOS if it's there. It might be preventing your USB peripherals from interfacing properly with the system.
m
0
l
December 13, 2010 3:27:36 PM

Good thought and thanks for your response GraceFully. I forgot to mention that I did go in and flip the legacy support on the BIOS USB setting. It doesn't work either way:-(

Any other ideas?

Thanks!
KindlePower
m
0
l
December 14, 2010 7:06:47 AM

I'll just post a few ideas, see if they work.

1. Try different USB ports.
2. Completely uninstall all of the drivers of the mice then try them without installing drivers.
3. If I remember correctly, ASUS has a mouse utility for the trackpad. Could that be interfering with the other devices?

I'll think of some more on the way home.
m
0
l
!