Sign in with
Sign up | Sign in
Your question

File Permission Errors

Last response: in Windows 7
Share
December 13, 2010 6:41:29 PM

Recently I have been receiving lots of File Permission Errors when saving documents. I have searched the internet endlessly and have still not found a solution.

Sometimes, when I save from Word (2010) I get this error:
Quote:
Word cannot complete the save due to a file permission error.
Then I can retry, it asks me to overwrite the old file and it works.

I am running Windows 7 64 bit Ultimate.

It is also happening in other applications. Such as Photoshop (CS5), again I resave and overwrite and it works.

This is IMMENSELY :fou:  annoying so any help is appreciated! :D 

More about : file permission errors

December 18, 2010 12:45:34 PM

*bump*
Related resources
December 26, 2010 12:16:31 PM

No, I don't use Live OneCare...

Any other suggestions.
I think it's something to do with my file permission settings.

Any help is appreciated.
January 1, 2011 7:19:39 PM

any other ideas?!
a b $ Windows 7
January 2, 2011 4:30:02 PM


Are you in a network in which another person might be working on the same file? Is "Always create a backup copy" ticked in Tools menu>Options>Save? How long is the filename of a document that behaves like this, including the full path?

January 8, 2011 12:51:23 PM

It's not to do with a network and even if I'm working near the root of the drive it still has this problem so full path length isn't the problem.

It's something to do with the permission settings? Anyone who knows permissions well can hopefully help!
July 19, 2011 3:10:26 PM

I am having the same issue. Sometimes when my users are trying to save a document from Office whether it be excel or word or even a pdf for that matter it says the user doesn't have the right permissions and then they try it again and it works fine...I am using windows 7 pro on a network and the user has admin rights on the machine and the permissions are correct on the share for security and shared permissions. I did try disabling Offline files, it worked for a little while, but now they are popping up again. Has anyone else had success???
July 20, 2011 7:30:39 AM

Because the events are occuring randomly, it could be a virusscanner or something that locks access to the file temporarily when it's being scanned. You could check it's settings if it's actively protecting files in use or something.
September 16, 2011 2:41:45 PM

I had tried all of the 'Take Ownership' style 'fixes' that I could find. Some would work temporarily, then revert back to the error, and some wouldn't work at all. Last night I stumbled across a thread on another site regarding 'icalcs' which is a Windows utility that edits ACLs (access control lists).

Long story short, I started running this utility via CMD prompt on my 1TB USB 3.0 drive and after an hour, went to bed. When I awakened, the utility had finished after processing nearly 400,000 files and my permission error problems are gone!

The blog where I found this information is located at:
http://lallousx86.wordpress.com/2009/06/14/resetting-nt...

However, many readers were having problems running the utility (not sure why), so I created a .BAT file that does it for you. Simply place the .BAT file in the directory to have its permissions reset, and run the file as an administrator.

You can download the .BAT from my site:
http://www.enoctis.net/shared/Win7_File-Permissions.zip

I hope everyone finds this useful and that they have as much luck as I did with it. My external drive is now error free.

Best Regards,

Sean Reeves
SPC, USa
Armorer NCO
!