File permissions on windows xp - home edition

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

How do I set file permissions on windows xp-home edition? I do not see the
security tab on the folder/file property window.

Thanks.
11 answers Last reply
More about file permissions windows home edition
  1. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    M.V. wrote:
    > How do I set file permissions on windows xp-home edition? I do not
    > see the security tab on the folder/file property window.
    >
    > Thanks.

    You need to disable simple file sharing which on Home Edition, you can only
    do in Safe Mode AFAIK. Also I think you can't set permissions unless you are
    in Safe Mode with Home Edition.
  2. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    snip
    >
    >You need to disable simple file sharing which on Home Edition, you can only
    >do in Safe Mode AFAIK. Also I think you can't set permissions unless you are
    >in Safe Mode with Home Edition.
    >

    Hi.

    I also have problems setting file permissions, e.g. the 'read-only'
    setting for a folder is ticked in grey, it can be changed but when I
    look again it is back.

    This is making life difficult for me re. folder settings for writing
    to files using active server pages under IIS.

    I'm using XP Pro. The Help also mentions the security tab which I
    can't find. Is Safe Mode the only answer here too?

    Thanx.

    Daniél Palm
    Disability is not inability
  3. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    "Daniél Palm" <pdp@lando.co.za> wrote in message
    news:r8edg1p9puirjbt0pa9oli7fpevsisipbf@4ax.com...
    > snip
    >>
    >>You need to disable simple file sharing which on Home Edition, you can
    >>only
    >>do in Safe Mode AFAIK. Also I think you can't set permissions unless you
    >>are
    >>in Safe Mode with Home Edition.
    >>
    >
    > Hi.
    >
    > I also have problems setting file permissions, e.g. the 'read-only'
    > setting for a folder is ticked in grey, it can be changed but when I
    > look again it is back.
    >
    > This is making life difficult for me re. folder settings for writing
    > to files using active server pages under IIS.
    >
    > I'm using XP Pro. The Help also mentions the security tab which I
    > can't find. Is Safe Mode the only answer here too?
    >

    This is by design. It is cosmetic and usually there is no need to change it.
    You can change it with the attrib command if needed. The problem you are
    having is probably to do with NTFS or share permissions not folder
    attributes.

    http://support.microsoft.com/default.aspx?scid=kb;en-us;326549

    Kerry
  4. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    "Gordon" <gordon@gbpcomputing.co.uk.invalid> wrote in message
    news:%236Jml0MpFHA.3004@TK2MSFTNGP15.phx.gbl...
    > M.V. wrote:
    >> How do I set file permissions on windows xp-home edition? I do not
    >> see the security tab on the folder/file property window.
    >>
    >> Thanks.
    >
    > You need to disable simple file sharing which on Home Edition, you can
    > only do in Safe Mode AFAIK. Also I think you can't set permissions unless
    > you are in Safe Mode with Home Edition.
    >

    Simple file sharing cannot be turned off in Home. You can use safe mode to
    access NTFS permissions.

    http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

    Kerry
  5. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    "Daniél Palm" <pdp@lando.co.za> wrote in message
    news:r8edg1p9puirjbt0pa9oli7fpevsisipbf@4ax.com...
    > snip
    >>
    >>You need to disable simple file sharing which on Home Edition, you can only
    >>do in Safe Mode AFAIK. Also I think you can't set permissions unless you are
    >>in Safe Mode with Home Edition.
    >>
    >
    > Hi.
    >
    > I also have problems setting file permissions, e.g. the 'read-only'
    > setting for a folder is ticked in grey, it can be changed but when I
    > look again it is back.
    >
    > This is making life difficult for me re. folder settings for writing
    > to files using active server pages under IIS.
    >
    > I'm using XP Pro. The Help also mentions the security tab which I
    > can't find. Is Safe Mode the only answer here too?
    >
    > Thanx.
    >
    > Daniél Palm
    > Disability is not inability


    To access the Security Tab in WinXP Pro:-
    Go to Control Panel > Folder Options > View and uncheck
    "Use Simple File Sharing" and click "Apply".
  6. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    On Sat, 20 Aug 2005 23:54:20 +1000, "TaurArian [MVP]"
    <taurarianREMOVECAPS@hotmail.com> wrote:

    snip

    >To access the Security Tab in WinXP Pro:-
    >Go to Control Panel > Folder Options > View and uncheck
    >"Use Simple File Sharing" and click "Apply".

    Thanks!

    Daniél Palm
    Disability is not inability
  7. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    I am in deep trouble: using Win XP Home SP2, starting up in Safe Mode,
    accessing the security tab on my NTFS System/OS partition (C:) I still can
    not change folder permissions - which I want to do specifically for
    C:\Programs and subsolders - my applications can not write to theire own
    folders, because somehow the write prtoection is on for ALL these folders and
    subfolders. (I have this annoying grey/green box write lock on all my folders
    here.)

    I open to the security tab and changed the advanced security permissions for
    admins, myself, users and even for anybody (I know this is dangerous, but I'm
    simply desperate) to allow ubiquitious access to everything for all folders,
    subfolders and files (i.e. I did this for C:, C:\Programs and also tried it
    for some subfolders). Still I can not unset the d..n write lock (note this is
    in safe mode!)!! Even if I go into the command console, trying to unset
    permissions with "attrib -R C:\somepath" or "attrib -R C:\sompath /s /d"
    nothing changes at all. (I also made sure I am the owner of all the files by
    resetting me as owner for all files in all folders and subfolders)

    I am clueless now - what is wrong, how can I otherwise get into the real
    Admin mode to change those annoying file access permissions?! Pleas help,
    thank you!!

    "Kerry Brown" wrote:


    > Simple file sharing cannot be turned off in Home. You can use safe mode to
    > access NTFS permissions.
  8. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    maybe I should add for clarification:
    1) the file permissions do change, but the folder permissions stay unchanged
    (as described in
    http://support.microsoft.com/default.aspx?scid=kb;en-us;326549
    concering the attrib command)
    2) owners of folders and files now are: Admins, and me (not me alone)
    3) it's a regular NTFS partition, with no shares (at least I did not set any
    shares...) I am aware of
  9. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    "Florian Leitner" <Florian Leitner@discussions.microsoft.com> wrote in
    message news:A1FA68A4-5448-4567-A9B9-63FAB460CC4D@microsoft.com...
    >I am in deep trouble: using Win XP Home SP2, starting up in Safe Mode,
    > accessing the security tab on my NTFS System/OS partition (C:) I still can
    > not change folder permissions - which I want to do specifically for
    > C:\Programs and subsolders - my applications can not write to theire own
    > folders, because somehow the write prtoection is on for ALL these folders
    > and
    > subfolders. (I have this annoying grey/green box write lock on all my
    > folders
    > here.)
    >
    > I open to the security tab and changed the advanced security permissions
    > for
    > admins, myself, users and even for anybody (I know this is dangerous, but
    > I'm
    > simply desperate) to allow ubiquitious access to everything for all
    > folders,
    > subfolders and files (i.e. I did this for C:, C:\Programs and also tried
    > it
    > for some subfolders). Still I can not unset the d..n write lock (note this
    > is
    > in safe mode!)!! Even if I go into the command console, trying to unset
    > permissions with "attrib -R C:\somepath" or "attrib -R C:\sompath /s /d"
    > nothing changes at all. (I also made sure I am the owner of all the files
    > by
    > resetting me as owner for all files in all folders and subfolders)
    >
    > I am clueless now - what is wrong, how can I otherwise get into the real
    > Admin mode to change those annoying file access permissions?! Pleas help,
    > thank you!!
    >

    Having the folder set for Raed Only does not stop users from
    reading/writing/modifying files within the folder as long as they have
    appropriate NTFS permissions. Are you sure you have not added the Deny
    permission anywhere? Deny takes precedence over everything else. If you deny
    a group everyone in that group will be denied even if they are listed as
    allowed access as a user or another group.

    Kerry
  10. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    "Kerry Brown" wrote:

    > Having the folder set for Raed Only does not stop users from
    > reading/writing/modifying files within the folder as long as they have
    > appropriate NTFS permissions. Are you sure you have not added the Deny
    > permission anywhere? Deny takes precedence over everything else. If you deny
    > a group everyone in that group will be denied even if they are listed as
    > allowed access as a user or another group.
    >
    > Kerry

    Usually being paranoid I might have changed something to "deny" but I do not
    know where to set such a special "deny" permission as you are writing about?
    I still have the problem that I can not always write to the Programs
    folders... Thank you!

    br,florian
  11. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    "Florian Leitner" <FlorianLeitner@discussions.microsoft.com> wrote in
    message news:96D61C75-8E05-4839-9BEF-D9DEDBB49DC1@microsoft.com...
    > "Kerry Brown" wrote:
    >
    >> Having the folder set for Raed Only does not stop users from
    >> reading/writing/modifying files within the folder as long as they have
    >> appropriate NTFS permissions. Are you sure you have not added the Deny
    >> permission anywhere? Deny takes precedence over everything else. If you
    >> deny
    >> a group everyone in that group will be denied even if they are listed as
    >> allowed access as a user or another group.
    >>
    > Usually being paranoid I might have changed something to "deny" but I do
    > not
    > know where to set such a special "deny" permission as you are writing
    > about?
    > I still have the problem that I can not always write to the Programs
    > folders... Thank you!
    >

    The same place you set the NTFS permissions. There are two columns Allow and
    Deny.

    Kerry
Ask a new question

Read More

Security Windows XP Permissions