Sign in with
Sign up | Sign in
Your question

How to configure Windows Firewall?

Last response: in Windows XP
Share
Anonymous
August 20, 2005 7:37:01 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

when i go into control panel then firewall , the circle to turn firewall on
or off are in shadows and it wont let me do anything and i want to turn
firewall on . do i have to play witht the firewall settings first or is there
a problem?
August 21, 2005 1:33:23 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Start > run > services.msc and scroll down to Windows Firewall/Internet
Connection Sharing (ICS) and verify the Status is Started and the Startup
Type is Automatic.

If they are not then highlight the item, right-click, select Properties and
edit things appropriately.

"rob180sx" <rob180sx@discussions.microsoft.com> wrote in message
news:724D2EA3-0C0B-4D93-B9E8-30C3BAD93D48@microsoft.com...
> when i go into control panel then firewall , the circle to turn firewall
> on
> or off are in shadows and it wont let me do anything and i want to turn
> firewall on . do i have to play witht the firewall settings first or is
> there
> a problem?
Anonymous
August 21, 2005 5:11:03 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

ya everythings fine there, but i still cant select on or off for the firewall.

"Jerry" wrote:

> Start > run > services.msc and scroll down to Windows Firewall/Internet
> Connection Sharing (ICS) and verify the Status is Started and the Startup
> Type is Automatic.
>
> If they are not then highlight the item, right-click, select Properties and
> edit things appropriately.
>
> "rob180sx" <rob180sx@discussions.microsoft.com> wrote in message
> news:724D2EA3-0C0B-4D93-B9E8-30C3BAD93D48@microsoft.com...
> > when i go into control panel then firewall , the circle to turn firewall
> > on
> > or off are in shadows and it wont let me do anything and i want to turn
> > firewall on . do i have to play witht the firewall settings first or is
> > there
> > a problem?
>
>
>
Related resources
Anonymous
August 21, 2005 7:46:05 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

rob180sx wrote:

> ya everythings fine there, but i still cant select on or off
> for the firewall.
Hi,

One thing you can check:

Start regedit.exe (from Start/Run).

If you under the registry key
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\DomainProfile\
and/or
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\StandardProfile\
find a registry value named EnableFirewall that is set to 0, set it
to 1 and reboot.

If those registry keys/values does not exist, the system will default
to the same as EnableFirewall set to 1.


Another thing: If this computer is in a domain, also the network
administrator can have disabled the firewall with Group Policy (GPO).


--
torgeir, Microsoft MVP Scripting and WMI, Porsgrunn Norway
Administration scripting examples and an ONLINE version of
the 1328 page Scripting Guide:
http://www.microsoft.com/technet/scriptcenter/default.m...
Anonymous
August 21, 2005 7:46:06 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

ok both values were set as 0 so i turned them on now the firewall is on but i
still cant turn it off by clicking the circle but i now can click the "dont
allow exceptions" box which i could not before. but i think your right this
computer used to be on a network at one time and and maybe the firewall was
turned off and i dont have permission to access it.... how would i fix this?

"Torgeir Bakken (MVP)" wrote:

> rob180sx wrote:
>
> > ya everythings fine there, but i still cant select on or off
> > for the firewall.
> Hi,
>
> One thing you can check:
>
> Start regedit.exe (from Start/Run).
>
> If you under the registry key
> HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\DomainProfile\
> and/or
> HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\StandardProfile\
> find a registry value named EnableFirewall that is set to 0, set it
> to 1 and reboot.
>
> If those registry keys/values does not exist, the system will default
> to the same as EnableFirewall set to 1.
>
>
> Another thing: If this computer is in a domain, also the network
> administrator can have disabled the firewall with Group Policy (GPO).
>
>
> --
> torgeir, Microsoft MVP Scripting and WMI, Porsgrunn Norway
> Administration scripting examples and an ONLINE version of
> the 1328 page Scripting Guide:
> http://www.microsoft.com/technet/scriptcenter/default.m...
>
August 21, 2005 11:16:02 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

rob180sx,
make sure you are logged in as an administrator to change firewall settings.
If you log in as a restricted user, all options will be grayed out. Perhaps
that is the problem?

Lasse

"rob180sx" wrote:

> ya everythings fine there, but i still cant select on or off for the firewall.
>
> "Jerry" wrote:
>
> > Start > run > services.msc and scroll down to Windows Firewall/Internet
> > Connection Sharing (ICS) and verify the Status is Started and the Startup
> > Type is Automatic.
> >
> > If they are not then highlight the item, right-click, select Properties and
> > edit things appropriately.
> >
> > "rob180sx" <rob180sx@discussions.microsoft.com> wrote in message
> > news:724D2EA3-0C0B-4D93-B9E8-30C3BAD93D48@microsoft.com...
> > > when i go into control panel then firewall , the circle to turn firewall
> > > on
> > > or off are in shadows and it wont let me do anything and i want to turn
> > > firewall on . do i have to play witht the firewall settings first or is
> > > there
> > > a problem?
> >
> >
> >
Anonymous
August 21, 2005 11:51:19 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

"rob180sx" <rob180sx@discussions.microsoft.com> wrote in message
news:724D2EA3-0C0B-4D93-B9E8-30C3BAD93D48@microsoft.com...
> when i go into control panel then firewall , the circle to turn firewall
> on
> or off are in shadows and it wont let me do anything and i want to turn
> firewall on . do i have to play witht the firewall settings first or is
> there
> a problem?

Are you on a corporate network i.e. a domain. In a domain group policy will
override local firewall settings.

Kerry
Anonymous
August 22, 2005 12:08:01 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

when i turn the computer on the only choice to log on i have is me or guest
nothing else!! also this is my at home computer no network anymore but it
used to be networked with my dads before i moved out. but since then ive also
formatted and everyhting so that shouldnt matter anymore.

"Kerry Brown" wrote:

> "rob180sx" <rob180sx@discussions.microsoft.com> wrote in message
> news:724D2EA3-0C0B-4D93-B9E8-30C3BAD93D48@microsoft.com...
> > when i go into control panel then firewall , the circle to turn firewall
> > on
> > or off are in shadows and it wont let me do anything and i want to turn
> > firewall on . do i have to play witht the firewall settings first or is
> > there
> > a problem?
>
> Are you on a corporate network i.e. a domain. In a domain group policy will
> override local firewall settings.
>
> Kerry
>
>
>
Anonymous
August 22, 2005 12:13:02 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

also i checked about being on a domain and so i went to control panel ,
system , computername and it says im a part of a workgroup not a domain.

"Kerry Brown" wrote:

> "rob180sx" <rob180sx@discussions.microsoft.com> wrote in message
> news:724D2EA3-0C0B-4D93-B9E8-30C3BAD93D48@microsoft.com...
> > when i go into control panel then firewall , the circle to turn firewall
> > on
> > or off are in shadows and it wont let me do anything and i want to turn
> > firewall on . do i have to play witht the firewall settings first or is
> > there
> > a problem?
>
> Are you on a corporate network i.e. a domain. In a domain group policy will
> override local firewall settings.
>
> Kerry
>
>
>
Anonymous
August 22, 2005 12:18:12 AM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

SORRY FOR POSTING 3 TIMES
but i checked user accounts and it says i am the administrator. so i dont
understand this problem.
"rob180sx" wrote:

> also i checked about being on a domain and so i went to control panel ,
> system , computername and it says im a part of a workgroup not a domain.
>
> "Kerry Brown" wrote:
>
> > "rob180sx" <rob180sx@discussions.microsoft.com> wrote in message
> > news:724D2EA3-0C0B-4D93-B9E8-30C3BAD93D48@microsoft.com...
> > > when i go into control panel then firewall , the circle to turn firewall
> > > on
> > > or off are in shadows and it wont let me do anything and i want to turn
> > > firewall on . do i have to play witht the firewall settings first or is
> > > there
> > > a problem?
> >
> > Are you on a corporate network i.e. a domain. In a domain group policy will
> > override local firewall settings.
> >
> > Kerry
> >
> >
> >
!