How to set owner and permission for a folder/file on Windo..

Archived from groups: microsoft.public.windowsxp.security_admin,micorsoft.public.windowsxp.help_and_suport,micorsoft.public.windowsxp.general (More info?)

First, I still have problem to set a folder to be
private. It should be a VERY EAY task.
But when I right click the Property of a folder on D: drive
its "Make this private" check box is gray out.
So I can NOT make a folder be private in D: drive.

It seem to me the private folders are private
under "My Documents" in C: drive.

I read from Help, it says a drive MUST be NTFS

But I type

convert D: /fs:ntfs

It says my D drive already is NTFS format.
Since it already in NTFS, then why I can't
make it private?

Since I am system administrator at home for my
Windows XP. If I created new folders on D: drive
for my daughter and son.
I need to set the ownership, group and permission
for each user, make the folders be private.

How do I do these in step-by-step.
I am UNIX/LINUX system administrator.
It is a very easy task for me do
these in UNIX/LINUX, just type

mkdir folder_name # create a directory/folder
chown owner_name folder_name # set owner for a foler
chgrp group_name folder_name # set group for a folder
chmod u=rwx,g=rx,o=r folder_name # set permission
# owner read/write/execute;
# group read/execute;
# others read only

or

chmod u+rwx,g+rx-w,o+r-wx folder_name


How do I do all these in Windows XP Home edition?
Thank Q very much in advance!
4 answers Last reply
More about owner permission folder file windo
  1. Archived from groups: microsoft.public.windowsxp.security_admin,micorsoft.public.windowsxp.help_and_suport,micorsoft.public.windowsxp.general (More info?)

    RC wrote:

    > First, I still have problem to set a folder to be
    > private. It should be a VERY EAY task.
    > But when I right click the Property of a folder on D: drive
    > its "Make this private" check box is gray out.
    > So I can NOT make a folder be private in D: drive.
    >
    > It seem to me the private folders are private
    > under "My Documents" in C: drive.
    >
    > I read from Help, it says a drive MUST be NTFS
    >
    > But I type
    >
    > convert D: /fs:ntfs
    >
    > It says my D drive already is NTFS format.
    > Since it already in NTFS, then why I can't
    > make it private?
    >
    > Since I am system administrator at home for my
    > Windows XP. If I created new folders on D: drive
    > for my daughter and son.
    > I need to set the ownership, group and permission
    > for each user, make the folders be private.
    (snip Unix commands)
    >
    > How do I do all these in Windows XP Home edition?

    Unlike XP Pro and *nix, XP Home does not have the ability to set
    advanced permissions like that. By default in XP Home, you can only
    make files and folders under My Documents "private". Passwording of
    folders is not supported unless you zip them. When you do
    (right click a folder, then "send to > compressed folder") and then open
    the zip file, you will find an option under file>"add a password".
    Otherwise, use third-party software. Google "password protect folders".

    So you could create a folder under the root of D: and either zip it or
    password protect it with a third-party program. Or you could upgrade to
    XP Pro and then you will have the ability to set fine-grained
    permissions, create user groups, etc.

    Malke
    --
    Elephant Boy Computers
    www.elephantboycomputers.com
    "Don't Panic!"
    MS-MVP Windows - Shell/User
  2. Archived from groups: microsoft.public.windowsxp.security_admin,microsoft.public.windowsxp.help_and_support,micorsoft.public.windowsxp.general (More info?)

    Malke wrote:

    > you could upgrade to
    > XP Pro and then you will have the ability to set fine-grained
    > permissions, create user groups, etc.

    OK, finally I upgrade to XP Professional.

    Then I created a folder under D: drive.
    When look at that folder, it auto created to
    serveral groups, administrator, me, owner, creater
    and user. (I am an administrator).

    I selected the user group, I am not belong to user group
    nor administrator, I made that folder full deny to the
    user group. But XP deny for everybody, include myself!

    Why?!

    Also I found out, I can NOT remove the user group from a
    folder, I must remove user group from D: drive root.
    So in this case, nobody can create a folder/file under
    D: drive except administrator and me, right?
  3. Archived from groups: microsoft.public.windowsxp.security_admin,microsoft.public.windowsxp.help_and_support,micorsoft.public.windowsxp.general (More info?)

    RC wrote:

    > Malke wrote:
    >
    >> you could upgrade to
    >> XP Pro and then you will have the ability to set fine-grained
    >> permissions, create user groups, etc.
    >
    > OK, finally I upgrade to XP Professional.
    >
    > Then I created a folder under D: drive.
    > When look at that folder, it auto created to
    > serveral groups, administrator, me, owner, creater
    > and user. (I am an administrator).
    >
    > I selected the user group, I am not belong to user group
    > nor administrator, I made that folder full deny to the
    > user group. But XP deny for everybody, include myself!
    >
    > Why?!
    >
    > Also I found out, I can NOT remove the user group from a
    > folder, I must remove user group from D: drive root.
    > So in this case, nobody can create a folder/file under
    > D: drive except administrator and me, right?

    <sigh> You really should have taken the time to do some reading about
    permissions before you plunged right in. Start with XP's Help & Support
    about "users" and "groups". *Everyone* is a member of the Users group.
    You've effectively denied permission to *everyone*. Of course you
    cannot remove built-in system groups like Users!

    You need to create a new *group* and set permissions for that *group*.

    Malke
    --
    Elephant Boy Computers
    www.elephantboycomputers.com
    "Don't Panic!"
    MS-MVP Windows - Shell/User
  4. Archived from groups: microsoft.public.windowsxp.security_admin,microsoft.public.windowsxp.help_and_support (More info?)

    RC wrote:
    > Malke wrote:
    >
    >> you could upgrade to
    >> XP Pro and then you will have the ability to set fine-grained
    >> permissions, create user groups, etc.
    >
    >
    > OK, finally I upgrade to XP Professional.
    >
    > Then I created a folder under D: drive.
    > When look at that folder, it auto created to
    > serveral groups, administrator, me, owner, creater
    > and user. (I am an administrator).
    >
    > I selected the user group, I am not belong to user group
    > nor administrator, I made that folder full deny to the
    > user group. But XP deny for everybody, include myself!
    >
    > Why?!
    >
    Because deny takes precedence over any other permission. YOu
    get all the permissions for all the groups that you belong
    to added by *one* deny is enough to deny permissions
    whatever else you may have. You are a user AND an
    administrator. Deny the user group and you deny yourself.

    Cheers,

    Cliff

    --

    Barzoomian the Martian - http://barzoomian.blogspot.com
Ask a new question

Read More

Windows XP