cannot enable windows firewall in XP SP2

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

I am the administrator and was using Windows XP SP1 and my ICF was enabled.
At the same time I was running MS Antispyware Beta and Spyware Doctor. I
then upgraded to SP2. After I installed this, Security Center was showing my
windows firewall in yellow - meaning I will monitor my own firewall. This
was the default setting, even though I've read the default should be 'On'.

I then went to recommendations and unchecked 'I have a firewall solution
that I will monitor myself' and clicked 'enable now' and got the message
'We're sorry. The Security Center could not turn on Windows Firewall. To try
turning on the firewall yourself, go to Windows Firewall in the Control
Panel. In the Windows Firewall dialog General tab, select On (recommended),
and then click Ok'. I tried to do this but the selections are dimmed out and
therefore I cannot select 'On'.

I then tried right clicking on My Computer on my desktop>Manage>Services and
Applications>Services and noted Windows firewall was 'started' and set to
'automatic'. I restarted it but that didn't work.

Next I tried Start/Run --> cmd.exe followed by netsh.exe winsock reset and
hit Enter, rebooted, and that failed to work as well. After this I tried the
following commands: Start/Run -->
regsvr32 %windir%\system32\atl.dll then
regsvr32 %windir%\system32\hnetcfg.dll
regsvr32 %windir%\system32\netshell.dll
regsvr32 %windir%\system32\netcfgx.dll
regsvr32 %windir%\system32\netman.dll
Reboot.

This did not work either.

Does anybody know what the problem is and how I can successfully enable my
windows firewall? I am not running Norton or any security programs other
than the ones mentioned above. Any help would be greatly appreciated.
4 answers Last reply
More about cannot enable windows firewall
  1. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    I am having the same problems on my home PC (no network). After install of
    SP2, cannot enable (turn on) Windows firewall. Have read thru all discussion
    group posts and have tried the following, all with no success:

    Start>Run cmd [enter]
    netsh winsock reset [enter]
    Follow prompts and reboot.

    If that didn't work (it didn't), see if registering the following DLLs helps:

    From Start/Run, run the following commands:
    regsvr32 %windir%\system32\atl.dll
    then
    regsvr32 %windir%\system32\hnetcfg.dll
    regsvr32 %windir%\system32\netshell.dll
    regsvr32 %windir%\system32\netcfgx.dll
    regsvr32 %windir%\system32\netman.dll
    Then do a reboot.

    Check to see if the Internet Connection Firewall is not disabled:
    In the desktop, right click on the My Computer icon\Manage\Services and
    Applications\Services\on Internet Connection Firewall (ICF) Status column
    should read Started and Start type shoud read Automatic if any or both are
    set different, double click on ICF Service and click on the Start button
    and/or set to Autostart in the rolldown.

    I am like Steve - any help or suggestions would be greatly appreciated as I
    am about ready to go back to SP1.




    "steve" wrote:

    > I am the administrator and was using Windows XP SP1 and my ICF was enabled.
    > At the same time I was running MS Antispyware Beta and Spyware Doctor. I
    > then upgraded to SP2. After I installed this, Security Center was showing my
    > windows firewall in yellow - meaning I will monitor my own firewall. This
    > was the default setting, even though I've read the default should be 'On'.
    >
    > I then went to recommendations and unchecked 'I have a firewall solution
    > that I will monitor myself' and clicked 'enable now' and got the message
    > 'We're sorry. The Security Center could not turn on Windows Firewall. To try
    > turning on the firewall yourself, go to Windows Firewall in the Control
    > Panel. In the Windows Firewall dialog General tab, select On (recommended),
    > and then click Ok'. I tried to do this but the selections are dimmed out and
    > therefore I cannot select 'On'.
    >
    > I then tried right clicking on My Computer on my desktop>Manage>Services and
    > Applications>Services and noted Windows firewall was 'started' and set to
    > 'automatic'. I restarted it but that didn't work.
    >
    > Next I tried Start/Run --> cmd.exe followed by netsh.exe winsock reset and
    > hit Enter, rebooted, and that failed to work as well. After this I tried the
    > following commands: Start/Run -->
    > regsvr32 %windir%\system32\atl.dll then
    > regsvr32 %windir%\system32\hnetcfg.dll
    > regsvr32 %windir%\system32\netshell.dll
    > regsvr32 %windir%\system32\netcfgx.dll
    > regsvr32 %windir%\system32\netman.dll
    > Reboot.
    >
    > This did not work either.
    >
    > Does anybody know what the problem is and how I can successfully enable my
    > windows firewall? I am not running Norton or any security programs other
    > than the ones mentioned above. Any help would be greatly appreciated.
    >
  2. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    steve wrote:

    > I am the administrator and was using Windows XP SP1 and my ICF was
    > enabled.
    > At the same time I was running MS Antispyware Beta and Spyware Doctor.
    > I
    > then upgraded to SP2. After I installed this, Security Center was
    > showing my
    > windows firewall in yellow - meaning I will monitor my own firewall.
    > This was the default setting, even though I've read the default should
    > be 'On'.
    >
    (snip)

    Known issue with MS Antispyware Beta - "Beta" software means it isn't
    finished and can cause problems. Don't run beta software on production
    machines.

    MS antispyware tool disables Windows Firewall (or to reset firewall):
    Start>Run cmd [enter]
    netsh winsock reset catalog [enter]
    Follow prompts and reboot.

    FIREWALL DEAD, or other network issues:
    http://support.microsoft.com/kb/892350

    "Due to an unidentified problem, Windows cannot display Windows Firewall
    settings" error, try:
    Start>Run regsvr32 hnetcfg.dll [enter]

    Malke
    --
    Elephant Boy Computers
    www.elephantboycomputers.com
    "Don't Panic!"
    MS-MVP Windows - Shell/User
  3. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    Kinda-sorta in the same vein, Security Center does not recognize MSAS so I
    always get "your system might be at risk" shield. Any ideas? Tnx

    "Malke" wrote:

    > steve wrote:
    >
    > > I am the administrator and was using Windows XP SP1 and my ICF was
    > > enabled.
    > > At the same time I was running MS Antispyware Beta and Spyware Doctor.
    > > I
    > > then upgraded to SP2. After I installed this, Security Center was
    > > showing my
    > > windows firewall in yellow - meaning I will monitor my own firewall.
    > > This was the default setting, even though I've read the default should
    > > be 'On'.
    > >
    > (snip)
    >
    > Known issue with MS Antispyware Beta - "Beta" software means it isn't
    > finished and can cause problems. Don't run beta software on production
    > machines.
    >
    > MS antispyware tool disables Windows Firewall (or to reset firewall):
    > Start>Run cmd [enter]
    > netsh winsock reset catalog [enter]
    > Follow prompts and reboot.
    >
    > FIREWALL DEAD, or other network issues:
    > http://support.microsoft.com/kb/892350
    >
    > "Due to an unidentified problem, Windows cannot display Windows Firewall
    > settings" error, try:
    > Start>Run regsvr32 hnetcfg.dll [enter]
    >
    > Malke
    > --
    > Elephant Boy Computers
    > www.elephantboycomputers.com
    > "Don't Panic!"
    > MS-MVP Windows - Shell/User
    >
  4. Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

    paddy wrote:

    > Kinda-sorta in the same vein, Security Center does not recognize MSAS
    > so I always get "your system might be at risk" shield. Any ideas? Tnx
    >
    For help with the Best MSAS program, post in one of the newsgroups
    specifically set up for it:

    At this time, support for the beta version of Microsoft Windows
    AntiSpyware is being provided through the following Microsoft
    newsgroups:

    - microsoft.private.security.spyware.announcements
    - microsoft.private.security.spyware.appcompat
    - microsoft.private.security.spyware.general
    - microsoft.private.security.spyware.install
    - microsoft.private.security.spyware.networking
    - microsoft.private.security.spyware.signatures
    - microsoft.private.security.spyware.onlinecommunity

    These newsgroups can be accessed via NNTP or HTTP. To access these
    newsgroups using HTTP, please go to the following location:

    http://communities.microsoft.com/newsgroups/default.asp?ICP=spyware&sLCID=us

    To access these newsgroups using NNTP, please use the following
    information for your NNTP client (such as Microsoft Outlook Express):

    - NNTP Server: privatenews.microsoft.com
    - Account name: privatenews\spyware
    - Password: spyware

    NOTE: No password will be required via the HTTP link.

    Malke
    --
    Elephant Boy Computers
    www.elephantboycomputers.com
    "Don't Panic!"
    MS-MVP Windows - Shell/User
Ask a new question

Read More

Firewalls Security Windows XP