Sign in with
Sign up | Sign in
Your question

CANNOT ENABLE SP2 FIREWALL

Last response: in Windows XP
Share
Anonymous
September 8, 2005 3:25:04 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Dell Dimension 8200, XP SP2, Norton Antivirus 2002 (up to date).

PROBLEM: The windows xp firewall isn't active. When I go to the security
setting to turn it on, I click on the icon and get the following:
Windows firewall settings cannot be displayed because the associated service
is not running. Do you want to start the window's firewall/internet
connection service? I click yes then get:
Windows cannot start the windows/Internet Connection Service.

HAVE READ USER GROUP COMMENTS AND HAVE ATTEMPTED THE FOLLOWING, ALL WITH NO
SUCCESS:

Start>Run cmd [enter]
netsh winsock reset [enter]
Follow prompts and reboot.

Start/Run --> cmd.exe
and then, in the command prompt that opened up, type:
netsh.exe winsock reset
and hit Enter. Follow prompts and reboot.

If that didn't work, see if registering the following DLLs helps:
From Start/Run, run the following commands:
regsvr32 %windir%\system32\atl.dll
then
regsvr32 %windir%\system32\hnetcfg.dll
regsvr32 %windir%\system32\netshell.dll
regsvr32 %windir%\system32\netcfgx.dll
regsvr32 %windir%\system32\netman.dll
Then do a reboot.

Check to see if the Internet Connection Firewall is not disabled:
In the desktop, right click on the My Computer icon\Manage\Services and
Applications\Services\on Internet Connection Firewall (ICF) Status column
should read Started and Start type shoud read Automatic if any or both are
set different, double click on ICF Service and click on the Start button
and/or set to Autostart in the rolldown window.

I HAVE WORKED ON THIS FOR THREE DAYS, AND AM ABOUT READY TO GO BACK TO
SERVICE PACK 1. ANY HELP WOULD BE GREATLY APPRECITATED.

More about : enable sp2 firewall

September 8, 2005 9:02:02 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

"carly" wrote:

> Dell Dimension 8200, XP SP2, Norton Antivirus 2002 (up to date).
>
> PROBLEM: The windows xp firewall isn't active. When I go to the security
> setting to turn it on, I click on the icon and get the following:
> Windows firewall settings cannot be displayed because the associated service
> is not running. Do you want to start the window's firewall/internet
> connection service? I click yes then get:
> Windows cannot start the windows/Internet Connection Service.
>
> HAVE READ USER GROUP COMMENTS AND HAVE ATTEMPTED THE FOLLOWING, ALL WITH NO
> SUCCESS:
>
> Start>Run cmd [enter]
> netsh winsock reset [enter]
> Follow prompts and reboot.
>
> Start/Run --> cmd.exe
> and then, in the command prompt that opened up, type:
> netsh.exe winsock reset
> and hit Enter. Follow prompts and reboot.
>
> If that didn't work, see if registering the following DLLs helps:
> From Start/Run, run the following commands:
> regsvr32 %windir%\system32\atl.dll
> then
> regsvr32 %windir%\system32\hnetcfg.dll
> regsvr32 %windir%\system32\netshell.dll
> regsvr32 %windir%\system32\netcfgx.dll
> regsvr32 %windir%\system32\netman.dll
> Then do a reboot.
>
> Check to see if the Internet Connection Firewall is not disabled:
> In the desktop, right click on the My Computer icon\Manage\Services and
> Applications\Services\on Internet Connection Firewall (ICF) Status column
> should read Started and Start type shoud read Automatic if any or both are
> set different, double click on ICF Service and click on the Start button
> and/or set to Autostart in the rolldown window.
>
> I HAVE WORKED ON THIS FOR THREE DAYS, AND AM ABOUT READY TO GO BACK TO
> SERVICE PACK 1. ANY HELP WOULD BE GREATLY APPRECITATED.
>
>
> Carly, I got the following from a post. I can't find this post anymore but I had copied it. It worked for me, and although your problem seems slightly different it's worth a shot:

"One thing you can check:
Start regedit.exe (from Start/Run).
If you under the registry key
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\DomainProfile\
and/or
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\StandardProfile\
find a registry value named EnableFirewall that is set to 0, set it to 1 and
reboot. If those registry keys/values does not exist, the system will default
to the same as EnableFirewall set to 1.
Another thing: If this computer is in a domain, also the network
administrator can have disabled the firewall with Group Policy (GPO).
-- torgeir, Microsoft MVP Scripting and WMI, Porsgrunn Norway Administration
scripting examples and an ONLINE version of the 1328 page Scripting Guide:
http://www.microsoft.com/technet/scriptcenter/default.m..."

When I do this the firewall becomes set to 'On', but the selections are
still dimmed out.

Anyways, hope this helps

Steve


>
Anonymous
September 8, 2005 10:25:02 PM

Archived from groups: microsoft.public.windowsxp.security_admin (More info?)

Steve:

Thanks for the suggestion, unfortunatley it did not work. Could not find
either
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\DomainProfile\
and/or
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\StandardProfile\
However, the system does not default to EnableFirewall set to 1 (If those
registry keys/values does not exist, the system will default
to the same as EnableFirewall set to 1).

This is a stand alone PC - no network, with telephone dial-up using
Earthlink as the ISP.

Carly
Another thing: If this computer is in a domain, also the network
administrator can have disabled the firewall with Group Policy (GPO).

"steve" wrote:

>
>
> "carly" wrote:
>
> > Dell Dimension 8200, XP SP2, Norton Antivirus 2002 (up to date).
> >
> > PROBLEM: The windows xp firewall isn't active. When I go to the security
> > setting to turn it on, I click on the icon and get the following:
> > Windows firewall settings cannot be displayed because the associated service
> > is not running. Do you want to start the window's firewall/internet
> > connection service? I click yes then get:
> > Windows cannot start the windows/Internet Connection Service.
> >
> > HAVE READ USER GROUP COMMENTS AND HAVE ATTEMPTED THE FOLLOWING, ALL WITH NO
> > SUCCESS:
> >
> > Start>Run cmd [enter]
> > netsh winsock reset [enter]
> > Follow prompts and reboot.
> >
> > Start/Run --> cmd.exe
> > and then, in the command prompt that opened up, type:
> > netsh.exe winsock reset
> > and hit Enter. Follow prompts and reboot.
> >
> > If that didn't work, see if registering the following DLLs helps:
> > From Start/Run, run the following commands:
> > regsvr32 %windir%\system32\atl.dll
> > then
> > regsvr32 %windir%\system32\hnetcfg.dll
> > regsvr32 %windir%\system32\netshell.dll
> > regsvr32 %windir%\system32\netcfgx.dll
> > regsvr32 %windir%\system32\netman.dll
> > Then do a reboot.
> >
> > Check to see if the Internet Connection Firewall is not disabled:
> > In the desktop, right click on the My Computer icon\Manage\Services and
> > Applications\Services\on Internet Connection Firewall (ICF) Status column
> > should read Started and Start type shoud read Automatic if any or both are
> > set different, double click on ICF Service and click on the Start button
> > and/or set to Autostart in the rolldown window.
> >
> > I HAVE WORKED ON THIS FOR THREE DAYS, AND AM ABOUT READY TO GO BACK TO
> > SERVICE PACK 1. ANY HELP WOULD BE GREATLY APPRECITATED.
> >
> >
> > Carly, I got the following from a post. I can't find this post anymore but I had copied it. It worked for me, and although your problem seems slightly different it's worth a shot:
>
> "One thing you can check:
> Start regedit.exe (from Start/Run).
> If you under the registry key
> HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\DomainProfile\
> and/or
> HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\StandardProfile\
> find a registry value named EnableFirewall that is set to 0, set it to 1 and
> reboot. If those registry keys/values does not exist, the system will default
> to the same as EnableFirewall set to 1.
> Another thing: If this computer is in a domain, also the network
> administrator can have disabled the firewall with Group Policy (GPO).
> -- torgeir, Microsoft MVP Scripting and WMI, Porsgrunn Norway Administration
> scripting examples and an ONLINE version of the 1328 page Scripting Guide:
> http://www.microsoft.com/technet/scriptcenter/default.m..."
>
> When I do this the firewall becomes set to 'On', but the selections are
> still dimmed out.
>
> Anyways, hope this helps
>
> Steve
>
>
> >
!