Windows 7

Laptop running windows 7, cannot print to a printer directly connected via a USB cable to a US robotics USR4361 Router. Yes I can connect to the internet via the router. However I can print to the printer if I directly connect it to my HP laptop. I have two other wireless Laptops running Vista home prem that can print to the printer.
8 answers Last reply
More about windows
  1. More details plz
  2. Not sure what other details you require.
  3. Your question is a little confusing. Is it a wireless printer? If you could elaborate a bit it would help. Take a look at these 2 links for some more information that may be helpful!

    http://windows.microsoft.com/en-us/windows7/Install-a-printer

    http://www.tomshardware.com/forum/13899-63-wireless-printer-offline-windows#t67249

    I hope this helps!

    Brett M,
    Windows Outreach Team
  4. So let me explain this to the best of my ability.
    I have a US Robotics router usr4361 that is directly hard wired to a HP MP830 printer using a USB cable.
    I have a HP wireless laptop running Windows 7 that using the Router I can connect to the internet.
    I am trying to connect the HP wireless laptop to the printer going through the router.
    If I remove the USB cable from the router and connect it to the HP Laptop I can print.......I did this for testing purposes only. This is not what I want to do because I have two other wireless Laptops running off the router and using the printer. I would like to have all three laptops working the same way. The other two Laptops have Windows Vista Prem running on them.
  5. Ok, so you mean on a network ?
    I has to be configured in network/devices.. Try to check your settings.
  6. question:
    is everybody on the network using win7.?
  7. Thanks all I got it. When I was installing the printer port it kept defaulting to the TCP/IP port. I needed use an internet port. I deleted the TCP/IP port, this allow me to configure an internet port. It was not easy to delete the TCP/IP port. You had to go into start type in regedit / current control set / control / print / monitors / and delete the port in the Standard TCP/IP
  8. ^
    there's an easier way to do that but I'm glad it worked for you...
Ask a new question

Read More

Configuration Laptops Windows 7 Printers