PIO Mode in Windows 2000

Archived from groups: comp.sys.ibm.pc.hardware.storage (More info?)

Hi folks:

I've exhausted my ideas and need some help. Here's the story:

I had a 40gb Maxtor drive in my Win2000 (SP4) computer running in UDMA Mode
5. I bought a 160gb Seagate, cloned the drive using Norton Ghost 2003, and
now the cloned drive is slow. The new drive has a total of four primary
partitions. I checked the device manager and Windows reports that the drive
is set to PIO mode. My BIOS recognizes the drive as UDMA5 and the Seatools
software from Seagate reports that the drive default is set to UDMA5. I am
led to believe that Windows is setting the mode to PIO on startup.

I have researched this and have found several references to the mode being
misrepresented in Windows and the fix was to install SP2....well, I'm
running SP4 so I doubt that is the problem.

I would appreciate it if anyone could help or point me in the right
direction.

Cheers.


--
FRP
frpyatt-@-yahoo.ca
2 answers Last reply
More about mode windows 2000
  1. Archived from groups: comp.sys.ibm.pc.hardware.storage (More info?)

    [This followup was posted to comp.sys.ibm.pc.hardware.storage and a copy
    was sent to the cited author.]

    In article <0Et2d.13641$lb5.1127411@news20.bellglobal.com>,
    frpyatt@yahoo.ca says...
    > I had a 40gb Maxtor drive in my Win2000 (SP4) computer running in UDMA Mode
    > 5. I bought a 160gb Seagate, cloned the drive using Norton Ghost 2003, and
    > now the cloned drive is slow. The new drive has a total of four primary
    > partitions. I checked the device manager and Windows reports that the drive
    > is set to PIO mode. My BIOS recognizes the drive as UDMA5 and the Seatools
    > software from Seagate reports that the drive default is set to UDMA5. I am
    > led to believe that Windows is setting the mode to PIO on startup.
    >
    > I have researched this and have found several references to the mode being
    > misrepresented in Windows and the fix was to install SP2....well, I'm
    > running SP4 so I doubt that is the problem.
    >
    > I would appreciate it if anyone could help or point me in the right
    > direction.

    There are several ways to try and fix it:

    1) I assume you have gone into Device Manager, and for each of the IDE
    channels, go into one of the tabs, and checked the drop-down to make
    certain it is set to use DMA If possible?

    2) Try deleting the IDE controller in Device Manager, then rebooting. It
    will redetect it and reset everything. (This worked on a laptop that had
    a similar problem.)

    3) If you are running a recent Intel chipset, try the Intel Application
    Accellerator. For other chipsets, check the websites for any special
    drivers.

    --
    If there is a no_junk in my address, please REMOVE it before replying!
    All junk mail senders will be prosecuted to the fullest extent of the
    law!!
    http://home.att.net/~andyross
  2. Archived from groups: comp.sys.ibm.pc.hardware.storage (More info?)

    "Andrew Rossmann" <andysnewsreply@no_junk.comcast.net> wrote in message
    news:MPG.1bb49bbdbfa7f806989690@news.comcast.giganews.com...
    > [This followup was posted to comp.sys.ibm.pc.hardware.storage and a copy
    > was sent to the cited author.]
    >
    > In article <0Et2d.13641$lb5.1127411@news20.bellglobal.com>,
    > frpyatt@yahoo.ca says...
    > > I had a 40gb Maxtor drive in my Win2000 (SP4) computer running in UDMA
    Mode
    > > 5. I bought a 160gb Seagate, cloned the drive using Norton Ghost 2003,
    and
    > > now the cloned drive is slow. The new drive has a total of four primary
    > > partitions. I checked the device manager and Windows reports that the
    drive
    > > is set to PIO mode. My BIOS recognizes the drive as UDMA5 and the
    Seatools
    > > software from Seagate reports that the drive default is set to UDMA5. I
    am
    > > led to believe that Windows is setting the mode to PIO on startup.
    > >
    > > I have researched this and have found several references to the mode
    being
    > > misrepresented in Windows and the fix was to install SP2....well, I'm
    > > running SP4 so I doubt that is the problem.
    > >
    > > I would appreciate it if anyone could help or point me in the right
    > > direction.
    >
    > There are several ways to try and fix it:
    >
    > 1) I assume you have gone into Device Manager, and for each of the IDE
    > channels, go into one of the tabs, and checked the drop-down to make
    > certain it is set to use DMA If possible?
    >
    > 2) Try deleting the IDE controller in Device Manager, then rebooting. It
    > will redetect it and reset everything. (This worked on a laptop that had
    > a similar problem.)
    >
    > 3) If you are running a recent Intel chipset, try the Intel Application
    > Accellerator. For other chipsets, check the websites for any special
    > drivers.
    >

    Hi, and thanks for the response. I have done all of the above items. I
    have come across a hotfix on the microsoft site that uses a newer version of
    atapi.sys, combined with a required registry entry. I will try that as a
    last resort....
Ask a new question

Read More

Windows 2000 Storage