Sign in with
Sign up | Sign in
Your question

Formatted C: Drive not visible in My Computer but accessible

Last response: in Storage
Share
Anonymous
a b G Storage
December 19, 2004 4:52:44 PM

Archived from groups: comp.sys.ibm.pc.hardware.storage (More info?)

I have a very peculiar problem on a PC I just built, running
Windows 98 SE.

I have formatted my SATA drive into three Primary partitions, the
first two of which are FAT32 (I will be putting Linux on the third
partition). I set it up with Parition Magic 7.0. It's like this:

1 C: Primary Active
2 Primary
D: Logical
3 Primary (Unallocated)

When I boot up Windows, and open My Computer, it only shows D:
(and A: and other normal stuff), not C:. But, I can type C:
into the "Address" bar, and then I can access it fine. If I
go into the Device Manager, and open up Disk Drives, I see my
drive, and if I select Properties/Settings it shows "Current
Drive Letter Assigment: 'C:,D:'.

So everything seems fine, except that C: doesn't show up in
My Computer... It shows up in the Scandisk menu just fine
and scans with no errors.

I've carefully checked and it's not just that the icon has
another icon on top - I've set auto layout, detail view, etc
and it's just not there. The My Computer folder has "View
Hidden Files" set so I haven't somehow hidden it. I'm
mystified. I've also run Norton Windoctor and it didn't come
up with anything.

Any insight would be most appreciated!

-Bob
Anonymous
a b G Storage
December 20, 2004 3:16:46 AM

Archived from groups: comp.sys.ibm.pc.hardware.storage (More info?)

bobdbitbucket@netscape.net wrote:

>I have a very peculiar problem on a PC I just built, running
>Windows 98 SE.

[snip]

>So everything seems fine, except that C: doesn't show up in
>My Computer... It shows up in the Scandisk menu just fine
>and scans with no errors.

Go to Control Panel, and use the Tweak UI applet there. On its My
Computer tab, make sure the box for the C: drive is checked.

If you don't have Tweak UI, you can get it from Microsoft, but I
suspect you already have it.
Related resources
!