Sign in with
Sign up | Sign in
Your question

Silicon Image SATARaid SI-3512 Problems - Drive or Motherb..

Last response: in Storage
Share
February 16, 2005 7:35:15 AM

Archived from groups: comp.sys.ibm.pc.hardware.storage (More info?)

Hello,

I would be very grateful if anyone could help me diagnose my disk
problem. I have a Gigabyte GA-K8NS Pro motherboard with a Silicon
Image SATARaid SI-3512 chip on board running two WD Server Edition
SATA hard drives.

Just recently one of the drives has started to click, very briefly
slow and spin up on the odd occasion. I am having difficulty in
working out whether it is because of the RAID chip or a dodgy drive,
and if the latter, which of my 2 drives to replace (they are 1 month
old). I suspect it is the Channel 1 device that needs replacing, but
I am not too sure, as in the error log there is also the line:

Error ocurred on Channel 0 Device device on adapter 0. Channel 0
Device - CDB 28 00 00 01 7b 00 00 00 80 00

Should I ditch the Silicon Image Raid and use the Nvidia GIGARaid also
on board? We did have a power cut recently, but the machine is
plugged into a power-cleaning UPS, so can only think that it is a
faulty disk. Below are details of the configuration and error logs.

WTIA

bjorn10

***

Config details:

SATARaid Configuration Information. 16-February-2005 11:59.02
SATARaid Version 1, 0, 0, 19


Computer Information -
Name NAME
Microsoft Windows 2000 5.0
Service Pack 4

Adapter 0 Information -
Chip Model SI-3512
Chip Revision 0001
Chip Type RAID
Driver Status 1
Major Version 2
Minor Version 2
File Version 1, 0, 0, 51
File Date Fri Aug 27 16:18:50 2004
PCI IRQ 17
PCI Bus Number 2
PCI Device Number 13

Primary Channel Information -
IDE Base Address UNKNOWN
Alt Base Address UNKNOWN
DMA Base Address UNKNOWN

Master Device Information -
Master Not Present!!!

Secondary Channel Information -
IDE Base Address UNKNOWN
Alt Base Address UNKNOWN
DMA Base Address UNKNOWN

Master Device Information -
Master Not Present!!!

RIO information -
Major revision 2
Minor revision 0
Array conflicts No
Number of sets 0

***

Error Log:

14-February-2005 09:34.07 SATARaid Event Logger Started
14-February-2005 09:34.07 SATARaid Event writer starting up.
14-February-2005 14:22.20 Error - Device remove
The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
14-February-2005 14:22.20 Warning - Member dropped
Set 0 dropped Channel 1 Device device on adapter 0 due to a port
error. SRB status was Device Selection Timed Out.
14-February-2005 14:22.21 Error - Device remove
The Channel 0 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
14-February-2005 14:22.28 Informational - New device
The Channel 0 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
device.
15-February-2005 11:29.32 SATARaid Event Logger Started
15-February-2005 11:29.32 SATARaid Event writer starting up.
15-February-2005 09:09.55 Informational - Rebuild started
Set 0 started a rebuild for Channel 1 Device device on adapter 0.
15-February-2005 09:15.02 Error - Device remove
The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
15-February-2005 09:15.02 Warning - Member dropped
Set 0 dropped Channel 1 Device device on adapter 0 due to a port
error. SRB status was Device Selection Timed Out.
15-February-2005 09:15.08 Informational - New device
The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
device.
15-February-2005 09:15.08 Informational - Rebuild started
Set 0 started a rebuild for Channel 1 Device device on adapter 0.
15-February-2005 11:29.02 Error - Device remove
The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
15-February-2005 11:29.02 Warning - Member dropped
Set 0 dropped Channel 1 Device device on adapter 0 due to a port
error. SRB status was Device Selection Timed Out.
15-February-2005 11:29.14 Informational - New device
The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
device.
15-February-2005 11:29.14 Informational - Rebuild started
Set 0 started a rebuild for Channel 1 Device device on adapter 0.
15-February-2005 11:30.50 Error - Device remove
The Channel 0 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
15-February-2005 11:30.50 Warning - Port Error - Device
Selection Timed Out
Error ocurred on Channel 0 Device device on adapter 0. Channel 0
Device - CDB 28 00 00 01 7b 00 00 00 80 00
15-February-2005 11:30.50 Warning - Member dropped
Set 0 dropped Channel 1 Device device on adapter 0 due to a port
error. SRB status was Success.
15-February-2005 11:30.50 Error - Device remove
The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
15-February-2005 11:30.54 Informational - New device
The Channel 0 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
device.
15-February-2005 11:30.55 Informational - New device
The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
device.
15-February-2005 11:30.55 Informational - Rebuild started
Set 0 started a rebuild for Channel 1 Device device on adapter 0.
15-February-2005 16:01.30 SATARaid Event Logger Started
15-February-2005 16:01.30 SATARaid Event writer starting up.
15-February-2005 16:07.01 SATARaid Event Logger Started
15-February-2005 16:07.01 SATARaid Event writer starting up.
15-February-2005 16:16.32 SATARaid Event Logger Started
15-February-2005 16:16.32 SATARaid Event writer starting up.
15-February-2005 17:54.42 SATARaid Event Logger Started
15-February-2005 17:54.42 SATARaid Event writer starting up.
16-February-2005 11:36.28 SATARaid Event Logger Started
16-February-2005 11:36.28 SATARaid Event writer starting up.
Anonymous
a b G Storage
February 16, 2005 1:04:36 PM

Archived from groups: comp.sys.ibm.pc.hardware.storage (More info?)

Dan wrote:

> Hello,
>
> I would be very grateful if anyone could help me diagnose my disk
> problem. I have a Gigabyte GA-K8NS Pro motherboard with a Silicon
> Image SATARaid SI-3512 chip on board running two WD Server Edition
> SATA hard drives.
>
> Just recently one of the drives has started to click, very briefly
> slow and spin up on the odd occasion. I am having difficulty in
> working out whether it is because of the RAID chip or a dodgy drive,
> and if the latter, which of my 2 drives to replace (they are 1 month
> old). I suspect it is the Channel 1 device that needs replacing, but
> I am not too sure, as in the error log there is also the line:
>
> Error ocurred on Channel 0 Device device on adapter 0. Channel 0
> Device - CDB 28 00 00 01 7b 00 00 00 80 00
>
> Should I ditch the Silicon Image Raid and use the Nvidia GIGARaid also
> on board? We did have a power cut recently, but the machine is
> plugged into a power-cleaning UPS, so can only think that it is a
> faulty disk. Below are details of the configuration and error logs.

Faulty disk is the most likely problem, but it could be a loose power cable,
defective power supply (unlikely if it's only affecting one disk but it
could be), some dust making an intermittent short, etc.

Blow the machine out and tighten the cables and check the power with a meter
(if you can, try to catch it _while_ the disk is misbehaving--I've seen
power supplies periodically drop the voltage for a few seconds then go back
to normal) and see if the problem goes away, if not then replace the disk.
If you want to be double-sure, back up the raid, swap the disks, rebuild
the array, and see if the problem moves with the disk.

> WTIA
>
> bjorn10
>
> ***
>
> Config details:
>
> SATARaid Configuration Information. 16-February-2005 11:59.02
> SATARaid Version 1, 0, 0, 19
>
>
> Computer Information -
> Name NAME
> Microsoft Windows 2000 5.0
> Service Pack 4
>
> Adapter 0 Information -
> Chip Model SI-3512
> Chip Revision 0001
> Chip Type RAID
> Driver Status 1
> Major Version 2
> Minor Version 2
> File Version 1, 0, 0, 51
> File Date Fri Aug 27 16:18:50 2004
> PCI IRQ 17
> PCI Bus Number 2
> PCI Device Number 13
>
> Primary Channel Information -
> IDE Base Address UNKNOWN
> Alt Base Address UNKNOWN
> DMA Base Address UNKNOWN
>
> Master Device Information -
> Master Not Present!!!
>
> Secondary Channel Information -
> IDE Base Address UNKNOWN
> Alt Base Address UNKNOWN
> DMA Base Address UNKNOWN
>
> Master Device Information -
> Master Not Present!!!
>
> RIO information -
> Major revision 2
> Minor revision 0
> Array conflicts No
> Number of sets 0
>
> ***
>
> Error Log:
>
> 14-February-2005 09:34.07 SATARaid Event Logger Started
> 14-February-2005 09:34.07 SATARaid Event writer starting up.
> 14-February-2005 14:22.20 Error - Device remove
> The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
> 14-February-2005 14:22.20 Warning - Member dropped
> Set 0 dropped Channel 1 Device device on adapter 0 due to a port
> error. SRB status was Device Selection Timed Out.
> 14-February-2005 14:22.21 Error - Device remove
> The Channel 0 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
> 14-February-2005 14:22.28 Informational - New device
> The Channel 0 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
> device.
> 15-February-2005 11:29.32 SATARaid Event Logger Started
> 15-February-2005 11:29.32 SATARaid Event writer starting up.
> 15-February-2005 09:09.55 Informational - Rebuild started
> Set 0 started a rebuild for Channel 1 Device device on adapter 0.
> 15-February-2005 09:15.02 Error - Device remove
> The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
> 15-February-2005 09:15.02 Warning - Member dropped
> Set 0 dropped Channel 1 Device device on adapter 0 due to a port
> error. SRB status was Device Selection Timed Out.
> 15-February-2005 09:15.08 Informational - New device
> The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
> device.
> 15-February-2005 09:15.08 Informational - Rebuild started
> Set 0 started a rebuild for Channel 1 Device device on adapter 0.
> 15-February-2005 11:29.02 Error - Device remove
> The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
> 15-February-2005 11:29.02 Warning - Member dropped
> Set 0 dropped Channel 1 Device device on adapter 0 due to a port
> error. SRB status was Device Selection Timed Out.
> 15-February-2005 11:29.14 Informational - New device
> The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
> device.
> 15-February-2005 11:29.14 Informational - Rebuild started
> Set 0 started a rebuild for Channel 1 Device device on adapter 0.
> 15-February-2005 11:30.50 Error - Device remove
> The Channel 0 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
> 15-February-2005 11:30.50 Warning - Port Error - Device
> Selection Timed Out
> Error ocurred on Channel 0 Device device on adapter 0. Channel 0
> Device - CDB 28 00 00 01 7b 00 00 00 80 00
> 15-February-2005 11:30.50 Warning - Member dropped
> Set 0 dropped Channel 1 Device device on adapter 0 due to a port
> error. SRB status was Success.
> 15-February-2005 11:30.50 Error - Device remove
> The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, was removed.
> 15-February-2005 11:30.54 Informational - New device
> The Channel 0 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
> device.
> 15-February-2005 11:30.55 Informational - New device
> The Channel 1 Device on adapter 0, WDC WD1200SD-01KCB0, is the new
> device.
> 15-February-2005 11:30.55 Informational - Rebuild started
> Set 0 started a rebuild for Channel 1 Device device on adapter 0.
> 15-February-2005 16:01.30 SATARaid Event Logger Started
> 15-February-2005 16:01.30 SATARaid Event writer starting up.
> 15-February-2005 16:07.01 SATARaid Event Logger Started
> 15-February-2005 16:07.01 SATARaid Event writer starting up.
> 15-February-2005 16:16.32 SATARaid Event Logger Started
> 15-February-2005 16:16.32 SATARaid Event writer starting up.
> 15-February-2005 17:54.42 SATARaid Event Logger Started
> 15-February-2005 17:54.42 SATARaid Event writer starting up.
> 16-February-2005 11:36.28 SATARaid Event Logger Started
> 16-February-2005 11:36.28 SATARaid Event writer starting up.

--
--John
Reply to jclarke at ae tee tee global dot net
(was jclarke at eye bee em dot net)
!