Sign in with
Sign up | Sign in
Your question

Hung installation

Tags:
Last response: in Windows 7
Share
December 21, 2010 5:06:28 PM

So, here's the original specs of this "new" system:

CPU: Intel Core 2 Duo E8500 w/ DangerDen TDX-775 liquid cooling block
Motherboard: Asus P5N-D
Memory: 4x CORSAIR 2Gb DDR2 667 (PC2 5300) 240 pin SDRAM sticks
Video: 2x BFG nVidia GeForce 8800GTX w/ DangerDen liquid cooling blocks
LSI Logic Ultra 320 PCI-X Card w/MPTBIOS 5.07.02
Hard Drives:
Ultra320 - 2x HP 36Gb 15000 RPM
Ultra320 - 1x Fujitsu 36Gb 15000 RPM
SATA - 1x 2Tb Seagate
SATA - 1x 500Gb Maxtor
SATA - 1x 640Gb Maxtor
IDE - 1x 250Gb Maxtor
Optical: LG SuperMulti CD/DVD
PSU: PC Power & Cooling 1kw, SLI Certified
And of course all the other cooling stuff (pump, reservoir, fans/radiator, etc.)
Also have the cooling fan mounted to the chipset heatsink.

Only reason for all the drives is that they used to be on a Windows Home Server that is no longer up, and I need to pull all the data out of the [x]:\DE directories once I get this system up. The 640Gb and 2Tb SATA drives are brand new with no data on them at all. Plan is to remove the SCSI devices, and the IDE drive once I've got the data off them.

Trying to install Windows 7 Ultimate 64 bit, with every device plugged in, I can get through the initial bootup without issues, goes through the process of asking me what drive to install on, expands the files, etc. After that, it reboots... And never gets past the "Starting Windows" screen. I let it go in safe mode all night last night, and eventually, it got into safe mode, but of course it can't complete an install.

So, removed the second video card, removed the SCSI card (and disconnected all three of those drives from power), disconnected the IDE drive, tried all four individual RAM chips in all four separate slots (thereby suggested, though not proving, that RAM is not the cause; I don't have any other machines that take these kinds of chips, so I can't memtest them on another computer).

Ultimately, it fails at the same spot every time - loading classpnp.sys.

I've tweaked everything I can think of in the BIOS. Disabled RAID. Set everything for compatibility mode. Tried a 700w power supply brand new out of box. Disconnected every drive except the 2Tb drive trying to install to. Same problem every time.

Even to be safe, instead of using this disk I bough from a local store, I tried another that came with my other computer, and same error there.

Any suggestions?

More about : hung installation

December 22, 2010 11:29:54 PM

Found first problem... Was all four RAM sticks.

Got new RAM that wasn't so budget, and it booted. Now has all 8Gb functional on this PSU/CPU/Motherboard, single GPU (haven't put the second GPU in yet). Installed on the SATA drive, then subsequently added the second and third SATA drive then the IDE drive. No problems thus far.

Added the LSI20320-R SCSI card back in, and back to where I was. Hangs on classpnp.sys when trying to boot in safe mode. In regular startup, hangs on "Starting Windows" Remove the card? No problem.

I added the actual drivers from lsi.com into %windir%\inf (the directory of the DevicePath key in the [HKLM\Software\Microsoft\Windows\CurrentVersion), renaming the old lsi_scsi.inf to lsi_scsi-old.inf and making sure that wouldn't be the problem. When trying to do a repair boot, it gave me a "bad driver failure" before I changed the drivers in the inf directory, and voila, after the driver change in the inf directory, I still get the same error in the boot repair menu.

I disabled the BIOS on the card because I don't intend to boot from any of those drives, and it had no effect. I also tried disabling the hook on boot. Neither worked.

Any suggestions for working with the LSI 20320-R?
!