Sign in with
Sign up | Sign in
Your question

Cannot turn on wifi(wifi settings on pc greyed out) after installing W

Last response: in Windows 8
Share
November 12, 2012 3:59:17 AM

Hello,

Just installed windows 8 and now i am unable to turn on wifi (hence not detecting wifi networks). I have a HP Pavilion g6 laptop with wifi network adapter shown as Broadcom 4313Gn. Tried installing windows 8 drivers from hp for the adapter, yet still doesn't work. Anyone found a solution?

More about : turn wifi wifi settings greyed installing

a b \ Driver
a b * Windows 8
November 12, 2012 5:47:03 AM

What is the full model number of the laptop? It's probably just missing the wireless driver, but unless the full model is given we won't be able to provide much help.
m
0
l
November 12, 2012 9:02:00 AM

The full model would be HP Pavilion g6 2141ex. I tried the windows 8 driver on HP site, yet still doesnt work.
m
0
l
Related resources
November 13, 2012 4:06:04 AM

I contacted the HP support centre, from which the instructed my network card would be broadcom. However i tried all drivers, still no luck. In addition on the device manager it shows as Broadcom adapter.
m
0
l
a b \ Driver
a b * Windows 8
November 13, 2012 6:21:53 AM

They also had a Windows 7 support page. Give the Windows 7 drivers a shot.
m
0
l
a b \ Driver
a b * Windows 8
November 13, 2012 11:28:03 PM

Any chance you have your ethernet cable connected at the same time?
m
0
l
a b \ Driver
a b * Windows 8
November 14, 2012 12:04:04 AM

Wouldn't matter. You can still connect to a wifi even if a wired connection is active.
m
0
l
a b \ Driver
a b * Windows 8
November 14, 2012 12:10:19 AM

Is there a wifi switch on your laptop?
m
0
l
a b \ Driver
a b * Windows 8
November 14, 2012 12:55:34 AM

user manual page 10 see if your wireless light is white then page 16 for wireless settings also do you have a ? mark under the peripheral for wireless
m
0
l
a b \ Driver
a b * Windows 8
November 14, 2012 1:21:37 AM

One of the changes for windows 8 is to disable your slower link when a faster one becomes available. That is why I asked if the Ethernet cable was plugged in.
If you want both networks then you need to make a policy change/registry change to disable this new feature.
m
0
l
a b \ Driver
a b * Windows 8
November 14, 2012 2:45:58 AM

I have windows 8 running on an Asus G53SW laptop with both the wireless and LAN connections active at the same time.

I know the group policy entry you are referring to. It does not shut the other link off but rather stops an automatic connection attempt when a faster connection already exists. For example, if a Gigabit LAN adapter is connected to a network, and a Wireless N connection is attempting to connect to the same access point, the policy will prevent the Wireless from automatically connecting to the slower wifi network. It does not disable the adapter, or disconnect an active connection. It also does not prevent the user from initiating a connection manually.

Edit: The "Minimize the number of simultaneous connections to the Internet or a Windows domain" policy states:

"If this policy setting is enabled, when the computer has at least one active connection to the Internet, a new automatic connection attempt to the Internet is blocked. When the computer has at least one active connection to a Windows domain, a new automatic connection to the same Windows domain is also blocked. Additional manual connection attempts by users to the Internet or to a Windows domain are not blocked by this policy setting."

This policy is assumed Enabled when either set to Enabled, or Not Configured.
m
0
l
November 14, 2012 3:35:18 AM

No wifi switch exists, only a button on the keyboard, which is always showing an orange light, and not working at all.
m
0
l
a b \ Driver
a b * Windows 8
November 14, 2012 4:26:07 PM

The_Prophecy said:
I have windows 8 running on an Asus G53SW laptop with both the wireless and LAN connections active at the same time.

I know the group policy entry you are referring to. It does not shut the other link off but rather stops an automatic connection attempt when a faster connection already exists. For example, if a Gigabit LAN adapter is connected to a network, and a Wireless N connection is attempting to connect to the same access point, the policy will prevent the Wireless from automatically connecting to the slower wifi network. It does not disable the adapter, or disconnect an active connection. It also does not prevent the user from initiating a connection manually.

Edit: The "Minimize the number of simultaneous connections to the Internet or a Windows domain" policy states:

"If this policy setting is enabled, when the computer has at least one active connection to the Internet, a new automatic connection attempt to the Internet is blocked. When the computer has at least one active connection to a Windows domain, a new automatic connection to the same Windows domain is also blocked. Additional manual connection attempts by users to the Internet or to a Windows domain are not blocked by this policy setting."

This policy is assumed Enabled when either set to Enabled, or Not Configured.



It was a simple, very easy to answer question: is the ethernet cable plugged in? I asked this because you can have settings that turn off your wireless adapter when a ethernet cable gets plugged into a wired port.
For example, control panel, device manager, check the advanced properties for a setting like "Disable upon Wired connect"
under for your wireless card. I would not bother to check this if I had not connected a ethernet cable
Which is why I asked the diagnostic question " do you have a ethernet cable plugged in"
m
0
l
November 14, 2012 10:59:58 PM

I found the solution. None of the above worked. What I did was uninstall the driver software in the device manager and when prompted clicked on delete software, and reinstalled twice until Boradcom #3 driver got installed and now it works. Seems like a number if preinstalled drivers exist in windows 8.
m
0
l
a b \ Driver
a b * Windows 8
November 15, 2012 12:19:00 AM

now your wireless light on the keyboard is white
m
0
l
!