Sign in with
Sign up | Sign in
Your question

Canon A75: Won't turn on

Last response: in Computer Peripherals
Share
October 12, 2004 5:52:00 AM

Archived from groups: alt.comp.periphs.dcameras (More info?)

I bought a new Canon A75 a few weeks ago and it has worked great until
yesterday. I was shooting some pics off an on, turning it off each
time I was done, and I went to turn it on to shoot some more pics and
it would not turn on. I also noticed that the lens was not retracted
into the camera body like it normall does when it's turned off, and the
lens cover was also open. I tried new batteries (several sets) and
removing the CF card, but it will not power on.

This afternoon I tried something new. I put the mode switch into
'Playback' mode and the pressed the on/off button while I was also
depressing the 'Set' button. The lens fully retracted into the cmaera
body and the lens cover closed. But it still will not turn on. The
rear LCD stays dark. If I turn it on in 'Shooting' mode, the lens
partially extends the first time I press the on button. If I press it
a second time, the lens come out a little further and the lens cover
opens. If I press the on button again, the lens restracts a bit and
the lens cover partially closes.

I called Canon and they told me I need to send it to them for warranty
repair.

Any ideas or suggestions?

Thanks.

More about : canon a75 turn

Anonymous
October 12, 2004 6:01:07 AM

Archived from groups: alt.comp.periphs.dcameras (More info?)

Yea... send it to them for warranty repair.


"Bob" <am_dew@REMOVepanixThis.com> wrote in message
news:ckfdc0$c0f$1@reader2.panix.com...
>
> I bought a new Canon A75 a few weeks ago and it has worked great until
> yesterday. I was shooting some pics off an on, turning it off each
> time I was done, and I went to turn it on to shoot some more pics and
> it would not turn on. I also noticed that the lens was not retracted
> into the camera body like it normall does when it's turned off, and the
> lens cover was also open. I tried new batteries (several sets) and
> removing the CF card, but it will not power on.
>
> This afternoon I tried something new. I put the mode switch into
> 'Playback' mode and the pressed the on/off button while I was also
> depressing the 'Set' button. The lens fully retracted into the cmaera
> body and the lens cover closed. But it still will not turn on. The
> rear LCD stays dark. If I turn it on in 'Shooting' mode, the lens
> partially extends the first time I press the on button. If I press it
> a second time, the lens come out a little further and the lens cover
> opens. If I press the on button again, the lens restracts a bit and
> the lens cover partially closes.
>
> I called Canon and they told me I need to send it to them for warranty
> repair.
>
> Any ideas or suggestions?
>
> Thanks.
!