Sign in with
Sign up | Sign in
Your question

Direct mpeg2 capture problems

Last response: in Graphics & Displays
Share
Anonymous
April 1, 2004 6:28:13 PM

Archived from groups: rec.video.desktop (More info?)

I wonder if anybody can help me out with a problem I'm having when
capturing miniDV video directly to mpeg2 using Ulead Video Studio 7.

I have an HP a350n pc, which uses a P4 2.8c cpu, 512Mb of pc3200 RAM,
and I have two 160Gb 7200rpm hard drives installed. DMA is enabled. I
take care to run the absolute minimum of programs, with antivirus and
other utilities disabled. Task manager typically shows 26 processes
running.

I find that the DV transcode buffer fills up and has to flush after
only about 4 minutes of video capture from my JVC miniDV camcorder. It
takes about 3 minutes to flush 2727 frames. Using task manager, I can
see that the cpu is working at about 85%.

I know that I can import footage as avi files without any problems,
and then transcode that to mpeg2 separately. I have discovered,
however, that the finished video quality taking that course of action
is actually slightly inferior to that obtained using direct mpeg2
capture, even using identical best quality settings. In particular,
there's noticeably less anti-aliasing on rapidly moving sections for
the direct-to-mpeg2 footage.

I'm trying to capture at the highest quality, using variable bitrate
set to the maximum DVD compliant 8264Kbs, with the quality slider in
the video capture properties dialogue box all the way over to the
right. Setting it to constant bitrate doesn't change things much - I
can still only capture about 4 minutes of video before the DV
transcode buffer has to flush. The disruption shows up on the mpeg2
video, too, and I don't like to have my camcorder on pause for any
extended period of time.

My hard drives have plenty of free space, and I keep them defragged on
a regular basis.

If I set the quality slider to the left, it does capture for longer,
but I find the resultant video quality unnacceptable.

Any ideas on how I can extend my capture time?


Thanks in advance for any advice offered,

C Toast
Anonymous
April 1, 2004 10:44:45 PM

Archived from groups: rec.video.desktop (More info?)

"C Toast" <ctoast@650dialup.com> wrote in message
news:9e361f93.0404011428.4ceca237@posting.google.com...
> I wonder if anybody can help me out with a problem I'm having when
> capturing miniDV video directly to mpeg2 using Ulead Video Studio 7.
>
> I have an HP a350n pc, which uses a P4 2.8c cpu, 512Mb of pc3200 RAM,
> and I have two 160Gb 7200rpm hard drives installed. DMA is enabled. I
> take care to run the absolute minimum of programs, with antivirus and
> other utilities disabled. Task manager typically shows 26 processes
> running.
>
> I find that the DV transcode buffer fills up and has to flush after
> only about 4 minutes of video capture from my JVC miniDV camcorder. It
> takes about 3 minutes to flush 2727 frames. Using task manager, I can
> see that the cpu is working at about 85%.
>
> I know that I can import footage as avi files without any problems,
> and then transcode that to mpeg2 separately. I have discovered,
> however, that the finished video quality taking that course of action
> is actually slightly inferior to that obtained using direct mpeg2
> capture, even using identical best quality settings. In particular,
> there's noticeably less anti-aliasing on rapidly moving sections for
> the direct-to-mpeg2 footage.
>
> I'm trying to capture at the highest quality, using variable bitrate
> set to the maximum DVD compliant 8264Kbs, with the quality slider in
> the video capture properties dialogue box all the way over to the
> right. Setting it to constant bitrate doesn't change things much - I
> can still only capture about 4 minutes of video before the DV
> transcode buffer has to flush. The disruption shows up on the mpeg2
> video, too, and I don't like to have my camcorder on pause for any
> extended period of time.
>
> My hard drives have plenty of free space, and I keep them defragged on
> a regular basis.
>
> If I set the quality slider to the left, it does capture for longer,
> but I find the resultant video quality unnacceptable.
>
> Any ideas on how I can extend my capture time?
>
>
> Thanks in advance for any advice offered,
>
> C Toast

Your system seems adequate, but I saw no mention of the
hardware you are using to connect your camera, while that's
not likely your problem, it could play a role in a solution.
There is some problem, as you should be able to capture to
DVD compliant MPEG with a good software encoder. I am
more of a hardware real-time encoder guy myself, but the SW
encoders out now combined with a +2000Mhz processor are
quite capable. While Ulead has a good rep, it may be the source
of the problem.

Luck;
Ken
Anonymous
April 2, 2004 2:41:33 AM

Archived from groups: rec.video.desktop (More info?)

C Toast wrote:

> I wonder if anybody can help me out with a problem I'm having
>

Yup.

>
> My hard drives have plenty of free space, and I keep them defragged on
> a regular basis.

If you have plenty of free space, I guesse I have to question why you are
encoding to mpeg2 while capturing.


> Any ideas on how I can extend my capture time?
>

Don't encode while capturing.

>
> Thanks in advance for any advice offered,
>

I suggest capturing as DV instead of mpeg and encode it after you edit it.
Related resources
Anonymous
April 2, 2004 5:26:03 AM

Archived from groups: rec.video.desktop (More info?)

Greetings,
For what it's worth, I have had no success in direct capture to mpeg
using Ulead DVD Workshop. But have no problem encoding with the same after
capturing dv avi to harddrive.

"C Toast" <ctoast@650dialup.com> wrote in message
news:9e361f93.0404011428.4ceca237@posting.google.com...
> I wonder if anybody can help me out with a problem I'm having when
> capturing miniDV video directly to mpeg2 using Ulead Video Studio 7.
>
> I have an HP a350n pc, which uses a P4 2.8c cpu, 512Mb of pc3200 RAM,
> and I have two 160Gb 7200rpm hard drives installed. DMA is enabled. I
> take care to run the absolute minimum of programs, with antivirus and
> other utilities disabled. Task manager typically shows 26 processes
> running.
>
> I find that the DV transcode buffer fills up and has to flush after
> only about 4 minutes of video capture from my JVC miniDV camcorder. It
> takes about 3 minutes to flush 2727 frames. Using task manager, I can
> see that the cpu is working at about 85%.
>
> I know that I can import footage as avi files without any problems,
> and then transcode that to mpeg2 separately. I have discovered,
> however, that the finished video quality taking that course of action
> is actually slightly inferior to that obtained using direct mpeg2
> capture, even using identical best quality settings. In particular,
> there's noticeably less anti-aliasing on rapidly moving sections for
> the direct-to-mpeg2 footage.
>
> I'm trying to capture at the highest quality, using variable bitrate
> set to the maximum DVD compliant 8264Kbs, with the quality slider in
> the video capture properties dialogue box all the way over to the
> right. Setting it to constant bitrate doesn't change things much - I
> can still only capture about 4 minutes of video before the DV
> transcode buffer has to flush. The disruption shows up on the mpeg2
> video, too, and I don't like to have my camcorder on pause for any
> extended period of time.
>
> My hard drives have plenty of free space, and I keep them defragged on
> a regular basis.
>
> If I set the quality slider to the left, it does capture for longer,
> but I find the resultant video quality unnacceptable.
>
> Any ideas on how I can extend my capture time?
>
>
> Thanks in advance for any advice offered,
>
> C Toast
Anonymous
April 2, 2004 7:44:07 PM

Archived from groups: rec.video.desktop (More info?)

"C Toast" <ctoast@650dialup.com> wrote in message
news:9e361f93.0404011428.4ceca237@posting.google.com...
> I know that I can import footage as avi files without any problems,
> and then transcode that to mpeg2 separately. I have discovered,
> however, that the finished video quality taking that course of action
> is actually slightly inferior to that obtained using direct mpeg2
> capture, even using identical best quality settings. In particular,
> there's noticeably less anti-aliasing on rapidly moving sections for
> the direct-to-mpeg2 footage.

This is particularly unusual since realtime MPEG-2 encoding in SW is usually
low quality.

> I'm trying to capture at the highest quality, using variable bitrate
> set to the maximum DVD compliant 8264Kbs, with the quality slider in
> the video capture properties dialogue box all the way over to the
> right. Setting it to constant bitrate doesn't change things much - I
> can still only capture about 4 minutes of video before the DV
> transcode buffer has to flush. The disruption shows up on the mpeg2
> video, too, and I don't like to have my camcorder on pause for any
> extended period of time.

Try capturing to AVI and use Tmpgenc to reencode to MPEG-2 using 2 pass
encoding.
!