Sign in with
Sign up | Sign in
Your question

Network setup help

Last response: in Wireless Networking
Share
Anonymous
a b F Wireless
September 14, 2004 10:03:03 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

I am a former IT person who has been "out of the loop" for a few years. Any
suggestions that anyone could offer would be MOST appreciated...

I have a small home network (1 desktop PC, Windows XP, Ethernet; 1 laptop,
Windows XP, wireless - 'excellent' connection status) that is connected to
the internet through a wireless broadband router using DSL. Both computers
can access the internet connection without any problem. I am unable to 'see'
either computer on the network from the other one, however. Both PCs are set
up on the same workgroup name, and the network setup wizard has run
successfully on both machines. My desktop can see the entire network, but
can't access the network share on my laptop. The laptop recognizes the
network but can't access it.

I have tried pinging both machines from the other ones, without success.
Both machines ping the network gateway (the router) without any difficulty.
Are there some access permissions that I need to manually set? Or am I
missing something else entirely? I really need to be able to share files and
printers between the two but feel like I am at the end of my proverbial rope!

More about : network setup

Anonymous
a b F Wireless
September 14, 2004 7:19:01 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

I am having the same problem tring to setup a wireless printserver. So when
you get any answer can you please forward them to me.

Thanks

"kamuish" wrote:

> I am a former IT person who has been "out of the loop" for a few years. Any
> suggestions that anyone could offer would be MOST appreciated...
>
> I have a small home network (1 desktop PC, Windows XP, Ethernet; 1 laptop,
> Windows XP, wireless - 'excellent' connection status) that is connected to
> the internet through a wireless broadband router using DSL. Both computers
> can access the internet connection without any problem. I am unable to 'see'
> either computer on the network from the other one, however. Both PCs are set
> up on the same workgroup name, and the network setup wizard has run
> successfully on both machines. My desktop can see the entire network, but
> can't access the network share on my laptop. The laptop recognizes the
> network but can't access it.
>
> I have tried pinging both machines from the other ones, without success.
> Both machines ping the network gateway (the router) without any difficulty.
> Are there some access permissions that I need to manually set? Or am I
> missing something else entirely? I really need to be able to share files and
> printers between the two but feel like I am at the end of my proverbial rope!
Anonymous
a b F Wireless
September 14, 2004 9:21:04 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

I'm having the same problem. Only difference I have is the Wireless Laptop
in XP-Pro and the Desktop is XP-Home.

"schmidty007" wrote:

> I am having the same problem tring to setup a wireless printserver. So when
> you get any answer can you please forward them to me.
>
> Thanks
>
> "kamuish" wrote:
>
> > I am a former IT person who has been "out of the loop" for a few years. Any
> > suggestions that anyone could offer would be MOST appreciated...
> >
> > I have a small home network (1 desktop PC, Windows XP, Ethernet; 1 laptop,
> > Windows XP, wireless - 'excellent' connection status) that is connected to
> > the internet through a wireless broadband router using DSL. Both computers
> > can access the internet connection without any problem. I am unable to 'see'
> > either computer on the network from the other one, however. Both PCs are set
> > up on the same workgroup name, and the network setup wizard has run
> > successfully on both machines. My desktop can see the entire network, but
> > can't access the network share on my laptop. The laptop recognizes the
> > network but can't access it.
> >
> > I have tried pinging both machines from the other ones, without success.
> > Both machines ping the network gateway (the router) without any difficulty.
> > Are there some access permissions that I need to manually set? Or am I
> > missing something else entirely? I really need to be able to share files and
> > printers between the two but feel like I am at the end of my proverbial rope!
Related resources
September 15, 2004 12:55:04 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

kamuish thought carefully and wrote on 9/14/2004 6:03 AM:
> I am a former IT person who has been "out of the loop" for a few years. Any
> suggestions that anyone could offer would be MOST appreciated...
>
> I have a small home network (1 desktop PC, Windows XP, Ethernet; 1 laptop,
> Windows XP, wireless - 'excellent' connection status) that is connected to
> the internet through a wireless broadband router using DSL. Both computers
> can access the internet connection without any problem. I am unable to 'see'
> either computer on the network from the other one, however. Both PCs are set
> up on the same workgroup name, and the network setup wizard has run
> successfully on both machines. My desktop can see the entire network, but
> can't access the network share on my laptop. The laptop recognizes the
> network but can't access it.
>
> I have tried pinging both machines from the other ones, without success.
> Both machines ping the network gateway (the router) without any difficulty.
> Are there some access permissions that I need to manually set? Or am I
> missing something else entirely? I really need to be able to share files and
> printers between the two but feel like I am at the end of my proverbial rope!

Clean off any spyware/adware/viruses using Spybot Search & Destroy AND
Ad-Aware w/ VX plugin AND your favorite antivirus.

The following two short articles are the basics for File & Printer
Sharing for WinXP. Take a quick glance through these to see if you've
missed anything.

Windows XP Professional File Sharing
By Ron Lowe and Steve Winograd
December 12, 2001
<http://www.practicallynetworked.com/sharing/xp_fileshar...;

Windows XP Simple File Sharing
<http://www.practicallynetworked.com/sharing/xp/fileshar...;

Otherwise, here's some stuff I pasted together from earlier posts.

You don't say if you have XP Home or Pro, Service Pack 1 or 2. I'm
assuming you cannot see any workgroup in My Network Places/Entire
Network/Microsoft Windows Network and can't open up the folders.
However, the internet works fine for everyone, you've run Network Setup
Wizard a few times and you have set some folders for sharing (folder
icon with hand underneath).

Check your firewall settings if you have one, or since you're behind a
router, disable or even uninstall the firewall. The exact settings
depend on the firewall software, but may say something like "Put local
network in trusted zone" or "Enable File and Printer Sharing". My
Windows Firewall is set to allow ports 139 & 445 (TCP) and 137 & 138
(UDP) only for my local network (ie, Scope = subnet)

If the firewall is set correctly then the firewall is allowing the
computers talk to each other for file sharing. Next, check to see if
each computer has the necessary services/protocols running for file and
printer sharing:

Check if the "Computer Browser" and "TCP/IP NetBIOS Helper" services
have started and are set to automatic (start/run, type services.msc, hit
return).

Check that "Client for MS Networks" and "File and Printer Sharing" are
installed and enabled in Network Properties (Control Panel/Network
Connections/right-click on Local Area Connection, select Properties).

Check that NetBIOS is enabled in Advanced TCP/IP Settings. Again, go to
Network Properties, highlight "Internet Protocol (TCP/IP)", click
Properties button, click Advanced button. Click WINS tab, check "Enable
NetBIOS over TCP/IP"

Check that "TCP/IP Filtering" is not enabled and set to "Permit All". Go
to Advanced TCP/IP settings, click on Options tab, highlight "TCP/IP
filtering", click Properties button. Check "Permit All", UNcheck "Enable
TCP/IP Filtering (All adapters)".

*****
[the following is courtesy of Steve Winograd]
Run "ipconfig /all" and look at the "Node Type" at the beginning of
the output. If it says "Peer-to-Peer" (which should actually be
"Point-to-Point") that's the problem. It means that the computer only
uses a WINS server, which isn't available on a peer-to-peer network,
for NetBIOS name resolution.

If that's the case, run the registry editor, open this key:
HLM\System\CurrentControlSet\Services\Netbt\Parameters
and delete these values if they're present:
NodeType
DhcpNodeType
Reboot, then try network access again.

If that doesn't fix it, open that registry key again, create a DWORD
value called "NodeType", and set it to 1 for "Broadcast" or 4 for
"Mixed".

For details, see these Microsoft Knowledge Base articles:

Default Node Type for Microsoft Clients
http://support.microsoft.com/default.aspx?scid=kb;en-us;160177

TCP/IP and NBT Configuration Parameters for Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;314053
*****

The steps above establish the necessary services/protocols required for
File and Printer Sharing. The steps below give the computers permission
to share files and printers (courtesy of Chuck):

*****
On any XP Pro computer, check to see if Simple File Sharing (Control
Panel - Folder Options - View - Advanced settings) is enabled or
disabled. With XP Home and Pro together, you need to have SFS properly
set on each computer.

With XP Pro, if SFS is disabled, check the Local Security Policy
(Control Panel - Administrative Tools). Under Local Policies - Security
Options, look at "Network access: Sharing and security model", and
ensure it's set to "Classic - local users authenticate as themselves".

With XP Pro, if you set the Local Security Policy to "Guest only", make
sure that the Guest account is enabled, thru Local User Manager (Start -
Run - "lusrmgr.msc"), and has an identical, non-blank, password on all
computers. If "Classic", setup and use a common non-Guest account, with
identical, non-blank, password on all computers.

For XP Home, OR for XP Pro with Simple File Sharing enabled, make sure
that the Guest account is enabled (for XP Pro, thru Local User Manager
(Start - Run - "lusrmgr.msc")), on each computer.
*****

All of these steps - firewall setting, services/protocols, permissions -
should have your home network running perfectly. If not, then there is a
deeper problem. That deeper problem could be from
adware/spyware/viruses, improperly uninstalled software or just sloppy
programming.

The following steps reset Winsock and the TCP/IP stack. They may break
certain software on your computer - just uninstall/re-install the
software again after these steps are complete.

Microsoft Knowledge Base Article - 811259
How to determine and recover from Winsock2 corruption
<http://support.microsoft.com/default.aspx?scid=kb;en-us;811259&Product=winxp>

How to reset Internet Protocol (TCP/IP) in Windows XP
Microsoft Knowledge Base Article - 299357
<http://support.microsoft.com/default.aspx?scid=kb;en-us;299357&Product=winxp>

Hope this helps,

Lance
*****
Anonymous
a b F Wireless
September 16, 2004 12:59:07 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Thanks for the suggestions... as it turns out I actually found the solution
to my own problem. After reading so much about firewalls on this forum, I
got to thinking... I had only been thinking about the firewall in the sense
of blocking non-local traffic. As soon as I disabled the firewall program
running on each of my machines, I could ping without any difficulty at all.
Upon re-enabling the firewall, I simply had to enter the network IP for each
machine in the other machine's firewall's "allow" list. Now everything works
like a champ!

As far as the other requests posted on this thread are concerned, check your
either your commercial firewall program or Windows firewall to see if they
are blocking local traffic. Disable the firewall program and then try
pinging from the opposite machine (you can find the machine's IP by entering
the command 'ipconfig' at the command prompt, or by finding your network
adapter on the network connections control panel and selecting the 'Support'
tab). If you can ping successfully after disabling the firewall, just
re-enable your firewall and add the IP address for the firewall that was
blocking your traffic...
Anonymous
a b F Wireless
September 20, 2004 3:05:04 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Folks,
I read kamuish's message and all follow-up and it looks like that I have
exactly the same problem. I have 2 desktops (Win XP Home), one (host)
connected to the DSL router and another one (guest) communicating via
wireless connection. Both access internet fine, and Host sees the Guest, but
Guest does not see the network at all -- I see a weird message "You might not
have permission to use this network resource, blah-blah". Network setup
wizard ran fine on both. After reading people's comments I certainly suspect
a firewall blocking local traffic. I assume this is Windows firewall as I
haven't installed anything else on these PCs. Could you pls describe a bit in
more detail how to disable the firewall and enable this "allow" list kamuish
talked about? I am not very familiar with the way firewalls set up in XP.

"kamuish" wrote:

> I am a former IT person who has been "out of the loop" for a few years. Any
> suggestions that anyone could offer would be MOST appreciated...
>
> I have a small home network (1 desktop PC, Windows XP, Ethernet; 1 laptop,
> Windows XP, wireless - 'excellent' connection status) that is connected to
> the internet through a wireless broadband router using DSL. Both computers
> can access the internet connection without any problem. I am unable to 'see'
> either computer on the network from the other one, however. Both PCs are set
> up on the same workgroup name, and the network setup wizard has run
> successfully on both machines. My desktop can see the entire network, but
> can't access the network share on my laptop. The laptop recognizes the
> network but can't access it.
>
> I have tried pinging both machines from the other ones, without success.
> Both machines ping the network gateway (the router) without any difficulty.
> Are there some access permissions that I need to manually set? Or am I
> missing something else entirely? I really need to be able to share files and
> printers between the two but feel like I am at the end of my proverbial rope!
September 20, 2004 11:24:57 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Look in the section titled "After you install"
http://www.microsoft.com/windowsxp/sp2/default.mspx

Lance
*****

nickuh thought carefully and wrote on 9/20/2004 11:05 AM:

> Folks,
> I read kamuish's message and all follow-up and it looks like that I have
> exactly the same problem. I have 2 desktops (Win XP Home), one (host)
> connected to the DSL router and another one (guest) communicating via
> wireless connection. Both access internet fine, and Host sees the Guest, but
> Guest does not see the network at all -- I see a weird message "You might not
> have permission to use this network resource, blah-blah". Network setup
> wizard ran fine on both. After reading people's comments I certainly suspect
> a firewall blocking local traffic. I assume this is Windows firewall as I
> haven't installed anything else on these PCs. Could you pls describe a bit in
> more detail how to disable the firewall and enable this "allow" list kamuish
> talked about? I am not very familiar with the way firewalls set up in XP.
>
> "kamuish" wrote:
>
>
>>I am a former IT person who has been "out of the loop" for a few years. Any
>>suggestions that anyone could offer would be MOST appreciated...
>>
>>I have a small home network (1 desktop PC, Windows XP, Ethernet; 1 laptop,
>>Windows XP, wireless - 'excellent' connection status) that is connected to
>>the internet through a wireless broadband router using DSL. Both computers
>>can access the internet connection without any problem. I am unable to 'see'
>>either computer on the network from the other one, however. Both PCs are set
>>up on the same workgroup name, and the network setup wizard has run
>>successfully on both machines. My desktop can see the entire network, but
>>can't access the network share on my laptop. The laptop recognizes the
>>network but can't access it.
>>
>>I have tried pinging both machines from the other ones, without success.
>>Both machines ping the network gateway (the router) without any difficulty.
>>Are there some access permissions that I need to manually set? Or am I
>>missing something else entirely? I really need to be able to share files and
>>printers between the two but feel like I am at the end of my proverbial rope!
!