Sign in with
Sign up | Sign in
Your question

Movie Maker gives "class not registered"

Last response: in Windows XP
Share
February 14, 2005 1:29:06 PM

Archived from groups: microsoft.public.windowsxp.video (More info?)

WHY? It worked not a few months ago, I can't think of any changes made to
the computer. Grr.... is it a driver? I've SEARCHED and SEARCHED... but
nothing.

It's a JVC-DVL310 / with XP / Movie Maker [or Premiere, but premiere says
"Can't Activate Camcorder, Try Resetting] / with a firewire 1394 cable.

It worked a few months ago and I made a stunning DVD.
February 15, 2005 2:45:08 AM

Archived from groups: microsoft.public.windowsxp.video (More info?)

On the Start -> Run dialog enter the following line:

regsvr32 %windir%\system32\qdv.dll

and press the OK (also ok the resulting dialogs). Restart Windows Movie
Maker and try capturing the movie again.

--
Rehan
www.rehanfx.org - get transitions and effects for Windows Movie Maker



"ryan" <ryan@discussions.microsoft.com> wrote in message
news:0A570121-59CB-4252-B57B-32F4AE5AF120@microsoft.com...
> WHY? It worked not a few months ago, I can't think of any changes made to
> the computer. Grr.... is it a driver? I've SEARCHED and SEARCHED... but
> nothing.
>
> It's a JVC-DVL310 / with XP / Movie Maker [or Premiere, but premiere says
> "Can't Activate Camcorder, Try Resetting] / with a firewire 1394 cable.
>
> It worked a few months ago and I made a stunning DVD.
>
February 15, 2005 2:45:09 AM

Archived from groups: microsoft.public.windowsxp.video (More info?)

THANKS!... worked. But what did it do?
-ry

"Rehan" wrote:

> On the Start -> Run dialog enter the following line:
>
> regsvr32 %windir%\system32\qdv.dll
>
> and press the OK (also ok the resulting dialogs). Restart Windows Movie
> Maker and try capturing the movie again.
>
> --
> Rehan
> www.rehanfx.org - get transitions and effects for Windows Movie Maker
>
>
>
> "ryan" <ryan@discussions.microsoft.com> wrote in message
> news:0A570121-59CB-4252-B57B-32F4AE5AF120@microsoft.com...
> > WHY? It worked not a few months ago, I can't think of any changes made to
> > the computer. Grr.... is it a driver? I've SEARCHED and SEARCHED... but
> > nothing.
> >
> > It's a JVC-DVL310 / with XP / Movie Maker [or Premiere, but premiere says
> > "Can't Activate Camcorder, Try Resetting] / with a firewire 1394 cable.
> >
> > It worked a few months ago and I made a stunning DVD.
> >
>
>
>
Related resources
Anonymous
February 15, 2005 4:31:02 PM

Archived from groups: microsoft.public.windowsxp.video (More info?)

Re-registered the dll file in the Registry.
--
Cari (MS-MVP) Windows Client - Printing & Imaging
www.coribright.com

"ryan" <ryan@discussions.microsoft.com> wrote in message
news:D E145EE4-C62A-4E5B-B8E8-6A5FDFD74201@microsoft.com...
> THANKS!... worked. But what did it do?
> -ry
>
February 16, 2005 1:38:21 AM

Archived from groups: microsoft.public.windowsxp.video (More info?)

I am glad it worked. Most likely you had uninstalled some other video
related program. Some programs when uninstalled, unregister the DLLs without
realizing these may be used by other programs. This line re-registered the
particular DLL that is used by Movie Maker during capturing.

--
Rehan
www.rehanfx.org - get transitions and effects for Windows Movie Maker



"ryan" <ryan@discussions.microsoft.com> wrote in message
news:D E145EE4-C62A-4E5B-B8E8-6A5FDFD74201@microsoft.com...
> THANKS!... worked. But what did it do?
> -ry
>
> "Rehan" wrote:
>
>> On the Start -> Run dialog enter the following line:
>>
>> regsvr32 %windir%\system32\qdv.dll
>>
>> and press the OK (also ok the resulting dialogs). Restart Windows Movie
>> Maker and try capturing the movie again.
>>
>> --
>> Rehan
>> www.rehanfx.org - get transitions and effects for Windows Movie Maker
>>
>>
>>
>> "ryan" <ryan@discussions.microsoft.com> wrote in message
>> news:0A570121-59CB-4252-B57B-32F4AE5AF120@microsoft.com...
>> > WHY? It worked not a few months ago, I can't think of any changes made
>> > to
>> > the computer. Grr.... is it a driver? I've SEARCHED and SEARCHED...
>> > but
>> > nothing.
>> >
>> > It's a JVC-DVL310 / with XP / Movie Maker [or Premiere, but premiere
>> > says
>> > "Can't Activate Camcorder, Try Resetting] / with a firewire 1394 cable.
>> >
>> > It worked a few months ago and I made a stunning DVD.
>> >
>>
>>
>>
!